Announcement

Collapse
No announcement yet.

Two feeds in the same Raspberry

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HF_ATL
    replied
    Many thanks once more @abcd567

    Now all traces are gone, after reboot and typing those last command lines I got always "...service could not be found"

    Leave a comment:


  • abcd567
    replied
    Originally posted by HF_ATL View Post
    You're right. Better to start from a fresh install and avoid dealing with all of these issues.
    However by this time I'll not do it since it is working despite this issue. So it doesn't really matter

    Btw here is my output:
    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/nginx/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/.debhelper/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/.debhelper/generated/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/usr/share/doc/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/usr/share/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/usr/bin/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/etc/nginx/sites-available/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/etc/init.d/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/etc/logrotate.d/dump1090-mutability
    /run/dump1090-mutability
    find: ‘/run/user/1000/gvfs’: Permission denied
    /etc/nginx/sites-available/dump1090-mutability
    /etc/dump1090-mutability
    /etc/default/dump1090-mutability
    /etc/logrotate.d/dump1090-mutability

    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability2
    find: ‘/run/user/1000/gvfs’: Permission denied

    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability-2
    /usr/share/dump1090-mutability-2
    find: ‘/run/user/1000/gvfs’: Permission denied
    /etc/init.d/dump1090-mutability-2
    /etc/default/dump1090-mutability-2



    First disable the auto start of dump1090-mutability-2 at boot
    Code:
    sudo update-rc.d -f dump1090-mutability-2 remove 
    
    sudo systemctl daemon-reload

    Now remove all left-over garbage of dump1090-mutability/dump1090-mutability-2:
    Code:
    sudo rm -rf /run/dump1090-mutability
    sudo rm /etc/nginx/sites-available/dump1090-mutability
    sudo rm -rf /etc/dump1090-mutability
    sudo rm /etc/default/dump1090-mutability
    sudo rm /etc/logrotate.d/dump1090-mutability
    
    sudo rm -rf /usr/share/dump1090-mutability-2
    sudo rm /etc/init.d/dump1090-mutability-2
    sudo rm /etc/default/dump1090-mutability-2

    Now reboot and check
    Code:
    sudo reboot
    
    sudo systemctl status dump1090-mutability
    sudo systemctl status dump1090-mutability2
    sudo systemctl status dump1090-mutability-2
    
    sudo find / -name dump1090-mutability-2
    Last edited by abcd567; 2019-10-25, 17:08.

    Leave a comment:


  • HF_ATL
    replied
    Originally posted by abcd567 View Post
    HF_ATL:

    Oh, your output of "find" commands show that at some stage you have built dump1090-mutability from source code.

    The 2-receiver script does NOT build from source code. It downloads and installs the pre-built .deb package which I have built and uploaded to Github.
    Yes that makes sense since this system is running for some time and in the past I may have built dump1090-mutability from source code.

    Leave a comment:


  • abcd567
    replied
    HF_ATL:

    Oh, your output of "find" commands show that at some stage you have built dump1090-mutability from source code.

    The 2-receiver script does NOT build from source code. It downloads and installs the pre-built .deb package which I have built and uploaded to Github.
    Last edited by abcd567; 2019-10-25, 13:42.

    Leave a comment:


  • HF_ATL
    replied
    Originally posted by abcd567 View Post
    If HF_ATL has executed commands in my following post, then /etc/init.d/ files will be first disabled (note remove at the end of first 2 commands), then deleted also

    https://forum.flightradar24.com/thre...l=1#post129173

    The problem is not due to files generated by script. It is due to files with suffix -2, which are not generated by script, must have been done manually.
    I confirm that I have executed those commands.

    Leave a comment:


  • abcd567
    replied
    Originally posted by wiedehopf View Post
    Wait so it's generating it from the /etc/init.d/ files?
    That makes more sense, must have gotten it backwards.

    I have no clue which file you still have floating around and frankly it doesn't matter because the executable is no longer around.
    If HF_ATL has executed commands in my following post, then /etc/init.d/ files will be first disabled (note remove at the end of first 2 commands), then deleted also

    https://forum.flightradar24.com/thre...l=1#post129173

    The problem is not due to files generated by script. It is due to files with suffix -2, which are not generated by script, must have been done manually.
    Last edited by abcd567; 2019-10-25, 13:30.

    Leave a comment:


  • HF_ATL
    replied
    You're right. Better to start from a fresh install and avoid dealing with all of these issues.
    However by this time I'll not do it since it is working despite this issue. So it doesn't really matter

    Btw here is my output:
    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/nginx/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/.debhelper/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/.debhelper/generated/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/usr/share/doc/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/usr/share/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/usr/bin/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/etc/nginx/sites-available/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/etc/init.d/dump1090-mutability
    /home/pi/build-dump-mut/dump1090/debian/dump1090-mutability/etc/logrotate.d/dump1090-mutability
    /run/dump1090-mutability
    find: ‘/run/user/1000/gvfs’: Permission denied
    /etc/nginx/sites-available/dump1090-mutability
    /etc/dump1090-mutability
    /etc/default/dump1090-mutability
    /etc/logrotate.d/dump1090-mutability

    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability2
    find: ‘/run/user/1000/gvfs’: Permission denied

    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability-2
    /usr/share/dump1090-mutability-2
    find: ‘/run/user/1000/gvfs’: Permission denied
    /etc/init.d/dump1090-mutability-2
    /etc/default/dump1090-mutability-2

    Leave a comment:


  • abcd567
    replied
    Running the 2-receiver script for dump1090-fa AFTER re-imaging would have been much better as it wont have any left-over files of dump1090-mutability.

    Leave a comment:


  • abcd567
    replied
    Please note that the 2-receiver script does not generate dump1090-mutability-2, it generates dump1090-mutability2 (ie sufix 2 and not -2). It seems you have done some configuration manually.

    Here is the output on my 2-receiver install, which clearly shows dump1090-mutability-2 does not exist.

    Code:
    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability
    /etc/default/dump1090-mutability
    /etc/nginx/sites-available/dump1090-mutability
    /etc/logrotate.d/dump1090-mutability
    /etc/init.d/dump1090-mutability
    find: ‘/proc/12809’: No such file or directory
    find: ‘/proc/12985’: No such file or directory
    /usr/share/dump1090-mutability
    /usr/share/doc/dump1090-mutability
    /usr/bin/dump1090-mutability
    /run/dump1090-mutability
    
    
    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability2
    /etc/default/dump1090-mutability2
    /etc/init.d/dump1090-mutability2
    /run/dump1090-mutability2
    
    
    pi@raspberrypi:~ $ sudo find / -name dump1090-mutability-2
    pi@raspberrypi:~

    Leave a comment:


  • abcd567
    replied
    You can find left-over files location by command:

    Code:
    sudo find / -name dump1090-mutability
    sudo find / -name dump1090-mutability2
    sudo find / -name dump1090-mutability-2
    Last edited by abcd567; 2019-10-25, 13:08.

    Leave a comment:


  • wiedehopf
    replied
    Wait so it's generating it from the /etc/init.d/ files?
    That makes more sense, must have gotten it backwards.

    I have no clue which file you still have floating around and frankly it doesn't matter because the executable is no longer around.

    Leave a comment:


  • abcd567
    replied
    The dump1090-mutability's service file is generated by the system (systemd-sysv-generator) at boot from its init.d file "/etc/init.d/dump1090-mutability". The last set of commands I gave should remove this file for both instances. It must be left-over copy of service file which can be removed by command mentioned by weidehopf
    Code:
    sudo rm -f /lib/systemd/system/dump1090-mutability.service /etc/systemd/system/dump1090-mutability.service 
    
    sudo reboot
    You can find left-over file location by command:

    Code:
    sudo find / -name dump1090-mutability
    After this headache, do you realize it was better to re-image and then install dump1090-fa?
    Last edited by abcd567; 2019-10-25, 12:58.

    Leave a comment:


  • wiedehopf
    replied
    That's a 2nd service you must have created yourself. (note the -2)

    Remove it like this.

    sudo rm -f /lib/systemd/system/dump1090-mutability-2.service /etc/systemd/system/dump1090-mutability-2.service
    sudo reboot

    Removing the displayed file in init.d didn't help because it's generated from the service file.

    If you don't know what you are doing and have followed one guide unsuccessfully and don't know how to undo what you did, it's really best to start with a fresh image.

    Leave a comment:


  • HF_ATL
    replied
    Originally posted by wiedehopf View Post
    That's not running:


    But if you mind it we can remove the service files and it should be gone:

    sudo rm -f /lib/systemd/system/dump1090-mutability.service /etc/systemd/system/dump1090-mutability.service
    sudo reboot

    Anyway the snippet you showed just shows that it was running 2 days ago, not that it's running.
    So it doesn't really matter.

    Now I have the following output for the "sudo systemctl status dump1090-mutability":
    dump1090_mut.png

    Leave a comment:


  • wiedehopf
    replied
    That's not running:
    dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
    Loaded: loaded (/etc/init.d/dump1090-mutability; generated)
    Active: active (exited) since Wed 2019-10-23 14:10:49 WEST; 1 day 18h ago
    But if you mind it we can remove the service files and it should be gone:

    sudo rm -f /lib/systemd/system/dump1090-mutability.service /etc/systemd/system/dump1090-mutability.service
    sudo reboot

    Anyway the snippet you showed just shows that it was running 2 days ago, not that it's running.
    So it doesn't really matter.

    Leave a comment:

Working...
X