Announcement

Collapse
No announcement yet.

second receiver setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • second receiver setup

    i want to setup and run a second receiver with identical hardware at the same address to test before I move it to another seperate location.

    I am running FR24 on a Raspberry Pi 3
    I cloned my SD card from my existing receiver, and then ran fr24feed signup
    it seems to work but is using the same radar id as my existing station, how do I get a new radar id?

  • #2
    sudo fr24feed --signup
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Thanks, thats what I did, perhaps I should not re-use the sharing key? do I need to get a new one?

      Comment


      • #4
        If you cloned it the settings were already present and didn't need to re-run signup
        But Correct. Leave it blank = new.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          OK thanks I didnt enter a key and it now has a new radar code... but some other weird stuff happening.
          As I said i have 2 sets of identical hardware
          the original one has receiver "ModeS Beast (TCP)"
          Whenever I try and set the same setting on the new receiver setup, when I click the save button it reverts to AVR (TCP)
          However the receiver seems to be working, but FR24feed -status shows a Fail for FR24 MLAT ???
          Last edited by kiwiandy; 2020-03-08, 06:55.

          Comment


          • #6
            Yep. Need to change manually or force an update to 24.8 if not already

            https://forum.flightradar24.com/foru...-changes-issue

            sudo apt-get update
            sudo apt-get install fr24feed
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Hmmm ran the 2 commands you listed.... result:

              fr24feed is already the newest version (1.0.24-7).

              0 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.

              it didnt update to 24.8? and the problem persists?

              Comment


              • #8
                did update run a bunch of stuff on screen? Cause it should have updated sources

                pi@raspberrypi:~ $ sudo apt policy fr24feed
                fr24feed:
                Installed: 1.0.24-7
                Candidate: 1.0.24-8
                Version table:
                1.0.24-8 500
                500 http://repo.feed.flightradar24.com flightradar24/raspberrypi-beta armhf Packages
                *** 1.0.24-7 100
                100 /var/lib/dpkg/status

                That same thread has the manual 24-8 force command by abcd in it too.
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  this is what it did:
                  pi@raspberrypi:~ $ sudo apt-get update

                  Hit:1 http://flightaware.com/adsb/piaware/files/packages stretch InRelease

                  Hit:2 http://repo.feed.flightradar24.com flightradar24 InRelease

                  Get:3 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]

                  Get:4 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]

                  Fetched 40.3 kB in 3s (10.8 kB/s)

                  Reading package lists... Done

                  pi@raspberrypi:~ $ sudo apt-get install fr24feed

                  Reading package lists... Done

                  Building dependency tree

                  Reading state information... Done

                  fr24feed is already the newest version (1.0.24-7).

                  0 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.


                  I tried to edit manually as per the other post you linked to, and now my receiver type is DVBT Stick ??

                  Comment


                  • #10
                    okay I changed the entry to beast-tcp and it now is using the correct receiver type but MLAT is not running?

                    Comment


                    • #11
                      ini file:
                      receiver="beast-tcp"

                      fr24key="XXXXXXXXXXXXX"

                      host="127.0.0.1:30002"

                      bs="yes"

                      raw="yes"

                      logmode="2"

                      logpath="/var/log/fr24feed"

                      mlat="yes"

                      mlat-without-gps="yes"



                      Comment


                      • #12
                        Since you cloned it, re-running signup asks for details again

                        You should have entered all the same feeder type etc as working copy, but if it went to dvbt and so on you likely have run with the automatic version of the answers instead of picking them

                        That then leads to the 24-7 change from web-page issue.

                        It's quite possibly over-written your dump1090 you had installed as a result and now conflicting/not actually running properly.

                        You have 2 options.

                        force the update from the thread and then you can toggle mlat and edit options to your hearts content (it wont run unless it has contacts)
                        https://forum.flightradar24.com/foru...644#post181644

                        And run Wiedehopfs dump1090-fa script https://github.com/wiedehopf/adsb-sc...or-dump1090-fa

                        OR..

                        Re-clone the working one, upgrade it to 24-8
                        And when you run --signup don't let it pick DVBT (leave it unplugged)
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • #13
                          Sweet as that did the trick, seems to be working good now.
                          Really appreciate your help!

                          Comment

                          Working...
                          X