Announcement

Collapse
No announcement yet.

Mode-S Beast on Raspbian/Raspberry Pi with USB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mode-S Beast on Raspbian/Raspberry Pi with USB

    I have connected Mode-S Beast on Raspbian/Raspberry Pi with USB.
    I am unable to make it working after installing the dump1090-mutability and other clients.
    I have followed some articles to install fa-client, fr24-client, pf-client, dump1090, dump1090-mutability, adsbreceiver.net, etc.
    It seems that the dump1090-mutability is not able to listen to mode-s beast on USB.
    Is there any method to connect Mode-S Beast on Raspbian/Raspberry Pi with USB and feed data?

    This is the error I get when I open dump1090.
    Problem fetching data from dump1090. AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date.

  • #2
    Dump1090 is designed for USB SDR dongles. Not other receivers. It is an interface to use the RTL chipset contained within them.

    You can use other receivers with Dump1090, but for visual display only. You will require a lot more work and software to connect to it and decode the binary data first as mode-s produces different data.

    As discussed http://discussions.flightaware.com/a...90-t37135.html

    FR24feed is capable of connecting to the mode-s beast on its own. You can then use the outputs to other software
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      I also tried installing FR24feed first on a fresh installation of Raspbian but didnt work even for fr24. Can you give me the instructions to configure FR24feed with mode-s beast connected on Raspbian/Raspberry Pi with USB and use the outputs to other software?

      Comment


      • #4
        Uhm, its part of the setup guide when you install FR24feed...

        4 - ModeS Beast (USB/Network)

        Step 5.1 - Would you like to enable RAW data feed on port 30334 (yes/no)$:
        Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)


        http://forum.flightradar24.com/threa...ll=1#post74852
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          You need to uninstall all the automatic stuff you have installed and start again.

          Install just fr24feed and chose the right options.

          Then add other software as desired once working 100%

          Don't try and to multiple things at once. It will end up in the same broken state as they all start automatically and will conflict.

          http://forum.flightradar24.com/showthread.php?p=68021



          Sent from my XT1092 using Tapatalk
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            The most flexible way is to start with ModeSmixer2. It will be used as the interface between USB and all other sharing softwares. Just set it up to connect to the correct /dev/ttyUSB(x) at 3000000 bps, and enable beast type data out on 30005. It also has a web interface with maps, stats etc. It replaces dump1090 as the data provider.

            When that is working, you can install the other feeding clients, and they will all think they are getting data from dump1090.

            When installing FR24feed, you should configure it to use beast-tcp on port 30005.

            The command line to start modesmixer2 will look something like this:

            /root/modesmixer2 --inSerial /dev/ttyUSB0:3000000:none --outServer beast:30005 --web 8088


            Download: http://xdeco.org/?page_id=48

            BR /M
            F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
            P-ESGR, P-ESIA, P-ESIB, P-ESGF
            mrmac (a) fastest.cc

            Comment

            Working...
            X