Results 1 to 10 of 10

Thread: Serious Problem With fr24feed on RPI

  1. #1
    Passenger
    Join Date
    May 2010
    Location
    EGPD
    Posts
    46

    Exclamation Serious Problem With fr24feed on RPI

    Hi

    I'm getting time sync errors in my fr24feed.log file which look like

    2016-02-03 09:43:34 | ERROR: time drift is 1454260023 seconds, resetting dump1090 start time[feed][i]sent 18 AC in 1 packet

    The time drift number is different each time and there are normally more than one per line

    However, my RPi is correct to the nearest millisecond and not 46 years out like the log suggests

    Here are the status flags from fr24

    ac_map_size="3072"
    build_arch="armv7l"
    build_flavour="generic"
    build_os="Linux"
    build_revision="HEAD-796dd01.git"
    build_timetamp="20160128-1017"
    build_version="1.0.16-11"
    cfg_baudrate=""
    cfg_bs="yes"
    cfg_host="192.168.0.253:30002"
    cfg_mpx=""
    cfg_path=""
    cfg_raw="yes"
    cfg_receiver="avr-tcp"
    cfg_windowmode="0"
    d11_map_size="26"
    feed_alias="T-EGPD7"
    feed_current_mode="UDP"
    feed_current_server="83.140.21.66"
    feed_last_ac_sent_num="14"
    feed_last_ac_sent_time="1454493076"
    feed_last_attempt_time="1454492765"
    feed_last_config_attempt="1454492765"
    feed_last_config_info=""
    feed_last_config_result="success"
    feed_last_connected_time="1454492785"
    feed_num_ac_tracked="18"
    feed_status="connected"
    feed_status_message=""

    gps_tods="0"
    last_json_utc="1454493010"
    last_rx_connect_status="OK"
    last_rx_connect_time="1454492762"
    last_rx_connect_time_s="2016-02-03 09:46:02"
    local_tods="35472"
    msg_ring_full="0"
    msg_ring_length="0"
    num_messages="37316"
    num_resyncs="0"
    offline-mode="no"
    rx_connected="1"
    shutdown="no"
    time_update_utc="1454493073"
    time_update_utc_s="2016-02-03 09:51:13"
    timing_is_valid="1"
    timing_last_drift="+0.0005"
    timing_last_offset="+0.0005"
    timing_last_result="success"
    timing_source="NTP"
    timing_time_last_attempt="1454492765"
    timing_time_last_success="1454492765"
    timing_time_since_last_success="1454492765"


    Notice the drift and offset flags

    timing_last_drift="+0.0005"
    timing_last_offset="+0.0005"

    Which do not equate to ERROR: time drift is 1454260023 seconds

    I've done the usual, reboot and shutdown completely then turn back on and nothing changes.
    T-EGPD7

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,057
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,057
    Before you removed it..

    The error you are getting does not depend on your local clock, the message itself is ambiguous and is fixed in the upcoming release.
    The fixed release is not out yet.

    Its also mentioned a few places enabling the logfile is likely not required unless for diagnostics. The auto prune does not work on all systems and can harm constant writes to an SD card.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  4. #4
    Passenger
    Join Date
    May 2010
    Location
    EGPD
    Posts
    46
    This was working perfectly with 1.14 but since 1.16 it has broken <--- Ignore

    I'll try to disable the log file. I've disabled it in the setting web page.

    Thanks, was getting seriously stressed, nearly reverted back to my previous build.

    Do you have any idea when the fix will be released?

    And another question if I may. in the log file when fr24 starts it say

    [main][i]Automatic updates are DISABLED

    Is there a way to turn that on? I seem to have missed that bit

    Thanks for the replys
    Last edited by Angelus1971; 2016-02-03 at 10:49.
    T-EGPD7

  5. #5
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,057
    Correct. I believe there are changes being made to improve MLAT calculations server side going by update reports. Which is why its currently not being displayed on the map (but data still taken)

    Means more tweaking of timestamp and data format within the client.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  6. #6
    Passenger
    Join Date
    May 2010
    Location
    EGPD
    Posts
    46
    Thanks

    Are all MLATS not showing? I ask as there are quite a few showing as coming from MLATs at the moment
    T-EGPD7

  7. #7
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,057
    Just ones generated from the FR owned/supplied F-receivers.

    When position is calculated from RPIs usually labelled as T-MLAT6 or 7
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  8. #8
    Passenger
    Join Date
    May 2010
    Location
    EGPD
    Posts
    46
    Something else that I've noticed. Turning the log to disabled in the configuration hasn't stopped the logging. It still continuing. Any idea how to turn it off??
    T-EGPD7

  9. #9
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,057
    Might need a sudo service fr24feed restart if not done already.
    From what I can tell the log toggle is specified at startup
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  10. #10
    Passenger
    Join Date
    May 2010
    Location
    EGPD
    Posts
    46
    Thanks again. That did the trick. 5 mins now and no logging!!

    Just hitting the restart button on the config webpage, although it started the service it didn't do a clean restart by the looks of it.
    T-EGPD7

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •