Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 54

Thread: strange radar down

  1. #21
    Passenger
    Join Date
    Aug 2015
    Location
    London, UK
    Posts
    5
    Quote Originally Posted by vinnyspb View Post
    Thanks for the output.

    Your's one looks good to me. You don't need to manually start/stop fr24feed before running this script, it is intended to do it automatically if upgrade is required.
    In your case fr24feed is already up to date, it would be nice to see someone else's output who has issues and haven't updated yet.
    As you see I'm on 1.0.14-11 & the script fails as follows:



    Reading package lists... Done
    Installed version: 1.0.14-11
    Latest available: 1.0.16-7
    Upgrading fr24feed...
    Waiting for fr24feed to stop completely...
    Failed to get properties: Connection reset by peer
    Failed to get properties: Connection timed out
    Failed to get properties: Connection timed out
    Failed to get properties: Connection timed out
    Failed to stop fr24feed.service: Connection timed out
    Failed to get load state of fr24feed.service: Connection timed out
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be upgraded:
    fr24feed
    1 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.
    Need to get 0 B/433 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    (Reading database ... 143866 files and directories currently installed.)
    Preparing to unpack .../fr24feed_1.0.16-7_armhf.deb ...
    Failed to execute operation: Activation of org.freedesktop.systemd1 timed out
    [....] Stopping fr24feed (via systemctl): fr24feed.serviceFailed to stop fr24feed.service: Activation of org.freedesktop.systemd1 timed out
    Failed to get load state of fr24feed.service: Activation of org.freedesktop.systemd1 timed out
    failed!
    dpkg: error processing archive /var/cache/apt/archives/fr24feed_1.0.16-7_armhf.deb (--unpack):
    subprocess new pre-installation script returned error exit status 1
    Failed to execute operation: Activation of org.freedesktop.systemd1 timed out
    Errors were encountered while processing:
    /var/cache/apt/archives/fr24feed_1.0.16-7_armhf.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Failed to restart fr24feed.service: Connection timed out
    pi@RPHS ~ $

  2. #22
    Passenger
    Join Date
    Dec 2015
    Posts
    9
    Same problem over here the last 2 days. I guess something goes wrong with the update. If i do an manual sudo /usr/lib/fr24/fr24feed_updater.sh it works.

    Checking the apt history says:

    pi@pi3 /var/log/apt $ cat history.log

    Start-Date: 2015-12-16 07:01:15
    Commandline: apt-get install -y fr24feed
    Upgrade: fr24feed:armhf (1.0.14-11, 1.0.16-7)
    Error: Sub-process /usr/bin/dpkg returned an error code (2)
    End-Date: 2015-12-16 07:01:16

    Start-Date: 2015-12-17 07:01:15
    Commandline: apt-get install -y fr24feed
    Upgrade: fr24feed:armhf (1.0.14-11, 1.0.16-7)
    Error: Sub-process /usr/bin/dpkg returned an error code (2)
    End-Date: 2015-12-17 07:01:16

    Start-Date: 2015-12-17 19:51:44
    Commandline: apt-get install -y fr24feed
    Upgrade: fr24feed:armhf (1.0.14-11, 1.0.16-7)
    End-Date: 2015-12-17 19:51:49

    Looking at the crontab entry it says:
    0 7 * * * root /usr/lib/fr24/fr24feed_updater.sh

    Should the "root" in this line not been replaced by "sudo"??

  3. #23
    Flight attendant
    Join Date
    Mar 2015
    Location
    Nancy, France
    Posts
    65
    Quote Originally Posted by vinnyspb View Post
    Most likely there is something wrong with auto-update script, that is scheduled to run at 07:00 local time (RPi system timezone).

    Just double checked it on Raspbian OS and it works fine, so that may be related to some other OS or different configurations.

    Could you please run this update script:



    and post the output?
    Hi,

    I had this crash during 3 consecutive days, and updated now by launching the command "sudo /usr/lib/fr24/fr24feed_updater.sh", which brought me from version 1.0.14-11 to version 1.0.16-7. I have kept the output, if you need it I can post it.
    I guess there is indeed a problem with the auto-update, as there are surely intermediate versions between the 2 mentioned above...
    T-LFSN4

    Check your rank from FR24 feeder stats at https://jollain.com/FR24/stats.php

  4. #24
    Purser attigliano's Avatar
    Join Date
    May 2010
    Location
    Copenhagen
    Posts
    116
    Linux is new to me, so I may say something stupid
    Is there somewhere in RaPi OS where you should grant a update script?
    I had read that I could make a update by running: apt-get update and then apt-get upgrade this didn't work.
    Then I run: sudo apt-get update and then sudo apt-get upgrade now my RaPi get updated and it had worked since
    Last edited by attigliano; 2015-12-18 at 06:59.
    T-EKCH5: Raspberry Pi type B+ + FlightAware Pro Stick Plus + 1090MHz Bandpass Filter + A3-ADS-B Antenna

  5. #25
    Passenger
    Join Date
    Mar 2015
    Posts
    8
    This morning fr24feed appears to be working normally...

  6. #26
    Flight attendant
    Join Date
    Mar 2015
    Location
    Nancy, France
    Posts
    65
    So far everything is fine for me as well.
    Is there a way to find on this forum the latest version of the feeder, and on the feeder a command that displays the version running? This would allow us to check that the latest version is installed.
    T-LFSN4

    Check your rank from FR24 feeder stats at https://jollain.com/FR24/stats.php

  7. #27
    Flight attendant
    Join Date
    Jun 2015
    Posts
    62
    pellonet, Erik12345, patrick1501,
    which OS (name, version) are you guys using?

    patrick1501,
    output is definitely welcome!

  8. #28
    Flight attendant
    Join Date
    Mar 2015
    Location
    Nancy, France
    Posts
    65
    Quote Originally Posted by vinnyspb View Post
    pellonet, Erik12345, patrick1501,
    which OS (name, version) are you guys using?

    patrick1501,
    output is definitely welcome!
    Feeding from Raspberry Pi, OS is Raspbian.

    Here is the output:

    Code:
    pi@RaspiFR24 ~ $ sudo /usr/lib/fr24/fr24feed_updater.sh
    Hit http://raspberrypi.collabora.com wheezy Release.gpg
    Get:1 http://archive.raspberrypi.org wheezy Release.gpg [473 B]                                                                 
    Get:2 http://mirrordirector.raspbian.org wheezy Release.gpg [490 B]                                                                                         
    Hit http://raspberrypi.collabora.com wheezy Release                                                                             
    Get:3 http://mirrordirector.raspbian.org wheezy Release [14.4 kB]                          
    Hit http://repo.feed.flightradar24.com flightradar24 Release.gpg                           
    Hit http://repo.mutability.co.uk wheezy Release.gpg                                        
    Hit http://archive.raspberrypi.org wheezy Release                                          
    Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages                                 
    Hit http://repo.feed.flightradar24.com flightradar24 Release                                   
    Hit http://repo.mutability.co.uk wheezy Release                          
    Get:4 http://mirrordirector.raspbian.org wheezy/main armhf Packages [6908 kB]
    Hit http://archive.raspberrypi.org wheezy/main armhf Packages                                       
    Ign http://raspberrypi.collabora.com wheezy/rpi Translation-en                                                        
    Ign http://archive.raspberrypi.org wheezy/main Translation-en                                                         
    Hit http://repo.feed.flightradar24.com flightradar24/raspberrypi-beta armhf Packages            
    Hit http://repo.mutability.co.uk wheezy/rpi armhf Packages                                    
    Ign http://repo.feed.flightradar24.com flightradar24/raspberrypi-beta Translation-en
    Ign http://repo.mutability.co.uk wheezy/rpi Translation-en                    
    Get:5 http://mirrordirector.raspbian.org wheezy/contrib armhf Packages [23.6 kB]                                                                                       
    Get:6 http://mirrordirector.raspbian.org wheezy/non-free armhf Packages [49.3 kB]                                                                                      
    Get:7 http://mirrordirector.raspbian.org wheezy/rpi armhf Packages [592 B]                                                                                             
    Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en                                                                                                   
    Ign http://mirrordirector.raspbian.org wheezy/main Translation-en                                                                                                      
    Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en                                                                                                  
    Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en                                                                                                       
    Fetched 6997 kB in 45s (153 kB/s)                                                                                                                                      
    Reading package lists... Done
    Installed version: 1.0.14-11
    Latest available: 1.0.16-7
    Upgrading fr24feed...
    Waiting for fr24feed to stop completely...
    [....] Stopping FR24 feeder: fr24feedKilling all children processes
    . ok 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be upgraded:
      fr24feed
    1 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
    Need to get 0 B/433 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    	LC_CTYPE = "UTF-8",
    	LANG = "en_GB.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    (Reading database ... 78701 files and directories currently installed.)
    Preparing to replace fr24feed 1.0.14-11 (using .../fr24feed_1.0.16-7_armhf.deb) ...
    [ ok ] Stopping FR24 feeder: fr24feed.
    Unpacking replacement fr24feed ...
    Setting up fr24feed (1.0.16-7) ...
    [ ok ] Stopping FR24 feeder: fr24feed.
    [ ok ] Starting FR24 feeder: fr24feed.
    pi@RaspiFR24 ~ $
    T-LFSN4

    Check your rank from FR24 feeder stats at https://jollain.com/FR24/stats.php

  9. #29
    Passenger
    Join Date
    Nov 2012
    Location
    BUE - Argentina
    Posts
    12
    Today again, 4 days in a row the fr24feed stopped at 10:00UTC. No other process stopped at my RPI (LiveATC and Flight Aware working normally). There is nothing in the /var/log/messages as mentioned by henkverhaar...

  10. #30
    Passenger
    Join Date
    Dec 2015
    Posts
    9
    Quote Originally Posted by atairlines View Post
    Today again, 4 days in a row the fr24feed stopped at 10:00UTC. No other process stopped at my RPI (LiveATC and Flight Aware working normally). There is nothing in the /var/log/messages as mentioned by henkverhaar...
    How about /var/log/apt/history.log
    If the reason is that it get stopped by a failing update, you should see it there.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •