Page 51 of 91 FirstFirst ... 41495051525361 ... LastLast
Results 501 to 510 of 901

Thread: Archived - Beta test MLAT software for Raspberry Pi

  1. #501
    Passenger
    Join Date
    Feb 2014
    Location
    T-LZSL5
    Posts
    11
    Failed and got this...
    Log is working too. It expect only existing directory, not a file name.

    2016-01-13 07:00:51 | [time][i]Time synchronized correctly, offset -0.0007 seconds, drift -0.0000 seconds/minute
    2016-01-13 07:00:51 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:00:55 | [mlat][i]Pinging the server
    2016-01-13 07:00:55 | [mlat][i]Stats 0/0
    2016-01-13 07:00:56 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:01:01 | [feed][i]sent 9 AC in 1 packet
    2016-01-13 07:01:06 | [feed][i]sent 9 AC in 1 packet
    2016-01-13 07:01:11 | [feed][i]sent 9 AC in 1 packet
    2016-01-13 07:01:15 | [mlat][i]Pinging the server
    2016-01-13 07:01:15 | [mlat][i]Stats 0/0
    2016-01-13 07:01:16 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:01:21 | [feed][i]sent 10 AC in 1 packet
    2016-01-13 07:01:26 | [feed][i]sent 9 AC in 1 packet
    2016-01-13 07:01:31 | [feed][i]sent 9 AC in 1 packet
    2016-01-13 07:01:35 | [mlat][i]Pinging the server
    2016-01-13 07:01:35 | [mlat][i]Stats 0/0
    2016-01-13 07:01:36 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:01:40 | [feed][i]removed 1 of 11 AC
    2016-01-13 07:01:41 | [feed][i]sent 9 AC in 1 packet
    2016-01-13 07:01:47 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:01:52 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:01:55 | [mlat][i]Pinging the server
    2016-01-13 07:01:55 | [mlat][i]Stats 0/0
    2016-01-13 07:01:57 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:02:02 | [feed][i]sent 8 AC in 1 packet
    2016-01-13 07:02:06 | [reader][i][0]Connection terminated
    2016-01-13 07:02:06 | [main][i]Terminating child process 27658 with SIGETERM


    and it seems, that dump1090 is executed without --net parameter..

    2016-01-12 21:47:42 | [main][i]FR24 Feeder/Decoder [0x02117000]
    2016-01-12 21:47:42 | [main][i]Version: 1.0.14-11/generic
    2016-01-12 21:47:42 | [main][i]Built on 20150828-0958 (r:master-8c35732.git/Linux/armv7l)
    2016-01-12 21:47:42 | [main][i]Automatic updates are ENABLED
    2016-01-12 21:47:42 | [main][i]Copyright 2008-2015 (c) Piotr Pawluczuk
    2016-01-12 21:47:42 | [main][i]Flightradar24 AB(http://flightradar24.com)
    2016-01-12 21:47:43 | [main][i]DNS mode: LIBC
    2016-01-12 21:47:43 | ERROR
    2016-01-12 21:47:43 | [main][i]Reader 0 started
    2016-01-12 21:47:43 | [main][i]Socket server started
    2016-01-12 21:47:43 | [main][i]MLAT data feed started
    2016-01-12 21:47:43 | [reader][i][0]Initializing reader
    2016-01-12 21:47:43 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090 --raw --mlat)
    2016-01-12 21:47:43 | [master][i]Starting processing thread
    2016-01-12 21:47:43 | [bs][i]Initializing server
    2016-01-12 21:47:43 | [bs][i]Starting server on 0.0.0.0:30003
    2016-01-12 21:47:43 | [mlat][i]Waiting for MLAT configuration
    2016-01-12 21:47:43 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-01-12 21:47:43 | [reader][i][0]Connected to the receiver, authenticating
    2016-01-12 21:47:43 | [reader][i][0]Authenticated, processing messages
    2016-01-12 21:47:43 | [bs][i]New client connected 192.168.1.10:53019
    2016-01-12 21:47:44 | [reader][w][0]Setting new UTC offset: 0!
    2016-01-12 21:47:44 | [time][i]Synchronizing time via NTP
    2016-01-12 21:47:47 | [time][i]Time synchronized correctly, offset +0.0010 seconds
    2016-01-12 21:47:47 | [main][i]Feed Network client started
    2016-01-12 21:47:47 | [main][i]RAW data server started
    2016-01-12 21:47:47 | [raw][i]Initializing server
    2016-01-12 21:47:47 | [raw][i]Starting server on 0.0.0.0:30002
    2016-01-12 21:47:47 | [feed][i]Downloading configuration
    2016-01-12 21:47:47 | [feed][c]Interval: 5s
    2016-01-12 21:47:47 | [feed][c]Latitude: 48.7782
    2016-01-12 21:47:47 | [feed][c]Longitude: 18.6181
    2016-01-12 21:47:47 | [feed][c]GND: YES
    2016-01-12 21:47:47 | [feed][c]NonADSB: YES
    2016-01-12 21:47:47 | [feed][c]Timestamps: optional
    2016-01-12 21:47:47 | [feed][c]Max range AIR: 350.0nm
    2016-01-12 21:47:47 | [feed][c]Max range GND: 100.0nm
    2016-01-12 21:47:47 | [feed][i]defined 1 server
    2016-01-12 21:47:47 | [feed][n]LZSL5@83.140.21.66:8099/UDP
    2016-01-12 21:47:47 | [feed][n]connecting
    2016-01-12 21:47:47 | [stats][i]Stats thread started
    2016-01-12 21:47:47 | [mlat][i]MLAT configuration received, service ENABLED
    2016-01-12 21:47:47 | [mlat][i]Starting MLAT with preconfigured position: 48.78,18.62,870.0
    2016-01-12 21:47:47 | [mlat][i]MLAT bandwidth reduction active, level 1
    2016-01-12 21:47:47 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-01-12 21:47:47 | [mlat][i]Registering MLAT station
    2016-01-12 21:47:47 | [mlat][i]Registering MLAT station: SUCCESS
    2016-01-12 21:48:05 | [mlat][i]Pinging the server
    2016-01-12 21:48:05 | [mlat][i]Stats 0/0
    2016-01-12 21:48:07 | [feed][n]connected via TCP
    2016-01-12 21:48:07 | [feed][n]switching to UDP
    2016-01-12 21:48:07 | [feed][n]working
    2016-01-12 21:48:07 | [feed][i]sent 1 AC in 1 packet
    Last edited by RoSi; 2016-01-13 at 12:50.

  2. #502
    Purser
    Join Date
    Sep 2013
    Location
    T-VHST9
    Posts
    101
    Anyone can post change log of new beta version "1.0.16-10"?
    T-VHST9: http://vhst9.hopto.org/
    (24/7)

  3. #503
    Flight attendant
    Join Date
    Jun 2015
    Posts
    62
    Version 1.0.16-10 has been released few days ago to the beta and today to the stable APT repository.

    Major changes include:
    - For those users who feed to Flightaware and chain the data to FR24, FA MLAT data will not be sent to FR24 (mixing with ADS-B data as it previously was)
    - Auto-upgrade script fix ($PATH was missing when running from crontab)
    - Few steps towards restoring RPi-based MLAT

    For all users with auto-upgrade enabled:
    Within this release auto upgrade should be fixed, but as the script will be invoked from the previous version, it may break the feed software. Please, run upgrade manually:

    sudo /usr/lib/fr24/fr24feed_updater.sh

  4. #504
    Passenger
    Join Date
    Feb 2013
    Location
    London, UK
    Posts
    43
    I just upgraded from 1.0.16-7. I needed to make fr24feed_updater.sh executable before this would work:
    Code:
    sudo chmod +x /usr/lib/fr24/fr24feed_updater.sh 
    sudo /usr/lib/fr24/fr24feed_updater.sh
    Then it went fine. I'm now running 1.0.16-10

    Thanks for the easy update!

  5. #505
    Passenger
    Join Date
    Mar 2015
    Posts
    3
    Quote Originally Posted by vinnyspb View Post
    Version 1.0.16-10 has been released few days ago to the beta and today to the stable APT repository.

    Major changes include:
    - For those users who feed to Flightaware and chain the data to FR24, FA MLAT data will not be sent to FR24 (mixing with ADS-B data as it previously was)
    - Auto-upgrade script fix ($PATH was missing when running from crontab)
    - Few steps towards restoring RPi-based MLAT

    For all users with auto-upgrade enabled:
    Within this release auto upgrade should be fixed, but as the script will be invoked from the previous version, it may break the feed software. Please, run upgrade manually:

    sudo /usr/lib/fr24/fr24feed_updater.sh
    I'm seeing a lot of this in the log since 1200 today.

    Code:
    2016-01-27 16:27:40 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 16:27:40 | [feed][i]Failed on start, Sleeping 120 seconds
    2016-01-27 16:29:40 | [feed][i]Downloading configuration
    2016-01-27 16:29:40 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 16:29:40 | [feed][i]Failed on start, Sleeping 120 seconds
    2016-01-27 16:31:40 | [feed][i]Downloading configuration
    2016-01-27 16:31:40 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 16:31:40 | [feed][i]Failed on start, Sleeping 120 seconds
    2016-01-27 16:32:46 | [time][i]Synchronizing time via NTP
    2016-01-27 16:32:50 | [time][i]Time synchronized correctly, offset +0.0002 seconds, drift -0.0000 seconds/minute
    2016-01-27 16:33:40 | [feed][i]Downloading configuration
    2016-01-27 16:33:41 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 16:33:41 | [feed][i]Failed on start, Sleeping 120 seconds
    2016-01-27 16:35:41 | [feed][i]Downloading configuration
    2016-01-27 16:35:41 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 16:35:41 | [feed][i]Failed on start, Sleeping 120 seconds

  6. #506
    First officer
    Join Date
    Mar 2013
    Location
    Arhus (T-EKAH3), Denmark
    Posts
    345
    Please remind me; How can I check the feeder software version on my RPi?

  7. #507
    Passenger
    Join Date
    Mar 2014
    Location
    Moscow, Russian Federation
    Posts
    3
    At Feeder Status page (IP:8754, ex. 192.168.0.1:8754) and at the top of page you see your version (ex. Linux/generic/armv7l/1.0.16-7)
    T-UUMO56 | Moscow, Russian Federation

  8. #508
    Passenger
    Join Date
    Jan 2016
    Location
    Noblesville, IN
    Posts
    3
    After upgrading to 10.0.16-10, my status page reads:
    Flightradar24 Feeder/Decoder

    Linux/generic/armv7l/1.0.16-10

    Updated: 15:01:27 GMT-0500 (Eastern Standard Time)

    FR24 Link: Disconnected ()
    FR24 Radar Code: N/A
    Aircraft Tracked (ModeS & ADS-B): 37
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: NO

    Here's the monitor.txt:
    ac_map_size="3072"
    build_arch="armv7l"
    build_flavour="generic"
    build_os="Linux"
    build_revision="HEAD-e1849f9.git"
    build_timetamp="20160125-0828"
    build_version="1.0.16-10"
    cfg_baudrate=""
    cfg_bs="no"
    cfg_host="127.0.0.1:30002"
    cfg_mpx="no"
    cfg_path=""
    cfg_raw="no"
    cfg_receiver="dvbt"
    cfg_windowmode="0"
    d11_map_size="20"
    feed_last_config_attempt="1453925520"
    feed_last_config_info=""
    feed_last_config_result="error"
    gps_tods="0"
    last_json_utc="1453925516"
    last_rx_connect_status="OK"
    last_rx_connect_time="1453925515"
    last_rx_connect_time_s="2016-01-27 20:11:55"
    local_tods="72785"
    mlat-ok="NO"
    mlat-started="YES"
    mlat_problem="no-config"
    msg_ring_full="0"
    msg_ring_length="0"
    num_messages="1116"
    num_resyncs="0"
    rx_connected="1"
    shutdown="no"
    time_update_utc="1453925588"
    time_update_utc_s="2016-01-27 20:13:08"
    timing_is_valid="1"
    timing_last_drift="-0.0022"
    timing_last_offset="-0.0022"
    timing_last_result="success"
    timing_source="NTP"
    timing_time_last_attempt="1453925520"
    timing_time_last_success="1453925520"
    timing_time_since_last_success="1453925520"

    And here's what's in my fr24feed.log:

    2016-01-27 14:35:22 | [main][i]FR24 Feeder/Decoder [0x02117000]
    2016-01-27 14:35:22 | [main][i]Version: 1.0.16-10/generic
    2016-01-27 14:35:22 | [main][i]Built on 20160125-0828 (r:HEAD-e1849f9.git/Linux/armv7l)
    2016-01-27 14:35:22 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-01-27 14:35:22 | [main][i]DNS mode: LIBC
    2016-01-27 14:35:22 | [main][i]Automatic updates are DISABLED
    2016-01-27 14:35:22 | ERROR
    2016-01-27 14:35:22 | [w]Detected --net argument for dump1090, disabling internal RAW feed!
    2016-01-27 14:35:22 | [w]Detected --net argument for dump1090, disabling internal BS feed!
    2016-01-27 14:35:22 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-01-27 14:35:22 | [main][i]Reader thread started
    2016-01-27 14:35:22 | [reader][i]Initializing reader
    2016-01-27 14:35:22 | [main][i]MLAT data feed started
    2016-01-27 14:35:22 | [reader][i]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090 --net --raw --mlat)
    2016-01-27 14:35:22 | [mlat][i]Waiting for MLAT configuration
    2016-01-27 14:35:22 | [reader][i]Connected to the receiver, configuring
    2016-01-27 14:35:22 | [reader][i]Configured, processing messages
    2016-01-27 14:35:22 | [master][i]Starting processing thread
    2016-01-27 14:35:23 | [reader][w]Setting new UTC offset: 0!
    2016-01-27 14:35:23 | [time][i]Synchronizing time via NTP
    2016-01-27 14:35:26 | [time][i]Time synchronized correctly, offset +0.0019 seconds
    2016-01-27 14:35:26 | [main][i]Feed Network client started
    2016-01-27 14:35:26 | [feed][i]Downloading configuration
    2016-01-27 14:35:27 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 14:35:27 | [feed][i]Failed on start, Sleeping 120 seconds
    2016-01-27 15:41:45 | [time][i]Time synchronized correctly, offset -0.0002 seconds


    I've tried re-starting, then complete un-install, re-install. I also show as offline on my site page. Any ideas?
    Last edited by W9MDO; 2016-01-27 at 20:49.

  9. #509
    Passenger
    Join Date
    Jan 2016
    Location
    EDVY
    Posts
    3
    Quote Originally Posted by W9MDO View Post
    After upgrading to 10.0.16-10, my status page reads:
    Flightradar24 Feeder/Decoder

    Linux/generic/armv7l/1.0.16-10

    Updated: 15:01:27 GMT-0500 (Eastern Standard Time)

    FR24 Link: Disconnected ()
    FR24 Radar Code: N/A
    Aircraft Tracked (ModeS & ADS-B): 37
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: NO

    Here's the monitor.txt:
    ac_map_size="3072"
    build_arch="armv7l"
    build_flavour="generic"
    build_os="Linux"
    build_revision="HEAD-e1849f9.git"
    build_timetamp="20160125-0828"
    build_version="1.0.16-10"
    cfg_baudrate=""
    cfg_bs="no"
    cfg_host="127.0.0.1:30002"
    cfg_mpx="no"
    cfg_path=""
    cfg_raw="no"
    cfg_receiver="dvbt"
    cfg_windowmode="0"
    d11_map_size="20"
    feed_last_config_attempt="1453925520"
    feed_last_config_info=""
    feed_last_config_result="error"
    gps_tods="0"
    last_json_utc="1453925516"
    last_rx_connect_status="OK"
    last_rx_connect_time="1453925515"
    last_rx_connect_time_s="2016-01-27 20:11:55"
    local_tods="72785"
    mlat-ok="NO"
    mlat-started="YES"
    mlat_problem="no-config"
    msg_ring_full="0"
    msg_ring_length="0"
    num_messages="1116"
    num_resyncs="0"
    rx_connected="1"
    shutdown="no"
    time_update_utc="1453925588"
    time_update_utc_s="2016-01-27 20:13:08"
    timing_is_valid="1"
    timing_last_drift="-0.0022"
    timing_last_offset="-0.0022"
    timing_last_result="success"
    timing_source="NTP"
    timing_time_last_attempt="1453925520"
    timing_time_last_success="1453925520"
    timing_time_since_last_success="1453925520"

    And here's what's in my fr24feed.log:

    2016-01-27 14:35:22 | [main][i]FR24 Feeder/Decoder [0x02117000]
    2016-01-27 14:35:22 | [main][i]Version: 1.0.16-10/generic
    2016-01-27 14:35:22 | [main][i]Built on 20160125-0828 (r:HEAD-e1849f9.git/Linux/armv7l)
    2016-01-27 14:35:22 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-01-27 14:35:22 | [main][i]DNS mode: LIBC
    2016-01-27 14:35:22 | [main][i]Automatic updates are DISABLED
    2016-01-27 14:35:22 | ERROR
    2016-01-27 14:35:22 | [w]Detected --net argument for dump1090, disabling internal RAW feed!
    2016-01-27 14:35:22 | [w]Detected --net argument for dump1090, disabling internal BS feed!
    2016-01-27 14:35:22 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-01-27 14:35:22 | [main][i]Reader thread started
    2016-01-27 14:35:22 | [reader][i]Initializing reader
    2016-01-27 14:35:22 | [main][i]MLAT data feed started
    2016-01-27 14:35:22 | [reader][i]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090 --net --raw --mlat)
    2016-01-27 14:35:22 | [mlat][i]Waiting for MLAT configuration
    2016-01-27 14:35:22 | [reader][i]Connected to the receiver, configuring
    2016-01-27 14:35:22 | [reader][i]Configured, processing messages
    2016-01-27 14:35:22 | [master][i]Starting processing thread
    2016-01-27 14:35:23 | [reader][w]Setting new UTC offset: 0!
    2016-01-27 14:35:23 | [time][i]Synchronizing time via NTP
    2016-01-27 14:35:26 | [time][i]Time synchronized correctly, offset +0.0019 seconds
    2016-01-27 14:35:26 | [main][i]Feed Network client started
    2016-01-27 14:35:26 | [feed][i]Downloading configuration
    2016-01-27 14:35:27 | [e]HTTP Response: [HTTP/1.1 400 Bad Request]
    2016-01-27 14:35:27 | [feed][i]Failed on start, Sleeping 120 seconds
    2016-01-27 15:41:45 | [time][i]Time synchronized correctly, offset -0.0002 seconds


    I've tried re-starting, then complete un-install, re-install. I also show as offline on my site page. Any ideas?
    I had the same problem with the new version.
    After some tests and analysis I decided to revert to the old version.
    Login to your Pi and do the following:
    Code:
    sudo dpkg -i /var/cache/apt/archives/fr24feed_1.0.16-7_armhf.deb
    This worked for me I'm online again.

  10. #510
    Passenger
    Join Date
    Jan 2016
    Location
    Noblesville, IN
    Posts
    3
    Thanks, but unfortunately, I don't have the older file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •