Page 8 of 10 FirstFirst ... 678910 LastLast
Results 71 to 80 of 91

Thread: Help Setting Up Flightradar24 Software

  1. #71
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    wildthing01

    Method-1
    Issue this command
    sudo nano /etc/fr24feed.ini

    Above command will open the file fr24feed.ini. In this file make following 2 changes:
    (1) change
    receiver="avr-tcp"
    to
    receiver="beast-tcp"

    (2) change
    host="127.0.0.1:30002"
    to
    host="127.0.0.1:30005"


    After changes are done, press Ctrl+o keys to save, then Ctrl+x keys to close.

    Now restart fr24feed
    sudo systemctl restart fr24feed

    ALTERNATIVE Method
    In your browser go to following address:

    IP-of-Pi:8754/settings.html

    Change settings to make them as in the screenshot below.
    After changes are done, click Save button, then Restart button.
    Both these buttons are at bottom-right of settings page.

    fr24feed setting BEAST-TCP using dump1090-fa or dump1090-mut v1.15.png
    Last edited by abcd567; 2019-10-10 at 10:00.

  2. #72
    Captain
    Join Date
    Apr 2018
    Posts
    861
    Yeah beast-tcp has less issues.
    Do as described above.

    Also update fr24feed:

    sudo apt update
    sudo apt upgrade
    sudo reboot

  3. #73
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    Now I dont have latest version in Armbian Repo

    pi@orangepipc:~$ sudo apt update

    pi@orangepipc:~$ apt-cache policy fr24feed
    fr24feed:
    Installed: 1.0.23-8
    Candidate: 1.0.23-8

    I think I should do this:

    sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"

    EDIT:
    Instead of bash command, used this:

    Code:
    pi@orangepipc:~$ wget http://repo.feed.flightradar24.com/rpi_binaries/fr24feed_1.0.24-4_armhf.deb
    
    pi@orangepipc:~$ sudo dpkg -i fr24feed_1.0.24-4_armhf.deb
    
    
    pi@orangepipc:~$ apt-cache policy fr24feed                  fr24feed:                                                     
      Installed: 1.0.24-4
      Candidate: 1.0.24-4
      Version table:
     *** 1.0.24-4 100
            100 /var/lib/dpkg/status
    
    pi@orangepipc:~$ sudo systemctl restart fr24feed
    pi@orangepipc:~$ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-10-10 10:46:50.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-CYYZ30.
    [ ok ] FR24 Tracked AC: 66.
    [ ok ] Receiver: connected (2929 MSGS/0 SYNC).
    [ ok ] FR24 MLAT: ok [UDP].
    [ ok ] FR24 MLAT AC seen: 64.
    Last edited by abcd567; 2019-10-10 at 10:54.

  4. #74
    Passenger
    Join Date
    May 2019
    Location
    Germanx-Berlin
    Posts
    18
    Hello Captain,

    Receiver can not be changed to Mode S Best (TCP)

  5. #75
    Captain
    Join Date
    Apr 2018
    Posts
    861
    What version are you at:

    fr24feed --version

    Also which receiver are you using that can't do beast-tcp?
    Aren't you using dump1090?

  6. #76
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    wildthing01

    Please issue following command, then again try to change setting.

    Code:
    sudo mount -o remount,rw /
    If you are making changes through browser (ip-of-pi:8754/settings.html), then after issueing above command, reload the browser (Ctrl+F5).
    Last edited by abcd567; 2019-10-10 at 11:16.

  7. #77
    Passenger
    Join Date
    May 2019
    Location
    Germanx-Berlin
    Posts
    18
    My receiver is fine (see here)

    pi@raspberrypi:~ $ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-10-10 11:25:03.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EDDB165.
    [ ok ] FR24 Tracked AC: 3.
    [ ok ] Receiver: connected (56401 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!


    Update I have done.

    Feeding software is still not running

  8. #78
    Passenger
    Join Date
    May 2019
    Location
    Germanx-Berlin
    Posts
    18
    Usage:
    mount [-lhV]
    mount -a [options]
    mount [options] [--source] <source> | [--target] <directory>
    mount [options] <source> <directory>
    mount <operation> <mountpoint> [<target>]

    Mount a filesystem.

    Options:
    -a, --all mount all filesystems mentioned in fstab
    -c, --no-canonicalize don't canonicalize paths
    -f, --fake dry run; skip the mount(2) syscall
    -F, --fork fork off for each device (use with -a)
    -T, --fstab <path> alternative file to /etc/fstab
    -i, --internal-only don't call the mount.<type> helpers
    -l, --show-labels show also filesystem labels
    -n, --no-mtab don't write to /etc/mtab
    -o, --options <list> comma-separated list of mount options
    -O, --test-opts <list> limit the set of filesystems (use with -a)
    -r, --read-only mount the filesystem read-only (same as -o ro)
    -t, --types <list> limit the set of filesystem types
    --source <src> explicitly specifies source (path, label, uuid)
    --target <target> explicitly specifies mountpoint
    -v, --verbose say what is being done
    -w, --rw, --read-write mount the filesystem read-write (default)

    -h, --help display this help and exit
    -V, --version output version information and exit

    Source:
    -L, --label <label> synonym for LABEL=<label>
    -U, --uuid <uuid> synonym for UUID=<uuid>
    LABEL=<label> specifies device by filesystem label
    UUID=<uuid> specifies device by filesystem UUID
    PARTLABEL=<label> specifies device by partition label
    PARTUUID=<uuid> specifies device by partition UUID
    <device> specifies device by path
    <directory> mountpoint for bind mounts (see --bind/rbind)
    <file> regular file for loopdev setup

    Operations:
    -B, --bind mount a subtree somewhere else (same as -o bind)
    -M, --move move a subtree to some other place
    -R, --rbind mount a subtree and all submounts somewhere else
    --make-shared mark a subtree as shared
    --make-slave mark a subtree as slave
    --make-private mark a subtree as private
    --make-unbindable mark a subtree as unbindable
    --make-rshared recursively mark a whole subtree as shared
    --make-rslave recursively mark a whole subtree as slave
    --make-rprivate recursively mark a whole subtree as private
    --make-runbindable recursively mark a whole subtree as unbindable

    For more details see mount(8).

  9. #79
    Captain
    Join Date
    Apr 2018
    Posts
    861
    You haven't answered, why can't you change it to beast-tcp?

    Which receiver are you using?

  10. #80
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    Can you please post screenshot of status page
    IP-of-Pi:8754

    It will show if the feeder is working (Aircrafts uploaded)

    Screenshot_20191010-075629_Chrome.jpg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •