Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 74

Thread: Raspberry Pi:How To Install Raspian OS + Dump1090 + FR24 Data Feeder

  1. #61
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,882
    @qsman
    Options A, B, and C are still valid.

    With option A and B during configiration, you have to choose:
    RECEIVER: DVB-T

    With option C during configuration, you have to choose any one of the following two settings.
    (1) Receiver : AVR(TCP), HOST/IP:30002
    (2) Receiver: Beast (TCP), HOST/IP:30005

    NOTE:
    The Option D (manual install of dump1090) and method to install dump1090-mutability are out-dated. Please do not use these. I will either update or totally remove these in next few days.
    Last edited by abcd567; 2018-02-20 at 06:54.

  2. #62
    Passenger
    Join Date
    Feb 2018
    Location
    Baltimore, MD
    Posts
    4
    Quote Originally Posted by abcd567 View Post
    @qsman
    Options A, B, and C are still valid.

    With option A and B during configiration, you have to choose:
    RECEIVER: DVB-T

    With option C during configuration, you have to choose any one of the following two settings.
    (1) Receiver : AVR(TCP), HOST/IP:30002
    (2) Receiver: Beast (TCP), HOST/IP:30005

    NOTE:
    The Option D (manual install of dump1090) and method to install dump1090-mutability are out-dated. Please do not use these. I will either update or totally remove these in next few days.
    Abcd567,

    Thank you so much for your reply. If I do need to troubleshoot I will know that I at least started off on the right foot.

    Sent from my Nexus 6P using Tapatalk

  3. #63
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,882
    POST #1 UPDATED ON FEBRUARY 20, 2018

  4. #64
    Passenger johnmiller's Avatar
    Join Date
    Jun 2013
    Location
    Olive Branch, MS
    Posts
    0
    I performed an update to my Raspberry Pi. During the FlightRadar24 update, something must have gone wrong, and the feeder won't work now.

    So, I started from scratch, following the instructions at the beginning of this thread: sudo bash -c "$(wget -O - ..."

    It went through the entire installation. I followed the instructions on what to enter, again as discussed at the beginning of this thread. But, I got this:

    Job for fr24feed.service failed. See 'systemctl status fr24feed.service' and 'journalctl -xn' for details.

    To try to help diagnose this, here are the results of the following commands:

    pi@raspberrypi:~ $ service fr24feed status
    ● fr24feed.service - Flightradar24 Decoder & Feeder
    Loaded: loaded (/etc/systemd/system/fr24feed.service; enabled)
    Active: activating (start-pre) since Fri 2018-03-16 19:39:45 CDT; 17s ago
    Process: 1165 ExecStartPre=/usr/lib/fr24/create_missing_directories.sh (code=exited, status=0/SUCCESS)
    Process: 1159 ExecStartPre=/usr/lib/fr24/unregister_kernel_modules.sh (code=exited, status=0/SUCCESS)
    Control: 1172 (install_dump109)
    CGroup: /system.slice/fr24feed.service
    └─control
    ├─1172 /bin/bash /usr/lib/fr24/install_dump1090.sh
    ├─1173 /bin/bash /usr/lib/fr24/install_dump1090.sh
    ├─1175 tee -a /var/log/fr24feed_install_dump1090.log
    ├─1179 apt-get update -y
    ├─1182 /usr/lib/apt/methods/http
    ├─1183 /usr/lib/apt/methods/http
    ├─1184 /usr/lib/apt/methods/http
    ├─1186 /usr/lib/apt/methods/gpgv
    └─1192 /usr/lib/apt/methods/copy

    pi@raspberrypi:~ $ sudo service fr24feed start
    Job for fr24feed.service failed. See 'systemctl status fr24feed.service' and 'journalctl -xn' for details.

    pi@raspberrypi:~ $ systemctl status fr24feed.service
    ● fr24feed.service - Flightradar24 Decoder & Feeder
    Loaded: loaded (/etc/systemd/system/fr24feed.service; enabled)
    Active: activating (start-pre) since Fri 2018-03-16 19:41:16 CDT; 36s ago
    Process: 1253 ExecStartPre=/usr/lib/fr24/create_missing_directories.sh (code=exited, status=0/SUCCESS)
    Process: 1247 ExecStartPre=/usr/lib/fr24/unregister_kernel_modules.sh (code=exited, status=0/SUCCESS)
    Control: 1261 (install_dump109)
    CGroup: /system.slice/fr24feed.service
    └─control
    ├─1261 /bin/bash /usr/lib/fr24/install_dump1090.sh
    ├─1262 /bin/bash /usr/lib/fr24/install_dump1090.sh
    ├─1263 tee -a /var/log/fr24feed_install_dump1090.log
    ├─1268 apt-get update -y
    ├─1271 /usr/lib/apt/methods/http
    ├─1272 /usr/lib/apt/methods/http
    ├─1273 /usr/lib/apt/methods/http
    ├─1275 /usr/lib/apt/methods/gpgv
    └─1281 /usr/lib/apt/methods/copy

    pi@raspberrypi:~ $ journalctl -xn
    No journal files were found.

    I don't know what to do to fix things, and need help.

    Thank you for whatever assistance you can offer!

  5. #65
    Passenger
    Join Date
    Jan 2019
    Posts
    2
    hello I have one (raspberry pi 3 + RTL2832U R820T2) I had this configuration with you and it worked wells.
    Code:
    receiver="avr-tcp"
    fr24key="key"
    host="127.0.0.1:30002"
    bs="no"
    raw="no"
    logmode="1"
    logpath="/var/log/fr24feed"
    mlat="yes"
    mlat-without-gps="yes"
    Currently it is connected but does not send data, and I have other feeder ok.

    Thanks in advance.

  6. #66
    Passenger
    Join Date
    Apr 2018
    Posts
    10
    Should these lines

    use-http=yes
    http-timeout=10
    be formatted as

    use-http="yes"
    http-timeout="10"

  7. #67
    Captain
    Join Date
    Apr 2018
    Posts
    884
    quotes or no quotes probably doesn't matter as long as the values after the = don't contain spaces or other special characters.

    works fine without quotes for me.

  8. #68
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,882
    Agree with @wiedehopf. Works both ways for me too.

    Mr. Khan of "Team FR24" has posted without quotes here:

    https://forum.flightradar24.com/thre...l=1#post112854

  9. #69
    Passenger
    Join Date
    Feb 2016
    Posts
    1
    Quote Originally Posted by wiedehopf View Post
    You need to run rtl_test after running the stop commands.
    The stop commands make sure that the dongle is not used by the other programs.

    Can you show the output for (execute in that order):

    pgrep -fa dump1090
    sudo systemctl stop fr24feed
    sudo rtl_test
    Thanks for this. I did run the rtl_test after running the stop commands.

    Here is what I have after running the above in that order:

    pi@raspberrypi:~ $ pgrep -fa dump1090
    520 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005 --max-range 360 --net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30 104 --net-bo-port 30005 --json-location-accuracy 1 --lat -41.15993 --lon 174.826 99 --write-json /run/dump1090-fa --quiet
    737 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --in put-type dump1090 --results beast,connect,localhost:30104 --results beast,listen ,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.191:5169:1 16732626
    pi@raspberrypi:~ $ sudo systemctl stop fr24feed
    pi@raspberrypi:~ $ sudo rtl_test
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    usb_claim_interface error -6
    Failed to open rtlsdr device #0.

  10. #70
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,882
    Quote Originally Posted by darryls.cody View Post
    pi@raspberrypi:~ $ pgrep -fa dump1090
    520 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --net-bo-port 30005
    You have installed dump1090-fa on Pi24, but you did not mention it in any of your posts.
    You have set fr24feed for "receiver=dvbt", so fr24feed has started its integral dump1090-mutability and trying to get data from it, while the stick is in use of dump1090-fa.

    DO NOT USE 2 TYPES OF DUMP1090 SIMULTANEOUSLY.

    Either
    stop dump1090-mutability of fr24feed by changing setting of fr24feed to following:
    Receiver = Beast (TCP)
    Host/Port = 127.0.0.1:30005
    FR24 settings - External dump1090 - BEAST-TCP.png



    OR
    uninstall dump1090-fa by following command:

    sudo apt-get remove dump1090-fa

    You can use following settings only after removal of dump1090-fa
    Receiver = DVBT Stick (default)
    FR24 settings - Integral dump1090.png
    Last edited by abcd567; 2019-06-22 at 06:19.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •