Page 13 of 64 FirstFirst ... 311121314152363 ... LastLast
Results 121 to 130 of 639

Thread: Flightradar24 decoder/feeder BETA testing (Win/RPi/Linux/OSX)

  1. #121
    Passenger
    Join Date
    Oct 2013
    Posts
    10

    Request for additional functionality - ARM7 Support

    Request for additional functionality - ARM7 Support

    dump1090 doesn't have to run on just Raspberry Pi's and neither should fr24feed

    ARM7 computers have hardware floating point support and other features that run faster than the Raspberry Pi ARM6 computer.

    Having an additional installation package for ARM 7 would be really nice.

    Blort

  2. #122
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    We can make an ARM7 build, same with the --version thing, sounds useful for us too.

    I will investigate the plugin option, but can't promise anything at this stage. You can probably already use our feeder by taking RAW data from the ADSB# application.

  3. #123
    Passenger
    Join Date
    May 2012
    Posts
    10
    Almost a week running seamlessly the new fr24 feeder (fr24feed_1.0.0-1 to fr24feed_1.0.2-1 as of today)
    CPU usage < 1% on the Raspberry
    Would be nice to be able to easily switch logging to /var/log off though

    Only remaining issue in the Settings web interface : when selecting "AVR (TCP)" in the "Receiver" type dropdown list and hitting the Save button, the saved value in fr24feed.ini ends being "avrtcp" where it should be "avr-tcp" (I had to edit the config file manually to get the feeder to work)

    Thanks

  4. #124
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    Thanks for a report, will fix it and add an option to disable logging as well.

  5. #125
    Captain
    Join Date
    Jan 2012
    Location
    Dudley area, UK
    Posts
    1,410
    Quote Originally Posted by piopawlu View Post
    Thanks for a report, will fix it and add an option to disable logging as well.
    On the logging FA feeder does log - but just keeps today and yesterday - a good compromise,

    so maybe the switch can be --logfiledays
    0 no logfile
    1 one day (today)
    2 two days (today and yesterday)

  6. #126
    Passenger
    Join Date
    Oct 2014
    Posts
    42
    My dump1090 crashed after 5 days of uptime. Only a reboot solved the issue. How often do you restart the fr24 service?

  7. #127
    Captain
    Join Date
    Jan 2012
    Location
    Dudley area, UK
    Posts
    1,410
    Can we run the new feeder on the Pi from the raw data from Malcom Robbs dump1090?

    If so, exactly what command switches do you need on dump1090 and on your feeder?

  8. #128
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    Yes, you can do it in one of two ways:

    1. Have the Malcom Robbs dump1090 invoked by fr24feed:
    In that case just edit /etc/fr24feed.ini (path) or supply --path="/path/to/dump1090 --your --own --arguments", please note that fr24feed will append "--raw" to the end.

    2. Attach to a running dump1090 via TCP:
    In that case you need to start dump1090 yourself and make sure to run it with --net. Then configure fr24feed to use receiver type "AVR over Network" with "--receiver=avr-tcp" and "--host=localhost:30002".

  9. #129
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    Quote Originally Posted by giacomo892 View Post
    My dump1090 crashed after 5 days of uptime. Only a reboot solved the issue. How often do you restart the fr24 service?
    Was it the dump1090 that crashed or the entire thing? Do you have any output from fr24feed logs? Did it try to restart?

  10. #130
    Passenger
    Join Date
    Oct 2014
    Posts
    42
    Quote Originally Posted by piopawlu View Post
    Was it the dump1090 that crashed or the entire thing? Do you have any output from fr24feed logs? Did it try to restart?
    The feeder was up. dump1090 was stuck. I tried to restart the service but dump1090 refused to come up.
    I tried to run it from command line. It showed the dongle but stuck there. No msg decoded.
    Rebooted the pi and all was online. I've to say i'm running the latest MalcomRobb version.

    Maybe USB related things??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •