Page 39 of 64 FirstFirst ... 29373839404149 ... LastLast
Results 381 to 390 of 639

Thread: Flightradar24 decoder/feeder BETA testing (Win/RPi/Linux/OSX)

  1. #381
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    Thanks for all the feedback!

    @eshabi, will test that scenario,, even if it seems unlikely
    @blort, seems like DNS resolves to incorrect server to get the feeder config,, can you ping feed.flightradar24.com?
    @StDt, was that the last message in the log? No termination information or anything?

  2. #382
    Passenger
    Join Date
    May 2014
    Posts
    19
    Quote Originally Posted by piopawlu View Post
    @eshabi, will test that scenario,, even if it seems unlikely
    When I tried to use the feeder to run dump1090 (external or included) using the configuration "path=" option and connect to its avr-tcp data on port 30002, it crashed.
    Tried to run them sequentially using a batch file - crashed.
    Added a delay in the batch file between running dump1090 and the feeder using "timeout /T 3" command - runs okay. This is my current configuration.
    Tried now to run the feeder with no dump1090 running - crashed.

    this is my config file:
    receiver="avr-tcp"
    fr24key=""
    host="localhost:30002"
    bs="no"
    raw="no"
    logmode="2"
    Last edited by eshabi; 2015-01-26 at 15:03.
    F-LLBG3, T-LLBG17

  3. #383
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    Thanks, this bug is confirmed on Windows platform. A fix will be issued most likely tomorrow morning.

  4. #384
    Passenger
    Join Date
    Jan 2015
    Location
    London, UK
    Posts
    36
    Quote Originally Posted by piopawlu View Post
    You can change the global timeout parameter in your /etc/fr24feed.ini config file or stop/start service night time if your range is reduced to local traffic. But a fix should be available tomorrow.
    PHP Code:
    2015-01-26 02:43:30 | [feed][n]ping 12
    2015
    -01-26 02:43:36 | [reader][w][0]Global timeout exceeded0 msgs0 resyncsreconnecting
    2015
    -01-26 02:43:36 | [reader][i][0]Connection terminated
    2015
    -01-26 02:43:36 | [main][i]Terminating child process 3089 with SIGETERM
    2015
    -01-26 02:43:42 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090  --raw)
    2015-01-26 02:43:42 | [reader][i][0]Connected to the receiverauthenticating
    2015
    -01-26 02:43:42 | [reader][i][0]Authenticatedprocessing messages
    2015
    -01-26 02:43:42 | [reader][i][0]Connection terminated
    2015
    -01-26 02:43:42 | [main][i]Terminating child process 3104 with SIGETERM
    2015
    -01-26 02:43:47 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090  --raw)
    2015-01-26 02:43:47 | [reader][i][0]Connected to the receiverauthenticating
    2015
    -01-26 02:43:47 | [reader][i][0]Authenticatedprocessing messages
    2015
    -01-26 02:43:47 | [reader][i][0]Connection terminated
    2015
    -01-26 02:43:47 | [main][i]Terminating child process 3105 with SIGETERM
    2015
    -01-26 02:43:53 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090  --raw)
    2015-01-26 02:43:53 | [reader][i][0]Connected to the receiverauthenticating
    2015
    -01-26 02:43:53 | [reader][i][0]Authenticatedprocessing messages
    2015
    -01-26 02:43:53 | [reader][i][0]Connection terminated
    2015
    -01-26 02:43:53 | [main][i]Terminating child process 3106 with SIGETERM
    2015
    -01-26 02:43:58 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/dump1090  --raw)
    2015-01-26 02:43:58 | [reader][i][0]Connected to the receiverauthenticating
    2015
    -01-26 02:43:58 | [reader][i][0]Authenticatedprocessing messages
    2015
    -01-26 02:43:59 | [reader][i][0]Connection terminated
    2015
    -01-26 02:43:59 | [main][i]Terminating child process 3107 with SIGETERM 
    This is still happening to me some nights around 2am. But other nights it's fine... What do you think I should change the timeout parameter to?

  5. #385
    Passenger
    Join Date
    Jan 2015
    Location
    Germany - T-EDDN41 - T-EDQD17
    Posts
    14
    Quote Originally Posted by piopawlu View Post
    Thanks for all the feedback!
    ...
    @StDt, was that the last message in the log? No termination information or anything?
    No sorry, nothing. The log ran all over the day.
    Are there further log-files I could look after?

    Same thing happened later:

    Code:
    ...
    2015-01-26 11:11:39 | [feed][i]sent 4 AC in 1 packet
    2015-01-26 11:11:44 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 11:11:49 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 11:11:51 | [feed][i]removed 3 of 12 AC
    2015-01-26 11:11:54 | [feed][i]sent 4 AC in 1 packet
    2015-01-26 11:11:59 | [feed][i]removed 1 of 10 AC
    2015-01-26 11:11:59 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 11:12:04 | [feed][i]sent 7 AC in 1 packet
    2015-01-26 11:12:09 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 11:12:14 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 11:12:19 | [feed][i]sent 7 AC in 1 packet
    2015-01-26 11:12:24 | [feed][i]sent 5 AC in 1 packet
    2015-01-26 18:49:08 | [main][i]FR24 Feeder/Decoder [0x02117000]
    2015-01-26 18:49:08 | [main][i]Version: 1.0.10-5/generic
    2015-01-26 18:49:08 | [main][i]Built on Jan 12 2015 16:03:50 (r:???/MacOSX/Universal)
    2015-01-26 18:49:08 | [main][i]Copyright 2008-2015 (c) Piotr Pawluczuk
    2015-01-26 18:49:08 | [main][i]Flightradar24 AB(http://flightradar24.com)
    2015-01-26 18:49:08 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2015-01-26 18:49:08 | [main][i]Reader 0 started
    2015-01-26 18:49:08 | [master][i]Starting processing thread
    2015-01-26 18:49:08 | [reader][i][0]Initializing reader
    2015-01-26 18:49:08 | [main][i]Socket server started
    2015-01-26 18:49:08 | [bs][i]Initializing server
    2015-01-26 18:49:08 | [reader][i][0]Connecting to Generic receiver via (exe:///Applications/FR24FeedOSX.app/Contents/Resources/dump1090  --raw)
    2015-01-26 18:49:08 | [time][i]Synchronizing time via NTP
    2015-01-26 18:49:08 | [bs][i]Starting server on 0.0.0.0:30003
    2015-01-26 18:49:08 | [reader][i][0]Connected to the receiver, authenticating
    2015-01-26 18:49:08 | [reader][i][0]Authenticated, processing messages
    2015-01-26 18:49:12 | [time][i]Time synchronized correctly, offset -0.0053 seconds
    2015-01-26 18:49:12 | [main][i]Feed Network client started
    2015-01-26 18:49:12 | [main][i]RAW data server started
    2015-01-26 18:49:12 | [feed][i]Downloading configuration
    2015-01-26 18:49:12 | [raw][i]Initializing server
    2015-01-26 18:49:12 | [raw][i]Starting server on 0.0.0.0:30002
    2015-01-26 18:49:12 | [feed][c]Interval: 5s
    2015-01-26 18:49:12 | [feed][c]Latitude: 49.XX00
    2015-01-26 18:49:12 | [feed][c]Longitude: 11.XX00
    2015-01-26 18:49:12 | [feed][c]GND: YES
    2015-01-26 18:49:12 | [feed][c]NonADSB: YES
    2015-01-26 18:49:12 | [feed][c]Timestamps: optional
    2015-01-26 18:49:12 | [feed][c]Max range AIR: 350.0nm
    2015-01-26 18:49:12 | [feed][c]Max range GND: 100.0nm
    2015-01-26 18:49:12 | [stats][i]Stats thread started
    2015-01-26 18:49:12 | [feed][i]defined 1 server
    2015-01-26 18:49:12 | [feed][n]EDDN41@83.140.21.66:8099/UDP
    2015-01-26 18:49:12 | [feed][n]connecting
    2015-01-26 18:49:12 | [feed][n]connected
    2015-01-26 18:49:12 | [feed][n]switching to UDP
    2015-01-26 18:49:12 | [feed][n]working
    2015-01-26 18:49:17 | [feed][i]sent 4 AC in 1 packet
    2015-01-26 18:49:22 | [feed][i]sent 5 AC in 1 packet
    2015-01-26 18:49:27 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 18:49:32 | [feed][i]sent 5 AC in 1 packet
    2015-01-26 18:49:37 | [feed][i]sent 5 AC in 1 packet
    2015-01-26 18:49:42 | [feed][i]sent 4 AC in 1 packet
    2015-01-26 18:49:47 | [feed][i]sent 3 AC in 1 packet
    2015-01-26 18:49:52 | [feed][i]sent 5 AC in 1 packet
    2015-01-26 18:49:57 | [feed][i]sent 5 AC in 1 packet
    2015-01-26 18:50:02 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 18:50:07 | [feed][i]sent 6 AC in 1 packet
    2015-01-26 18:50:12 | [feed][i]sent 6 AC in 1 packet
    ...
    Last edited by StDt; 2015-01-26 at 18:31.

  6. #386
    Passenger
    Join Date
    Oct 2013
    Posts
    10
    Yes I can ping feed.flightradar24.com:

    ping feed.flightradar24.com
    PING got.fr24.com (83.140.21.89) 56(84) bytes of data.
    64 bytes from 83.140.21.89.biz.sta.port80.se (83.140.21.89): icmp_seq=1 ttl=53 time=202 ms
    64 bytes from 83.140.21.89.biz.sta.port80.se (83.140.21.89): icmp_seq=2 ttl=53 time=205 ms
    ^C
    --- got.fr24.com ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 1001ms
    rtt min/avg/max/mdev = 202.473/203.850/205.227/1.377 ms

    Yet I still get this:

    2015-01-26 23:34:48 | [feed][i]Failed on start, Sleeping 120 seconds
    2015-01-26 23:36:48 | [feed][i]Downloading configuration
    2015-01-26 23:36:49 | [e]HTTP Response: [HTTP/1.1 404 Not Found]
    2015-01-26 23:36:49 | [feed][i]Failed on start, Sleeping 120 seconds
    2015-01-26 23:38:46 | [time][i]Synchronizing time via NTP
    2015-01-26 23:38:49 | [feed][i]Downloading configuration
    2015-01-26 23:38:49 | [e]HTTP Response: [HTTP/1.1 404 Not Found]
    2015-01-26 23:38:49 | [feed][i]Failed on start, Sleeping 120 seconds
    2015-01-26 23:38:51 | [time][i]Time synchronized correctly, offset -0.0007 seconds, drift -0.0000 seconds/minute


    Blort

  7. #387
    Passenger
    Join Date
    Jan 2015
    Location
    Germany - T-EDDN41 - T-EDQD17
    Posts
    14
    @piopawlu

    Same thing happened again and again.

    First I thought it would be the WLAN connection that breaks or interrupts the feeding.

    Then I tried a LAN cable connection. Same thing happening. (The feeding stops/breaks after a few hours/minutes, the log shows nothing at all - it stops logging)

    Any hints?

  8. #388
    Flight attendant Wolli's Avatar
    Join Date
    Dec 2014
    Location
    Germany
    Posts
    82

    feeder download (Win) "not found"

    @StDt: Maybe a firewall problem?

    @Piotr, page http://feed.flightradar24.com/windows/ click on "fr24feed_win32-1.0.11-5.zip" shows "404 - Not Found".

    Regards, -Wolli-
    Last edited by Wolli; 2015-01-27 at 16:06.

  9. #389
    Passenger
    Join Date
    Jan 2015
    Location
    Germany - T-EDDN41 - T-EDQD17
    Posts
    14
    Quote Originally Posted by Wolli View Post
    @StDt: Maybe a firewall problem?
    Regards, -Wolli-
    Nope, then it wouldn't feed at all.
    The log shows it is feeding. But after some time (minutes or hours) the feeding app doesn't feed anymore.

  10. #390
    Flight attendant Wolli's Avatar
    Join Date
    Dec 2014
    Location
    Germany
    Posts
    82
    @StDt: Yep, you're right, of course. My statement was an idea to blort's problem. Please excuse.

    @blort: Seems imho, that the feeder does not at all connect to the FR24 server. Might the reason be a firewall issue on your side? Just an interim possibility (while waiting for Piotr's answer). Good luck however, -Wolli-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •