Page 69 of 71 FirstFirst ... 19596768697071 LastLast
Results 681 to 690 of 707

Thread: Linux feeder software for Flightradar24 (Old software)

  1. #681
    First officer
    Join Date
    Mar 2014
    Location
    T-YBBN30
    Posts
    233
    Quote Originally Posted by jepolch View Post
    Thanks for telling me that. The more I find out about other sites, the better I like FlightAware. By the way, I was watching a FedEX flight on FR24 that was heading for KORF. When the tracking stopped he kept right on tracking out over the ocean for about five minutes. FR24 guessing.
    hehe likely, they said the broken lines are supposed to be the guesses, but I've seen solid lines too, a rescue helo I know landed on the mountain peak behind me, was shown on FR as continuing on for a great distance before vanishing mid flight had they accepted my likely single signal at the time, they would have seen it had landed (havent taken much notice to see if thats still the case, wouldnt take me long to confirm though since they put a helipad up there because bikies are notorious for speeding and taking corners wide trying to kill themselves over the often very narrow winding mountain road)

    I mean I accept and understand they want accuracy, but at same time, in trying to be so accurate, they are just making it the opposite. Though stuffs me how you want high level accuracy yet allow for these guesses which must be far worse than a single uploader source.

    Just looked at piaware, yewwww TCL? (reminds me of hte old IRC scripts days) anyway I installed source, and its tcllauncher requirement but because whoever wrote it understands debian and not linux in general, I have a major rewrite to do to get it to run here, and since its 36.3c and 71% humidity and I/ADSB gear is not in a part of the place with aircon kinda = not happening today

  2. #682
    Passenger
    Join Date
    May 2013
    Posts
    1
    Hi

    I can connect fr24feeder to my dump1090.

    My setup is the follow:
    Hex Mode Sqwk Flight Alt Spd Hdg Lat Long Sig Msgs Ti|
    -------------------------------------------------------------------------------
    44ce77 S 61 4 53
    400d91 S 1110 EZY39MN 34300 415 230 45.492 9.020 130 132 0
    4caa96 S 0231 SDM6273 7750 250 231 45.471 9.037 119 386 3
    4b17b3 S 4637 26975 76 112 9

    RTL device on OpenWRT router. It is working fine, i've tested with local web service and shows all planes on map

    pi@raspberrypi ~ $ sudo fr24feed
    [main][i]FR24 Feeder/Decoder [0x02117000]
    [main][i]Version: 1.0.9-2/generic
    [main][i]Built on 20141219-1257 (r:master-e132735.git/Linux/armv6l)
    [main][i]Copyright 2008-2014 (c) Piotr Pawluczuk
    [main][i]Flightradar24 AB(http://flightradar24.com)
    [main][i]Reader 0 started
    [time][i]Synchronizing time via NTP
    [reader][i][0]Initializing reader
    [reader][i][0]Connecting to Generic receiver via (tcp://192.168.1.2:30003)
    [master][i]Starting processing thread
    [reader][i][0]Connected to the receiver, authenticating
    [reader][i][0]Authenticated, processing messages
    [time][i]Time synchronized correctly, offset -0.0005 seconds
    [main][i]Feed Network client started
    [feed][i]Downloading configuration
    [feed][c]Interval: 5s
    [feed][c]Latitude: 45.4800
    [feed][c]Longitude: 9.2200
    [feed][c]GND: YES
    [feed][c]NonADSB: YES
    [feed][i]defined 1 server
    [feed][n]LIML20@83.140.21.66:8099/UDP
    [feed][n]connecting
    [i][stats]Stats thread started
    [feed][n]connected
    [feed][n]switching to UDP
    [feed][n]working



    But in FR web page my account said:

    Stats for: Offline
    Uptime (as % of available time): 0.3%
    Aircraft seen: 0
    Positions reported: 0
    Maximum distance: 0nm
    Status: Offline
    Current upload rate: 0 KB/s

    Could you help me?

    I execute dump1090 with these parameters:

    dump1090 --interactive --net --aggressive --quiet --enable-agc &


    With is the correct option to connect fr24feeder to an external dump1090 over the same network?


    Best regards!!


    PS: My dump1090 web map is located here -> http://italia.ayasystems.com:8080/

  3. #683
    Flight attendant
    Join Date
    Aug 2013
    Location
    5 km NE of EHEH
    Posts
    52
    I have been playing with the 'kalibrate' program. At the end it says: "Average absolute error: -18.056".
    What should I put on the dump1090 command line?
    --ppm -18 (note the minus sign)
    OR
    --ppm 18 (note no minus sign)
    I know the error is neglectable and will drift, but I am just curious. (There are dongles with a temperature compensated oscillator)

  4. #684
    Passenger
    Join Date
    Jan 2015
    Location
    Italy T-LIMC13
    Posts
    3
    Hello, I have more or less the same problems.
    I use Raspberry and with the old software it worked fine.

    Before I used the following:
    sudo ./dump1090 --ppm -6 --interactive --net --modeac --enable-agc --gain -10 --lat 46.558424 --lon 9.786614 &
    ./fr24feed_arm-rpi_242 --fr24key=1234567890123456 &

    (The coordinates and the key are not real)
    Anyway everything worked with no problems.
    The I experienced some problems, because on the dump1090 some planes were shown but they were no more uploaded on FLightRadar.
    This is a strange thing and I don't know exactly where the problem was.
    My coverage decreased day by day during those days.
    At the end I concluded that maybe it was a problem due to the power supply, my usb stick need to much power and the raspberry was not enable to provide it (or the its power supply).

    From the reception point of view I solved the problems buying an powered usb hub and using a much powerful power supply for the raspberry.

    It is not yet the same from the software point of view.
    The old software is still working fine, but not the new one.

    Then I discovered that the new beta software was release and I installed it.
    Since I want to check the coverage of my antenna I would like to use the Malcolm Robb version of dump1090 which includes the http page.
    My initial configuration was the following:

    /etc/fr24feed.ini

    receiver="dvbt"
    fr24key="1234567890123456"
    path="/usr/lib/fr24/dump1090"
    bs="yes"
    raw="yes"
    logmode="2"
    windowmode="0"
    mpx="no"

    The staus command reports:
    pi@pi ~ $ service fr24feed status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2015-02-19 12:21:23.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-LIMCXX.
    [ ok ] FR24 Tracked AC: 11.
    [ ok ] Receiver: connected (4964 MSGS/0 SYNC).

    But no data are uploaded on FlightRadar as far as I was able to see.
    I appear online, but no plane are uploaded.

    Mine preffered configuration would be the following:

    pi@pi ~ $ cat /etc/fr24feed.ini
    receiver="dvbt-mr"
    fr24key="1234567890123456"
    host="192.168.1.250"
    path="/usr/lib/fr24/mr-dump1090"
    bs="no"
    raw="no"
    logmode="2"
    procargs="--ppm -6 --interactive --net --modeac --enable-agc --gain -10 --lat 46.558424 --lon 9.786614"
    windowmode="0"
    mpx="no"

    With it the local http page works and planes are visible on the map.
    But the status is the follwing:

    pi@pi ~ $ service fr24feed status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2015-02-19 12:46:43.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-LIMCxx.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (0 MSGS/0 SYNC).

    No planes are recorded inside the local history file, no planes are upload on flightradar where I appear offline.

    What I see inside the log is the following:

    pi@pi ~ $ cat /var/log/fr24feed.log
    2015-02-19 13:41:30 | [main][i]FR24 Feeder/Decoder [0x02117000]
    2015-02-19 13:41:30 | [main][i]Version: 1.0.12-3/generic
    2015-02-19 13:41:30 | [main][i]Built on 20150209-1316 (r:master-0a6ad34.git/Linux/armv6l)
    2015-02-19 13:41:30 | [main][i]Copyright 2008-2015 (c) Piotr Pawluczuk
    2015-02-19 13:41:30 | [main][i]Flightradar24 AB(http://flightradar24.com)
    2015-02-19 13:41:30 | [main][i]DNS mode: LIBC
    2015-02-19 13:41:30 | ERROR
    2015-02-19 13:41:30 | [main][i]Reader 0 started
    2015-02-19 13:41:30 | [time][i]Synchronizing time via NTP
    2015-02-19 13:41:30 | [reader][i][0]Initializing reader
    2015-02-19 13:41:30 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/mr-dump1090 --ppm -6 --interactive --net --modeac --enable-agc --gain -10 --lat 46.558424 --lon 9.786614 --raw)
    2015-02-19 13:41:31 | [reader][i][0]Connected to the receiver, authenticating
    2015-02-19 13:41:31 | [master][i]Starting processing thread
    2015-02-19 13:41:31 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2015-02-19 13:41:31 | [reader][i][0]Authenticated, processing messages
    2015-02-19 13:41:35 | [time][i]Time synchronized correctly, offset +0.0004 seconds
    2015-02-19 13:41:35 | [main][i]Feed Network client started
    2015-02-19 13:41:35 | [feed][i]Downloading configuration
    2015-02-19 13:41:35 | [feed][c]Interval: 5s
    2015-02-19 13:41:35 | [feed][c]Latitude: 46.5584
    2015-02-19 13:41:35 | [feed][c]Longitude: 9.7866
    2015-02-19 13:41:35 | [feed][c]GND: YES
    2015-02-19 13:41:35 | [feed][c]NonADSB: YES
    2015-02-19 13:41:35 | [feed][c]Timestamps: optional
    2015-02-19 13:41:35 | [feed][c]Max range AIR: 350.0nm
    2015-02-19 13:41:35 | [feed][c]Max range GND: 100.0nm
    2015-02-19 13:41:35 | [feed][i]defined 1 server
    2015-02-19 13:41:35 | [feed][n]LIMCxx@83.140.21.66:8099/UDP
    2015-02-19 13:41:35 | [feed][n]connecting
    2015-02-19 13:41:35 | [stats][i]Stats thread started
    2015-02-19 13:41:35 | [feed][n]connected
    2015-02-19 13:41:35 | [feed][n]switching to UDP
    2015-02-19 13:41:36 | [feed][n]working
    2015-02-19 13:42:06 | [feed][n]ping 1
    2015-02-19 13:42:36 | [feed][n]ping 2


    The only thing I noticed is that on the folowing line there is always the --raw option:
    2015-02-19 13:41:30 | [reader][i][0]Connecting to Generic receiver via (exe:///usr/lib/fr24/mr-dump1090 --ppm -6 --interactive --net --modeac --enable-agc --gain -10 --lat 46.558424 --lon 9.786614 --raw)

    I never added --raw but it is always present.

    Where is the mistake?

    Thank you so much for your help and sorry if the solution is already known, but I didn't have the time to read all the posts of this thread.

    Bye, Leonardo.

  5. #685
    Administrator piopawlu's Avatar
    Join Date
    Mar 2011
    Location
    Sweden
    Posts
    226
    The mistake is that you have the "--interactive" mode selected which should be used ONLY when you are looking at the terminal to see the aircraft table etc. This mode prevents the "--raw" option which gives raw frames on stdout for FR24 app to process. Remove the "--interactive" and it should work.

  6. #686
    Passenger
    Join Date
    Jan 2015
    Location
    Italy T-LIMC13
    Posts
    3
    Thank you for your reply, I am going to try.

    What it is strange is that now, with the old configuration, I don't see incresing the number of planes uploaded.

    Let's try the new software without the --interactive parameter.

    Thank you.
    Bye.

  7. #687
    Passenger
    Join Date
    Jan 2015
    Location
    Italy T-LIMC13
    Posts
    3
    Great, it works!
    Fantastic!
    Thank you very much.

    Congratulation, great software.

    Leonardo.
    T-LIMC13

  8. #688
    Passenger
    Join Date
    Feb 2015
    Location
    Sverigeland
    Posts
    4
    The linux (raspberry pi) fr24feed writes every 5 seconds a status message to /var/log/fr24feed.log
    If you want to keep this file within reasonable limits, you should create a file /etc/logrotate.d/fr24feed with this content:

    ---------------
    /var/log/fr24feed.log {
    daily
    rotate 7
    delaycompress
    compress
    missingok
    copytruncate
    notifempty
    postrotate
    logger -i -t logrotate "fr24feed logrotate ran a few seconds ago"
    endscript
    }
    -----------------

    This keeps last 7 logs and deletes older ones. Last log is uncompressed for your reading pleasure.
    Older logs are compressed to save space but still easily readable with zless.

    You get a message in /var/log/syslog every time the log file is rotated.

    Enjoy.

  9. #689
    Passenger
    Join Date
    Mar 2015
    Posts
    18
    Hi Could any feeders/members give me some guidance on how to install the Raspberry pi fr24feed .tgz package option (without dump1090 as I already have this running).
    I want to retain my version of dump1090.
    As i understand things , the tgz is a compressed file.
    I take it this is okay for installs on Rpi model B,B+ and 2 ?
    I have taken a look at fr24feed installation manual but this option is not covered as far as i can see but it is a download option.
    From the rpi command line can someone please post the installation steps please, Thank You in advance.

  10. #690
    Passenger
    Join Date
    Mar 2015
    Location
    NW Tasmania
    Posts
    7
    This is my method:

    mkdir fr24
    cd fr24
    wget https://dl.dropboxusercontent.com/u/...rm-rpi_242.tgz

    tar xvfz fr24feed_arm-rpi_242.tgz
    fr24feed_arm-rpi_242 --signup
    ./fr24feed_arm-rpi_242 --fr24key=aaaaaaaa

    this will have your installation running but it will stop when you log out

    to keep running after logging out use:

    cd fr24
    nohup ./fr24feed_arm-rpi_242 --fr24key=aaaaaaaa &

    There are lots of different ways to automate the startup but for now, I do it manually.

    I am running on a Pi2 but it should be the same for all versions.

    Jim

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •