Page 20 of 71 FirstFirst ... 1018192021223070 ... LastLast
Results 191 to 200 of 707

Thread: Linux feeder software for Flightradar24 (Old software)

  1. #191
    Join Date
    Feb 2013
    London, UK
    I think it is a mistake on FR24's part, that the FR24 feeder software for linux is not "open source".

    If this was the case, we would be able to understand exactly what 'removed 15 from 50AC', and problems with timestamps mean, as well as enable us to offer improvements to the FR24 feeder software.

    Also, I am not really happy to run closed-source software from within my firewalled LAN. It's not that I don't trust FR24, but .....

    My RPi gets its time from a cheap USB GPS dongle, and incidentally, then acts as a stratum 0 ntp server for my LAN as well as sending data to FR24. It is currently reporting local network time as accurate to within 900nS, which is good enough for my network. If I wired up a 1PPS signal from the GPS to the RPi, the accuracy would be very much better, and good enough for MLAT I think.

    For discussions about the RPi, Open Source software, GPS and ntp, I think it might be better to start a new thread as "Linux-feeder-software-for-Flightradar24" really is not the place for these discussions.

    Perhaps "linux, RPi and FR24"?

    I'll open a new thread in a moment, and see what deveolps....

  2. #192
    Flight attendant
    Join Date
    Mar 2012
    Almaty, Kazakhstan
    Quote Originally Posted by mindlesstux View Post
    Seeing how you are using a raspberry pi, im gonna guess you are using dump1090. I noted similar lines and found that it is due to a lack of timestamps in the data that fr24 uses.

    I found that a fork of dump1090 offered them and seems a little better on my pi's resources.

    Also make sure your pi's datetime is current, should automatically do so on boot, but I would look into making sure the ntp service is running throughout the day to keep your system clock fairly current/accurate.
    Thank you for reply.
    I'am using adsbox with modesbeast.
    Yes, i had an idea that it happens because of incorrect time. But even after I've installed ntp to keep time synchronized it continues write "[e] Data feed time difference too big abs ..." but after a while it starts to send packets.

  3. #193
    Join Date
    Apr 2013
    Quote Originally Posted by Walt View Post

    Adsbox decoding is fully compatible with FR24. I use adsbox nearly a year. You can write to the author and receive the latest version (I use version from July 28).

    I'm trying to to use adsbox with flightradar feeder but without success. My current setup is made of a microadsb receiver, a guruplug server (ARM cpu) running Debian, adsbox (20130224) and fr24feed_arm-le-232s. I can see the planes on adsbox page and can also get the messages from telnet to port 30003, but when I try to use fr24 feeder, i got this error messages:

    [e]Data feed time difference too big abs( - )=33135
    [e]Data feed time difference too big abs( - )=32092
    [e]Data feed time difference too big abs( - )=29725

    I also find that if I ran a adbscope on another (windows) machine (using the raw client option to get the messages from adsbox) and use the windows feeder it works. Investigating further, i found that asbox doesnt insert time on the messages while adbscope do. Is there any special configuration that i should use?

  4. #194
    First officer nzradar's Avatar
    Join Date
    Apr 2011
    Palmerston North, New Zealand (T-NZPM21)
    It seems that the pseudo port 30003 data stream that I am using is the cause of my Linux 232s feeder problem I alluded to in an earlier post. I've been testing some Linux decoding software and the port 30003 data seems slightly different from PlanePlotter which I used in the initial test. So it's not the feeder that is the problem it is the data. I will communicate this directly with support.
    Palmerston North,
    New Zealand
    ex-FR24 Feeder

  5. #195
    Join Date
    Jun 2012
    Quote Originally Posted by GraemeH View Post
    Does this Linux software run on full Mac OS 10.8.3?
    Is it easy to set up? I am using SBS-3 and basestation.
    Hi GraemeH !

    My BaseStation.exe and fr24feed_x86_225 is working on Linux using wine(wine-1.0.1-1.el5).
    I'm using CentOS5(x86/64bit), It's so easy to install.
    (I don't know how to install wine on Mac OS 10)
    Why don't you try?

    Last edited by shogun02; 2013-05-01 at 12:08.

  6. #196
    Join Date
    Jan 2012
    Dudley area, UK
    I have my RPi and soon should receive a RTL2832U+R820T USB stick. I'd like to set it up for FR24. Reading through this thread leaves me confused since it's both full of what to do and how to fix.
    Would it be possible to do a new 'How To' thread that just has the facts of
    These are the logical blocks to put together to make this work (in my case 'RTL2832U+R820T + RPi to feed FR24' ) and these are the software steps needed to install everything needed - Maybe by Roofer (helpful guy )
    The next item might be 'Micro-USB stick + Windows 7 to feed FR24'
    The next getting GPS to work with RPi for FR24 - with whatever prerequisites are required (building on what has already been described)
    ...and so on.
    The author of the original item edits it to keep it up to date - discussions / questions are directed to a thread elsewhere set up for the purpose to discus the particular config.

  7. #197
    Super Moderator speedbird1960's Avatar
    Join Date
    May 2010
    Runcorn / LPL
    This post should help you

    If you get any problems there is always someone on here to help.
    AMS Daily Fight Information:

  8. #198
    Join Date
    Feb 2013
    London, UK
    Hello peterhr,

    Welcome to FR24!

    I am sorry that it isn't immediately obvious how to set up a RPi to work with all this stuff (RTL2832U+R820T, GPS stick etc.)

    The trouble is that linux is changing (improving) every day, and it is very difficult to keep up-to-date and current.

    I managed to feed to FR24 with my RPi and my USB RTL2838 DVB-T by following this very thread.

    I realise it is a long thread, and it certainly is not "click & play", but by following it, and trying things out, all the information was eventually good, and it worked for me.

    Sometimes, when I am playing with linux I make copious notes, about what, exactly, I did, what happened, and what I did to fix it and make it work.

    Unfortunately, this is not one of those times, so I cannot just send you my notes.

    I invite you to make a start, and do your best. If /when you run into problems, perhaps post here as that might be the place for the RPi and FR24 and linux, as opposed to "linux feeder software for FR24", because your question isn't so much about which version of the FR24 feeder software to use but is more about "How to make linux on the RPi work with FR24?"

    Best wishes.

  9. #199
    Passenger inquisitor's Avatar
    Join Date
    Jul 2012
    close to EDDS, Germany
    Today I saw that fr24feed v 232s had connected to which is some incredible 330ms from me, despite latency to European servers is just 39ms. Could it be that there's an issue with the server selection routine in this version? Given this delay it's hardly surprising that I haven't seen a single flight fed by me all day.
    feeding data as EDDS9 through a Raspberry Pi with RTL2832U+R820T USB stick

  10. #200
    Join Date
    May 2013
    Hi all
    I've been using fr24feed_arm-le_232 for a few days. Unfortenately it hangs after some hours of usage.
    I use an fully updated rpi with following kernel:
    Linux rpi 3.6.11+ #371 PREEMPT Thu Feb 7 16:31:35 GMT 2013 armv6l GNU/Linux
    The usage pattern always ends with following traces
    [i]sent 3 planes in 1 packets
    [i]sent 3 planes in 1 packets
    [i]sent 3 planes in 1 packets
    [n]pinging the server
    [n]waiting 8 seconds
    [n]switching to UDP
    Ending the program and restarting again runs it for another couple of hours.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts