Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: FR24 Feeder/Decoder: Version: 1.0.24-2/generic

  1. #11
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,049
    - Fixed Radarcape timestamp checking
    - Fixed avr-tcp receiver mode in no-mlat setting
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  2. #12
    Team FR24
    Join Date
    Feb 2015
    Posts
    221
    Version 1.0.24-4 should fix the broken feeds. If anyone is on version 1.0.24-2 and is having any problems please upgrade to 1.0.24.4.
    --

  3. #13
    Captain
    Join Date
    Apr 2018
    Posts
    863
    Hello Khan, on Odroid N2 running multiarch to run 32 bit applications, even with version 24-4 i still get the Bus error shortly after startup:

    Code:
    2019-10-10 01:50:52 | [feed][n]connecting
    2019-10-10 01:50:52 | [feed][n]connected via UDP (fd 25)
    2019-10-10 01:50:52 | [feed][i]Feed connected
    2019-10-10 01:50:52 | [feed][n]working
    2019-10-10 01:50:56 | [feed][i]sent 26,0 AC
    
    Thread 11 "th_master_tcp" received signal SIGBUS, Bus error.
    [Switching to LWP 32457]
    0x000fc7e4 in ?? ()
    The above is in gdb, maybe this gives you an idea of the problem.
    Can't make valgrind work sadly.

    Without gdb:
    Code:
    2019-10-10 01:52:47 | [feed][n]connecting
    2019-10-10 01:52:47 | [feed][n]connected via UDP (fd 25)
    2019-10-10 01:52:47 | [feed][i]Feed connected
    2019-10-10 01:52:47 | [feed][n]working
    Bus error
    Last edited by wiedehopf; 2019-10-10 at 09:08.

  4. #14
    Passenger
    Join Date
    Apr 2015
    Location
    Smedsby, Korsholm, Finland
    Posts
    23
    Quote Originally Posted by wiedehopf View Post
    He's getting the same bus error.

    The new version has a memory access error on some devices it seems.
    In other words bad programming or bad library, no clue.

    You can disable the auto-update and go back to the old version.
    If you want to do that, i'll provide some instructions here shortly.

    If you want to run dump1090 separately, you'll have to change /etc/fr24feed.ini to look like this:

    receiver="beast-tcp"
    fr24key="xxxxxxxxxxxxxxxx"
    host="127.0.0.1:30005"
    bs="no"
    raw="no"


    Then get rid of the auto-update:
    sudo rm /etc/cron.d/fr24feed_updater

    Install the old feed version:
    wget -O /tmp/fr24feed.deb https://repo-feed.flightradar24.com/...23-8_armhf.deb
    sudo dpkg -i /tmp/fr24feed.deb
    sudo systemctl restart fr24feed


    Note that running apt upgrade will again install the new fr24feed version which is defective at the moment.
    If you want to avoid that you can put a # in front of this line in /etc/apt/sources.list
    deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable

    This will stop automatic updates via apt upgrade.
    Or just don't run apt upgrade until the feeder is fixed.
    What's your hardware, Raspberry Pi?
    Ok! Thanks for the info!
    I will try to follow your instructions and see if I get the old FR24feed up and running again and accept the data from my separate installation of dump1090-mutability which I want to keep because it is honed and fine-tuned to the max and then block the autoupdate and comment flightradar24 from the apt sources list. Hope I don,t eff everything up because I'm not really getting along with Linux very well... Maybe I'll find some sparetime to do this tomorrow or late today.

    My Hardware is a Libre Computer "Le Potato" https://libre.computer/products/boards/aml-s905x-cc/ running 64-bit Armbian 5.2 testing Ubuntu 16.04.4

    The dump1090-mutability is compiled as 64-bit but the fr24-binaries was installed by using two extra helper libraries for 32-bit installation. Has worked like a charm for 14 months until now.

    The reason for me trying the "Le Potato" is that you can get twice the computing power at half the current consumption copared to Raspberry Pi3 which was the top of the line beginning of 2018 , the current consumption is of major importance at this remote island because of the lack of sunshine here up at 63 degrees North from November to January.

    I might get some time to fix it tomorrow.
    -Hans

  5. #15
    Captain
    Join Date
    Apr 2018
    Posts
    863
    Quote Originally Posted by HAm View Post
    Hope I don,t eff everything up because I'm not really getting along with Linux very well...
    Yeah, it would be nice if fr24feed fixed the Bus error or even offered an arm64 binary, woudn't hurt.

    If you need any further assistance with the modifications let me know.

    Oh if your dump1090-mutability until now was started by FR24 as i suspect, you might not want to change the fr24feed.ini settings.
    Just do the rest of the steps but leave the fr24feed.ini settings alone for now.

    Anyway if you change them, it is not a problem to reconfigure dump1090-mutability to automatically start if it doesn't right now.

  6. #16
    Passenger
    Join Date
    Apr 2015
    Location
    Smedsby, Korsholm, Finland
    Posts
    23

    Unhappy

    Quote Originally Posted by wiedehopf View Post
    Yeah, it would be nice if fr24feed fixed the Bus error or even offered an arm64 binary, woudn't hurt.

    If you need any further assistance with the modifications let me know.

    Oh if your dump1090-mutability until now was started by FR24 as i suspect, you might not want to change the fr24feed.ini settings.
    Just do the rest of the steps but leave the fr24feed.ini settings alone for now.

    Anyway if you change them, it is not a problem to reconfigure dump1090-mutability to automatically start if it doesn't right now.
    My dump1090-mutability was installed separately and starts automatically at every reboot. The fr24feed was installed afterwards and configured as s-beast reading the data at port 30005 at adress 127.0.0.1
    worked fine until yesterday morning.

    tried to install the old 1.0.23-8_armhf.deb but when using the wget as per your instruction it ended up as a 404 error... :

    sudo wget -O /tmp/fr24feed.deb https://repo-feed.flightradar24.com/...eb--2019-10-10 15:09:50-- https://repo-feed.flightradar24.com/...23-8_armhf.deb
    Resolving repo-feed.flightradar24.com (repo-feed.flightradar24.com)... 104.17.44.52, 104.17.43.52, 104.17.46.52, ...
    Connecting to repo-feed.flightradar24.com (repo-feed.flightradar24.com)|104.17.44.52|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2019-10-10 15:09:50 ERROR 404: Not Found.

    The funniest thing is that when following the same link I can download it to my Windows computer.
    Tried to get one of the older versions as per abcd567:s instructions but that ended up with the system telling me that a newer version is already installed and nothing is downloaded nor updated.

    So now I'm severely p....d off...
    How to get rid of the new flawed version and all its settings and get an older working version in place when installing according to abcd567 seems to be possible but rejected because there is already a newer one in place?
    -Hans

  7. #17
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    Quote Originally Posted by HAm View Post
    tried to install the old 1.0.23-8_armhf.deb but when using the wget as per your instruction it ended up as a 404 error... :

    sudo wget -O /tmp/fr24feed.deb https://repo-feed.flightradar24.com/...eb--2019-10-10 15:09:50-- https://repo-feed.flightradar24.com/...23-8_armhf.deb
    Resolving repo-feed.flightradar24.com (repo-feed.flightradar24.com)... 104.17.44.52, 104.17.43.52, 104.17.46.52, ...
    Connecting to repo-feed.flightradar24.com (repo-feed.flightradar24.com)|104.17.44.52|:443... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2019-10-10 15:09:50 ERROR 404: Not Found.

    The funniest thing is that when following the same link I can download it to my Windows computer.

    So now I'm severely p....d off...
    How to get rid of the new flawed version and all its settings and get an older working version in place when installing according to abcd567 seems to be possible but rejected because there is already a newer one in place?
    -Hans
    You are using commands copied outside a code tag. The URLs in these commands are shortened, and fail as Linux command. They work OK in a browser, hence you could download in Windows.

    Copy-paste commands below. These are within code tag, and are not shortened
    Code:
    ## First get rid of already installed new version
    sudo dpkg --purge fr24feed
    
    ## Now install old version
    wget https://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.23-8_armhf.deb
    sudo dpkg -i fr24feed_1.0.23-8_armhf.deb
    
    ## Get rid of the updator
    sudo rm /etc/cron.d/fr24feed_updater
    
    ## Checks
    apt-cache policy fr24feed                                                    
    
    ## Check receiver is NOT dvbt. It should be beast-tcp
    sudo nano /etc/fr24feed.ini
    
    ## Save file (Ctrl+o) and close (Ctrl+x)
    ## Restart fr24feed
    sudo systemctl restart fr24feed
    
    fr24feed-status
    Last edited by abcd567; 2019-10-10 at 16:49.

  8. #18
    Captain
    Join Date
    Apr 2018
    Posts
    863
    abcd is correct, i neglected to add code tags

    Anyway if dump1090 starts on its own, you need to change the configuration as described.

    I'm sure you'll have the problems resolved soon.

    @abcd, i'm not sure why you would purge the old installation, that will lead to the update cron file to be written again.
    Purging is only required in some cases.

  9. #19
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    Quote Originally Posted by wiedehopf View Post
    @abcd, i'm not sure why you would purge the old installation, that will lead to the update cron file to be written again.
    Purging is only required in some cases.
    You are right. I forgot about updater. Now I have added following command after installation command:

    sudo rm /etc/cron.d/fr24feed_updater

    I prefer purge over remove to get a better clean up.

  10. #20
    Passenger
    Join Date
    Apr 2015
    Location
    Smedsby, Korsholm, Finland
    Posts
    23
    Quote Originally Posted by abcd567 View Post
    You are using commands copied outside a code tag. The URLs in these commands are shortened, and fail as Linux command. They work OK in a browser, hence you could download in Windows.

    Copy-paste commands below. These are within code tag, and are not shortened
    Code:
    ## First get rid of already installed new version
    sudo dpkg --purge fr24feed
    
    ## Now install old version
    wget https://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.23-8_armhf.deb
    sudo dpkg -i fr24feed_1.0.23-8_armhf.deb
    
    ## Get rid of the updator
    sudo rm /etc/cron.d/fr24feed_updater
    
    ## Checks
    apt-cache policy fr24feed                                                    
    
    ## Check receiver is NOT dvbt. It should be beast-tcp
    sudo nano /etc/fr24feed.ini
    
    ## Save file (Ctrl+o) and close (Ctrl+x)
    ## Restart fr24feed
    sudo systemctl restart fr24feed
    
    fr24feed-status
    Took me ten minutes and now I'm up and running!
    Thank you all!

    oh6my@adsb-rx:~$ fr24feed-status
    * FR24 Feeder/Decoder Process: running
    * FR24 Stats Timestamp: 2019-10-10 17:23:40
    * FR24 Link: connected [UDP]
    * FR24 Radar: T-EFVA13
    * FR24 Tracked AC: 9
    * Receiver: connected (4969 MSGS/0 SYNC)
    * FR24 MLAT: ok [UDP]
    * FR24 MLAT AC seen: 9

    Hans

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •