Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: FR24 Link disconnected and nothing is uploaded. PlanePlotter and Plane Finder work OK

  1. #11
    Captain
    Join Date
    Apr 2018
    Posts
    863
    That looks good, let it run for a bit, check if any errors pop up.

    Maybe it just wasn't using the current configuration yet?
    (the website may not be able to restart fr24feed as it's a non standard installation)

    If it doesn't work, you can try adding these two lines to /etc/fr24feed.ini
    Code:
    use-http=yes
    http-timeout=20
    That may help, but i'm not sure what exactly it changes.
    Last edited by wiedehopf; 2019-10-03 at 16:12.

  2. #12
    Passenger
    Join Date
    Apr 2018
    Posts
    35
    [continuing]

    2019-10-03 17:08:28 | [feed][e]Could not connect!
    2019-10-03 17:08:28 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-03 17:08:28 | [feed][n]waiting 9 seconds
    2019-10-03 17:08:37 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-03 17:08:37 | [feed][n]connecting
    2019-10-03 17:11:07 | [feed][e]Could not connect!
    2019-10-03 17:11:07 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-03 17:11:07 | [feed][n]waiting 8 seconds
    2019-10-03 17:11:15 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-03 17:11:15 | [feed][n]connecting
    2019-10-03 17:13:45 | [feed][e]Could not connect!
    2019-10-03 17:13:45 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-03 17:13:45 | [feed][n]waiting 6 seconds
    2019-10-03 17:13:51 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-03 17:13:51 | [feed][n]connecting
    2019-10-03 17:15:56 | [time][i]Synchronizing time via NTP
    2019-10-03 17:15:57 | [stats][e]Cached feed_id=25232 for network T
    2019-10-03 17:15:57 | [stats][i]sent 16 bytes
    2019-10-03 17:15:59 | [time][i]Time synchronized correctly, offset -0.0007 seconds
    2019-10-03 17:16:21 | [feed][e]Could not connect!
    2019-10-03 17:16:21 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-03 17:16:21 | [feed][n]waiting 5 seconds
    2019-10-03 17:16:26 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-03 17:16:26 | [feed][n]connecting
    2019-10-03 17:18:56 | [feed][e]Could not connect!
    2019-10-03 17:18:56 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-03 17:18:56 | [feed][n]waiting 9 seconds
    2019-10-03 17:19:05 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-03 17:19:05 | [feed][n]connecting
    2019-10-03 17:21:36 | [feed][e]Could not connect!
    2019-10-03 17:21:36 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-03 17:21:36 | [feed][n]waiting 7 seconds
    2019-10-03 17:21:43 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-03 17:21:43 | [feed][n]connecting

  3. #13
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,852
    Please post output of following command (when posting, replace the key by xxxxx)

    Code:
    cat /etc/fr24feed.ini
    Last edited by abcd567; 2019-10-03 at 20:51.

  4. #14
    Passenger
    Join Date
    Apr 2018
    Posts
    35
    av6@Aerovision6:~$ cat /etc/fr24feed.ini
    receiver="beast-tcp"
    fr24key="xxxxxxxxxxx"
    host="127.0.0.1:30005"
    bs="no"
    raw="no"
    logmode="0"
    windowmode="0"
    mpx="no"
    mlat="no"
    mlat-without-gps="no"
    use-http=yes
    http-timeout=20

  5. #15
    Captain
    Join Date
    Apr 2018
    Posts
    863
    I don't know if the use-http even does anything anymore.
    That's the only idea i had.

    Pretty sure if that doesn't help, you're out of luck.

  6. #16
    Passenger
    Join Date
    Apr 2018
    Posts
    35
    Just as an update, the below better shows the error that I am experiencing. Clearly, Port 8099 (UDP) is blocked by the staff free wifi at my former employment.

    Is there a workaround here? For example, redirect to another port?

    As Plane Finder and PlanePlotter are working fine, it is strange that FR24 feeding is proving so problematic on this occassion.


    Thabks,
    Ian

    2019-10-05 08:16:03 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:16:03 | [feed][n]connecting
    2019-10-05 08:17:50 | [time][i]Synchronizing time via NTP
    2019-10-05 08:17:53 | [time][i]Time synchronized correctly, offset +0.0001 seconds, drift 0.0000 seconds/minute
    2019-10-05 08:18:32 | [feed][e]Could not connect!
    2019-10-05 08:18:32 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:18:32 | [feed][n]waiting 8 seconds
    2019-10-05 08:18:40 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:18:40 | [feed][n]connecting
    2019-10-05 08:21:10 | [feed][e]Could not connect!
    2019-10-05 08:21:10 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:21:10 | [feed][n]waiting 8 seconds
    2019-10-05 08:21:18 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:21:18 | [feed][n]connecting
    2019-10-05 08:23:48 | [feed][e]Could not connect!
    2019-10-05 08:23:48 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:23:48 | [feed][n]waiting 5 seconds
    2019-10-05 08:23:53 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:23:53 | [feed][n]connecting
    2019-10-05 08:25:21 | [stats][e]Cached feed_id=25232 for network T
    2019-10-05 08:25:21 | [stats][i]sent 16 bytes
    2019-10-05 08:26:23 | [feed][e]Could not connect!
    2019-10-05 08:26:23 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:26:23 | [feed][n]waiting 7 seconds
    2019-10-05 08:26:30 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:26:30 | [feed][n]connecting
    2019-10-05 08:27:53 | [time][i]Synchronizing time via NTP
    2019-10-05 08:27:56 | [time][i]Time synchronized correctly, offset +0.0001 seconds, drift -0.0000 seconds/minute
    2019-10-05 08:29:01 | [feed][e]Could not connect!
    2019-10-05 08:29:01 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:29:01 | [feed][n]waiting 6 seconds
    2019-10-05 08:29:07 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:29:07 | [feed][n]connecting
    2019-10-05 08:31:37 | [feed][e]Could not connect!
    2019-10-05 08:31:37 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:31:37 | [feed][n]waiting 5 seconds
    2019-10-05 08:31:42 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:31:42 | [feed][n]connecting
    2019-10-05 08:34:12 | [feed][e]Could not connect!
    2019-10-05 08:34:12 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:34:12 | [feed][n]waiting 8 seconds
    2019-10-05 08:34:20 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:34:20 | [feed][n]connecting
    2019-10-05 08:35:22 | [stats][e]Cached feed_id=25232 for network T
    2019-10-05 08:35:22 | [stats][i]sent 16 bytes
    2019-10-05 08:36:50 | [feed][e]Could not connect!
    2019-10-05 08:36:50 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:36:50 | [feed][n]waiting 9 seconds
    2019-10-05 08:36:59 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:36:59 | [feed][n]connecting
    2019-10-05 08:37:56 | [time][i]Synchronizing time via NTP
    2019-10-05 08:37:58 | [time][i]Time synchronized correctly, offset +0.0001 seconds, drift 0.0000 seconds/minute
    2019-10-05 08:39:30 | [feed][e]Could not connect!
    2019-10-05 08:39:30 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:39:30 | [feed][n]waiting 7 seconds
    2019-10-05 08:39:37 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:39:37 | [feed][n]connecting
    2019-10-05 08:42:08 | [feed][e]Could not connect!
    2019-10-05 08:42:08 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:42:08 | [feed][n]waiting 9 seconds
    2019-10-05 08:42:17 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:42:17 | [feed][n]connecting
    2019-10-05 08:44:47 | [feed][e]Could not connect!
    2019-10-05 08:44:47 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:44:47 | [feed][n]waiting 5 seconds
    2019-10-05 08:44:52 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:44:52 | [feed][n]connecting
    2019-10-05 08:45:22 | [stats][e]Cached feed_id=25232 for network T
    2019-10-05 08:45:22 | [stats][i]sent 16 bytes
    2019-10-05 08:47:23 | [feed][e]Could not connect!
    2019-10-05 08:47:23 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:47:23 | [feed][n]waiting 5 seconds
    2019-10-05 08:47:28 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:47:28 | [feed][n]connecting
    2019-10-05 08:47:58 | [time][i]Synchronizing time via NTP
    2019-10-05 08:48:00 | [time][i]Time synchronized correctly, offset -0.0000 seconds, drift -0.0000 seconds/minute
    2019-10-05 08:49:59 | [feed][e]Could not connect!
    2019-10-05 08:49:59 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:49:59 | [feed][n]waiting 5 seconds
    2019-10-05 08:50:04 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:50:04 | [feed][n]connecting
    2019-10-05 08:52:34 | [feed][e]Could not connect!
    2019-10-05 08:52:34 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:52:34 | [feed][n]waiting 7 seconds
    2019-10-05 08:52:41 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:52:41 | [feed][n]connecting
    2019-10-05 08:55:12 | [feed][e]Could not connect!
    2019-10-05 08:55:12 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:55:12 | [feed][n]waiting 9 seconds
    2019-10-05 08:55:21 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:55:21 | [feed][n]connecting
    2019-10-05 08:55:22 | [stats][e]Cached feed_id=25232 for network T
    2019-10-05 08:55:22 | [stats][i]sent 16 bytes
    2019-10-05 08:57:52 | [feed][e]Could not connect!
    2019-10-05 08:57:52 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 08:57:52 | [feed][n]waiting 7 seconds
    2019-10-05 08:57:59 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 08:57:59 | [feed][n]connecting
    2019-10-05 08:58:00 | [time][i]Synchronizing time via NTP
    2019-10-05 08:58:02 | [time][i]Time synchronized correctly, offset -0.0005 seconds, drift -0.0000 seconds/minute
    2019-10-05 09:00:29 | [feed][e]Could not connect!
    2019-10-05 09:00:29 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 09:00:29 | [feed][n]waiting 6 seconds
    2019-10-05 09:00:35 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 09:00:35 | [feed][n]connecting
    2019-10-05 09:03:05 | [feed][e]Could not connect!
    2019-10-05 09:03:05 | [feed][n]Error: Could not connect! (fd -1)
    2019-10-05 09:03:05 | [feed][n]waiting 6 seconds
    2019-10-05 09:03:11 | [feed][n]EGKK139@185.218.24.23:8099/UDP
    2019-10-05 09:03:11 | [feed][n]connecting

  7. #17
    Captain
    Join Date
    Apr 2018
    Posts
    863
    You could make a TCP stream of the raw beast data to another machine and then run fr24feed there.
    It seems outbound TCP connections are not a problem.

    So if the other machine you want to feed from is behind a router, you'll have to forward port 30004.
    On the other machine you run any dump1090 you want an configure it net-only.
    Then if the outside IP address of the router is changing you need a dyndns address.

    On the machine in the restricted network you run the data redirection.
    You could use the redirection-only install of combine1090: https://github.com/wiedehopf/combine...direction-only

    TARGET would be the outside IP address of the router or the dyndns address you have plus port 30004 which you have forwarded.

    Change sources to only be 127.0.0.1
    Ports you only want 30005

    After having that all configured you can install fr24feed on the other machine and feed from there.


    Pretty sure FR24 has no provisions for feeding in this case.
    The use-http is the only option i know and i'm not sure if it has any effect anymore.
    If you want to hear from FR24 you'll have to open a ticket, they don't seem to care about this forum.

  8. #18
    Passenger
    Join Date
    Apr 2018
    Posts
    35
    Hi Wiedehopf,

    Thank you for all of your help so far. It is really apreciated. Actually, I already raised a ticket with FR24, but this forum has been far more informative so far.

    So, I am reasonably IT literate, but a bit of a newbie to Linux (Ubuntu 18.04 on the 32-bit Toughbooks and also a single Rp3 running here at home.

    Therefore, please may I ask for a little more detailed info on your suggested TCP stream of raw data? This intertests me greatly, but I need to learn a little bit more first.

    So, current set-up is Dump1090 Mutability feeding Plane Finder and FR24 installed through the ADS-B Receiver Project (Joe Prochazka). I am however familiar with reinstalling the settings file / co-ordinates individually for all three. I then also feed PlanePlotter through virtual Windows (using Wine).

    Can I therefore redirect only the FR24 feed to TCP stream of raw data, or does this come from within Dump1090 Mutability? If the latter, can I still directly feed Plane Finder and PlanePlotter (the latter through Wine) directly from source, or is it "all or nothing"?

    Would I need the redirection-only install of combine1090: https://github.com/wiedehopf/combine...direction-only, which i am guessing that you wrote? Or is that an option of choice? Would it replace or run alongside the existing Dump1090 Mutability from ADS-B Receiver Project?

    I can set up another identical CF-18 Toughbook (with Ubuntu 18.04) at home and run 24/7 as the "other machine". Logically, I could feed all three from said machine, with the raw data from the Gatwick one. My home environment is reasonable quick Wifi (through Virgin Media) and I already feed all three from my home set-up (roof aerial) through the RPi, so would need to ensure that the "other machine" did not create conflicts there. (I think that this might possibly occur with PlanePlotter if more than one installation is running from the same IP address).

    Sorry if I ask any stupid questions above. Your continued help much apreciated.

    Ian

  9. #19
    Captain
    Join Date
    Apr 2018
    Posts
    863
    The stream of data is just a copy of all messages received by dump1090, you can continue running the other feeders as is.

    The redirection-only install won't do anything except run socat to forward the data. (maybe forward is a better word then redirect)

    On the additional machine at your home you'll need to configure dump1090 with the --net-only parameter, otherwise it won't run without a dongle.
    I'm not familiar with dump1090-mutability and how to configure it though.

    Here is an instruction on how to install dump1090-fa: https://github.com/wiedehopf/adsb-wi...ng-dump1090-fa
    That configuration i'm very familiar with.
    Oh i guess you need to compile it, that's why you are using the script.
    Gotta do a script that compiles and installs dump1090-fa for such cases, the adsb-receiver project is just so unflexible and added to that not that well maintained. (still a nice tool)
    You can compile it like explained here: https://github.com/wiedehopf/adsb-wi...fa-from-source

    The just replace "--device-index 0" with "--net-only" in the configuration file /etc/default/dump1090-fa
    That will have it running in net-only mode.
    Set up fr24feed to use beast-tcp as receiver from 127.0.0.1 on port 30005.
    (as described in the Installing dump1090-fa explanation)


    Note for a message rate of around 1500 messages per second, the datastream will use around 25 KByte/s of bandwidth.
    That usually isn't a problem though.
    Last edited by wiedehopf; 2019-10-05 at 11:26.

  10. #20
    Passenger
    Join Date
    Apr 2018
    Posts
    35
    Thank you again for the detailed reply.

    So it looks like I will need Dump1090-fa rather than -Mutability on my Gatwick machine, then to install Combine1090. I am assuming that to install Combine1090 alongside Dump1090--Mutability will simply not work.

    I checked out the dump1090-mutability configuration file on an identical Toughbook at home and noted:

    # If set to "none", dump1090 will be started in --net-only mode
    DEVICE=""


    Therefore, changing this to DEVICE="none" would achieve the required result for the “other machine” which will be running at home???


    Cheers, Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •