Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Raspberry Pi 4 - issue

  1. #1
    Passenger
    Join Date
    Feb 2015
    Posts
    30

    Raspberry Pi 4 - issue

    Hello all,

    I have the Raspberry Pi 4 running the Raspbian Buster.
    I have installed dump1090 and Fr24feed. The problem is that there is no aircraft shown, neither on the ip/dump1090/gmap.html, nor accessing the ip:8754

    When I run fre24feed-status I get:

    pi@raspberrypi:~ $ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-09-08 13:41:14.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-LPCO40.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (0 MSGS/ SYNC).
    [FAIL] FR24 MLAT: not running ... failed!



    Can you please help me?


    Thank you and best regards

  2. #2
    Captain
    Join Date
    Apr 2018
    Posts
    874
    Try updating to the current kernel first, there was a problem with the earlier versions.

    sudo apt update
    sudo apt dist-upgrade
    sudo reboot


    If that doesn't help you can run this to test the stick: https://github.com/wiedehopf/adsb-sc...---DVB-T-stick
    Or you can try dump1090-fa: https://github.com/wiedehopf/adsb-sc...for-dump1090fa

  3. #3
    Passenger
    Join Date
    Feb 2015
    Posts
    30
    Many thanks for your reply.
    I've done all the updates for RPi. Then tested the stick...

    -----------------------------------------------
    Lost samples in the first 2 seconds after starting the test are common and not a problem!
    Starting 30 second rtl_test, standby!
    -----
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001000

    Using device 0: Generic RTL2832U
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    [R82XX] PLL not locked!
    Sampling at 2400000 S/s.

    Info: This tool will continuously read from the device, and report if
    samples get lost. If you observe no further output, everything is fine.

    Reading samples in async mode...
    Allocating 15 zero-copy buffers
    Signal caught, exiting!

    User cancel, exiting...
    -----------------------------------------------

    I then executed:
    "sudo bash -c "$(wget -q -O - raw.githubusercontent.com/wiedehopf/adsb-scripts/master/install-complete.sh)"
    "hash -r"

    I still can't find any planes in dump1090 or dump1090-fa....

  4. #4
    Captain
    Join Date
    Apr 2018
    Posts
    874
    I'd say then you have an antenna or antenna connection problem.

    Can you post the contents of http://address/dump1090-fa/data/stats.json ?
    address being the address you can reach your RPi.

    You should probably also do a reboot after using the rtl_test script.

  5. #5
    Passenger
    Join Date
    Feb 2015
    Posts
    30
    I've checked all the connections, seems OK.

    I see the following output:

    {
    "latest":{"start":1567955472.8,"end":1567955472.8, "local":{"samples_processed":0,"samples_dropped":0 ,"modeac":0,"modes":0,"bad":0,"unknown_icao":0,"ac cepted":[0],"strong_signals":0},"remote":{"modeac":0,"modes": 0,"bad":0,"unknown_icao":0,"accepted":[0]},"cpr":{"surface":0,"airborne":0,"global_ok":0,"g lobal_bad":0,"global_range":0,"global_speed":0,"gl obal_skipped":0,"local_ok":0,"local_aircraft_relat ive":0,"local_receiver_relative":0,"local_skipped" :0,"local_range":0,"local_speed":0,"filtered":0}," altitude_suppressed":0,"cpu":{"demod":0,"reader":0 ,"background":0},"tracks":{"all":0,"single_message ":0},"messages":0},
    "last1min":{"start":1567955412.7,"end":1567955472. 8,"local":{"samples_processed":0,"samples_dropped" :0,"modeac":0,"modes":0,"bad":0,"unknown_icao":0," accepted":[0],"strong_signals":0},"remote":{"modeac":0,"modes": 0,"bad":0,"unknown_icao":0,"accepted":[0]},"cpr":{"surface":0,"airborne":0,"global_ok":0,"g lobal_bad":0,"global_range":0,"global_speed":0,"gl obal_skipped":0,"local_ok":0,"local_aircraft_relat ive":0,"local_receiver_relative":0,"local_skipped" :0,"local_range":0,"local_speed":0,"filtered":0}," altitude_suppressed":0,"cpu":{"demod":0,"reader":4 ,"background":170},"tracks":{"all":0,"single_messa ge":0},"messages":0},
    "last5min":{"start":1567955412.7,"end":1567955472. 8,"local":{"samples_processed":0,"samples_dropped" :0,"modeac":0,"modes":0,"bad":0,"unknown_icao":0," accepted":[0],"strong_signals":0},"remote":{"modeac":0,"modes": 0,"bad":0,"unknown_icao":0,"accepted":[0]},"cpr":{"surface":0,"airborne":0,"global_ok":0,"g lobal_bad":0,"global_range":0,"global_speed":0,"gl obal_skipped":0,"local_ok":0,"local_aircraft_relat ive":0,"local_receiver_relative":0,"local_skipped" :0,"local_range":0,"local_speed":0,"filtered":0}," altitude_suppressed":0,"cpu":{"demod":0,"reader":4 ,"background":170},"tracks":{"all":0,"single_messa ge":0},"messages":0},
    "last15min":{"start":1567955412.7,"end":1567955472 .8,"local":{"samples_processed":0,"samples_dropped ":0,"modeac":0,"modes":0,"bad":0,"unknown_icao":0, "accepted":[0],"strong_signals":0},"remote":{"modeac":0,"modes": 0,"bad":0,"unknown_icao":0,"accepted":[0]},"cpr":{"surface":0,"airborne":0,"global_ok":0,"g lobal_bad":0,"global_range":0,"global_speed":0,"gl obal_skipped":0,"local_ok":0,"local_aircraft_relat ive":0,"local_receiver_relative":0,"local_skipped" :0,"local_range":0,"local_speed":0,"filtered":0}," altitude_suppressed":0,"cpu":{"demod":0,"reader":4 ,"background":170},"tracks":{"all":0,"single_messa ge":0},"messages":0},
    "total":{"start":1567955412.7,"end":1567955472.8," local":{"samples_processed":0,"samples_dropped":0, "modeac":0,"modes":0,"bad":0,"unknown_icao":0,"acc epted":[0],"strong_signals":0},"remote":{"modeac":0,"modes": 0,"bad":0,"unknown_icao":0,"accepted":[0]},"cpr":{"surface":0,"airborne":0,"global_ok":0,"g lobal_bad":0,"global_range":0,"global_speed":0,"gl obal_skipped":0,"local_ok":0,"local_aircraft_relat ive":0,"local_receiver_relative":0,"local_skipped" :0,"local_range":0,"local_speed":0,"filtered":0}," altitude_suppressed":0,"cpu":{"demod":0,"reader":4 ,"background":170},"tracks":{"all":0,"single_messa ge":0},"messages":0}
    }

  6. #6
    Captain
    Join Date
    Apr 2018
    Posts
    874
    Can you show pictures of your setup or describe which cable/antenna you are using?

    Could be that your dongle is defective in a way that seems to work, but just doesn't receive anything.
    The stats you posted it's literally not receiving anything, not even noise.

    If you want you can do a spectrum scan like described here: https://forum.flightradar24.com/thre...ignals-In-Area

  7. #7
    Passenger
    Join Date
    Feb 2015
    Posts
    30
    Hi,

    I'm using the FA antenna with RG213 coax cable (5m). Antenna is mounted above the roof. In the RPI3 with the same setup I got many planes around me... Now with RPi4 no matter what I do I get no planes in the radar...

  8. #8
    Captain
    Join Date
    Apr 2018
    Posts
    874
    Remove the power and try once more, now that you have updated.
    (rebooting should be sufficient but remove power just to make sure)

    You should also be able to test the card you are using in the RPi4 in the RPi3 to test the configuration.

    Maybe there is something in the log, check after doing the power off/on:

    sudo journalctl --no-pager -u dump1090-fa
    Last edited by wiedehopf; 2019-09-08 at 19:17.

  9. #9
    Passenger
    Join Date
    Feb 2015
    Posts
    30
    The log has the following output...

    Sep 09 00:34:15 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:34:15 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:35:16 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:35:16 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:36:16 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:36:16 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:37:16 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:37:16 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:38:17 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:38:17 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:39:17 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:39:17 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:40:17 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:40:17 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:41:17 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:41:17 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:42:18 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:42:18 2019 WEST No data received from the SDR for a long time, it may have wedged
    Sep 09 00:43:18 raspberrypi dump1090-fa[1704]: Mon Sep 9 00:43:18 2019 WEST No data received from the SDR for a long time, it may have wedged

    I've run again the stick test script and found undervoltage warning this time. This issue could be related to that?
    I'm using the same power supply (https://www.amazon.co.uk/iFi-iPower-.../dp/B01GNNXP0Y) that I used for RPi3.

  10. #10
    Captain
    Join Date
    Apr 2018
    Posts
    874
    Is that power supply really $50? (shakes head in disbelieve)

    Anyway get the official power supply for the RPi4, might just solve your problem.
    Also if you are using an USB extension, just plug the dongle directly into the RPi.

    Have you tried the sd-card in the RPi3?
    There is really no need to go to the RPi4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •