And if it was set to dvbt. Chances are it's back to wrong version thanks to forced script installer

Sent from my EML-L09 using Tapatalk