Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: wanting webserver parameters for dump1090-mutability v1.15~dev

  1. #1
    Passenger
    Join Date
    Sep 2018
    Location
    St Ann's Bay or Timberlea Nova Scotia
    Posts
    37

    wanting webserver parameters for dump1090-mutability v1.15~dev

    my stable feeding computer has become unstable,
    fr24 feed segfaulting ...
    I was using fr24's
    mr-dump1090
    --net --net-http-port 38080
    + raw
    + decoded
    I was serving well.

    I'm now trying mutability but it does not open a mini webserver on desired port
    --net --net-http-port 38080
    netstat -t -p -l |grep dump1090
    nul

    I'm not seeing the parameters to get a miniserver up,
    what am I missing?
    /var/log not containing any errors

  2. #2
    Captain
    Join Date
    Apr 2018
    Posts
    746
    You need to run a separate webserver.

    dump1090 provides some configuration for lighttpd.

  3. #3
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,754
    The mr-dump1090 uses its integral webserver, and by default serves map at port 8080. This can be changed to another port number by argument --net-http-port <another port number>.

    The dump1090-mutability does NOT have an integrated webserver, and during its installation, lighttpd webserver is installed as its dependency. The lighttpd serves the webpage at "http://ip-of-pi/dump1090/gmap.html".

    The lighttpd's configuration file is located here:

    /etc/lighttpd/conf-available/89-dump1090.conf

    .

  4. #4
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,754
    Code:
    pi@raspberrypi:~ $ sudo nano /etc/lighttpd/conf-available/89-dump1090.conf
    
    # Allows access to the static files that provide the dump1090 map view, 
    # and also to the dynamically-generated json parts that contain aircraft 
    # data and are periodically written by the dump1090 daemon. 
    
    url.redirect += ( 
         "^/dump1090/$" => "/dump1090/gmap.html", 
         "^/dump1090$" => "/dump1090/gmap.html" 
    ) 
    
    alias.url += ( 
         "/dump1090/data/" => "/run/dump1090-mutability/", 
         "/dump1090/" => "/usr/share/dump1090-mutability/html/" 
    ) 
    
    # The stat cache must be disabled, as aircraft.json changes 
    # frequently and lighttpd's stat cache often ends up with the 
    # wrong content length. server.stat-cache-engine = "disable"
    
    server.stat-cache-engine = "disable"
    Last edited by abcd567; 2019-08-08 at 06:01.

  5. #5
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,754
    Code:
    pi@raspberrypi:~ $ cat /etc/lighttpd/lighttpd.conf
    
    server.modules = (
            "mod_indexfile",
            "mod_access",
            "mod_alias",
            "mod_redirect",
    )
    
    server.document-root        = "/var/www/html"
    server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
    server.errorlog             = "/var/log/lighttpd/error.log"
    server.pid-file             = "/var/run/lighttpd.pid"
    server.username             = "www-data"
    server.groupname            = "www-data"
    server.port                 = 80
    
    # strict parsing and normalization of URL for consistency and security
    # https://redmine.lighttpd.net/projects/lighttpd/wiki/Server_http-parseoptsDetails
    # (might need to explicitly set "url-path-2f-decode" = "disable"
    #  if a specific application is encoding URLs inside url-path)
    server.http-parseopts = (
      "header-strict"           => "enable",# default
      "host-strict"             => "enable",# default
      "host-normalize"          => "enable",# default
      "url-normalize-unreserved"=> "enable",# recommended highly
      "url-normalize-required"  => "enable",# recommended
      "url-ctrls-reject"        => "enable",# recommended
      "url-path-2f-decode"      => "enable",# recommended highly (unless breaks app)
     #"url-path-2f-reject"      => "enable",
      "url-path-dotseg-remove"  => "enable",# recommended highly (unless breaks app)
     #"url-path-dotseg-reject"  => "enable",
     #"url-query-20-plus"       => "enable",# consistency in query string
    )
    
    index-file.names            = ( "index.php", "index.html" )
    url.access-deny             = ( "~", ".inc" )
    static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
    
    compress.cache-dir          = "/var/cache/lighttpd/compress/"
    compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )
    
    # default listening port for IPv6 falls back to the IPv4 port
    include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
    include_shell "/usr/share/lighttpd/create-mime.conf.pl"include "/etc/lighttpd/conf-enabled/*.conf"
    
    #server.compat-module-load   = "disable"
    server.modules += (
            "mod_compress",
            "mod_dirlisting",
            "mod_staticfile",
    )
    Last edited by abcd567; 2019-08-08 at 15:37.

  6. #6
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,754
    (1) Map is available at following address when Default Settings are used:

    "http://ip-of-pi/dump1090/gmap.html"

    AND

    "http://ip-of-pi:80/dump1090/gmap.html"


    (2) If Default setting are changed from port 80 to port 38080

    To change default port from 80 to 38080, open file /etc/lighttpd/lighttpd.conf in nano editor:
    Code:
    sudo nano /etc/lighttpd/lighttpd.conf
    In the opened file, change line "server.port = 80" to "server.port = 38080".

    Save file (Ctrl+0) and Close it (Ctrl+x).
    Now give following command:

    Code:
    sudo systemctl restart lighttpd
    The map will now be available at:

    "http://ip-of-pi:38080/dump1090/gmap.html"

    Note:
    Before attempting any changes in file lighttpd.conf, make a backup copy (lighttpd.conf.orignal) by following command:

    Code:
    sudo cp /etc/lighttpd/lighttpd.conf   /etc/lighttpd/lighttpd.conf.orignal
    If anything goes wrong, you can revert to original by following command

    Code:
    sudo cp /etc/lighttpd/lighttpd.conf.orignal  /etc/lighttpd/lighttpd.conf
    Last edited by abcd567; 2019-08-08 at 16:38.

  7. #7
    Passenger
    Join Date
    Sep 2018
    Location
    St Ann's Bay or Timberlea Nova Scotia
    Posts
    37
    thanks,
    I'm using dump1090-mutability and lighttp

    Code:
    Problem fetching data from dump1090.
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date.

  8. #8
    Passenger
    Join Date
    Sep 2018
    Location
    St Ann's Bay or Timberlea Nova Scotia
    Posts
    37
    if anyone else is switching over from mr-dump1090 to dump1090-mutability
    the ports are now controlled as follows (note no 30005 beast mode)
    Code:
    # netstat  -l -p -t |grep fr24
    tcp        0      0 0.0.0.0:30002           0.0.0.0:*               LISTEN      902/fr24feed        
    tcp        0      0 0.0.0.0:8754            0.0.0.0:*               LISTEN      902/fr24feed        
    tcp        0      0 0.0.0.0:30003           0.0.0.0:*               LISTEN      902/fr24feed

  9. #9
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,006
    Quote Originally Posted by galenthurber View Post
    if anyone else is switching over from mr-dump1090 to dump1090-mutability
    the ports are now controlled as follows (note no 30005 beast mode)
    Code:
    # netstat  -l -p -t |grep fr24
    tcp        0      0 0.0.0.0:30002           0.0.0.0:*               LISTEN      902/fr24feed        
    tcp        0      0 0.0.0.0:8754            0.0.0.0:*               LISTEN      902/fr24feed        
    tcp        0      0 0.0.0.0:30003           0.0.0.0:*               LISTEN      902/fr24feed
    Those are only open as you have fr24 running and filtered for it. 8754 - webpage

    And the raw and decoded out options checked/enabled in settings. (Raw port depends on selected decoder type in your case dvbt so it's gone to 30002)

    If you reconfigure for besst-tcp, turn off the outputs from fr24 and setup dump1090 correctly 30005 and others will appear open.

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  10. #10
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,754
    This is fr24feed's configuration with dump1090-mutability ver 1.15~dev installed by user:

    "http://IP-of-Pi:8754/settings.html"

    fr24feed setting BEAST-TCP using dump1090-fa or dump1090-mut v1.15.png
    Last edited by abcd567; 2019-08-10 at 23:42.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •