Results 1 to 9 of 9

Thread: RPi4 dump1090 not working

  1. #1
    Passenger
    Join Date
    Sep 2012
    Location
    North Dorset
    Posts
    49

    RPi4 dump1090 not working

    Can anyone help please.

    Hardware:
    Raspberry pi 4 model B
    Nooelec NESDR Nano 2

    Installed dump1090-mutability ver 1.15~dev and the fr24feed.

    Status:
    Code:
    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-07-30 11:47:06.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EGDY50.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (0 MSGS/ SYNC).
    [FAIL] FR24 MLAT: not running ... failed!
    fr24feed.ini
    Code:
    receiver="beast-tcp"
    fr24key="083a900c888d05c1"
    host="127.0.0.1:30005"
    bs="no"
    raw="no"
    logmode="1"
    windowmode="0"
    logpath="/var/log/fr24feed"
    mpx="no"
    mlat="no"
    mlat-without-gps="no"

    fr24feed log file:
    Code:
    2019-07-30 12:14:13 | ______  _  _         _      _                    _              _____    ___ 
    2019-07-30 12:14:13 | |  ___|| |(_)       | |    | |                  | |            / __  \  /   |
    2019-07-30 12:14:13 | | |_   | | _   __ _ | |__  | |_  _ __  __ _   __| |  __ _  _ __`' / /' / /| |
    2019-07-30 12:14:13 | |  _|  | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / /  / /_| |
    2019-07-30 12:14:13 | | |    | || || (_| || | | || |_ | |  | (_| || (_| || (_| || |  ./ /___\___  |
    2019-07-30 12:14:13 | \_|    |_||_| \__, ||_| |_| \__||_|   \__,_| \__,_| \__,_||_|  \_____/    |_/
    2019-07-30 12:14:13 |                __/ |                                                         
    2019-07-30 12:14:13 |               |___/                                                          
    2019-07-30 12:14:13 | [main][i]FR24 Feeder/Decoder
    2019-07-30 12:14:13 | [main][i]Version: 1.0.23-8/generic
    2019-07-30 12:14:13 | [main][i]Built on Oct 16 2018 08:10:47 (HEAD-2d57e58.git/Linux/static_armel)
    2019-07-30 12:14:13 | [main][i]Running on: raspbian10
    2019-07-30 12:14:13 | [main][i]Local IP(s): 
    2019-07-30 12:14:13 | [main][i]Copyright 2012-2018 Flightradar24 AB
    2019-07-30 12:14:13 | [main][i]https://www.flightradar24.com
    2019-07-30 12:14:13 | [main][i]DNS mode: PING
    2019-07-30 12:14:13 | [main][i]Automatic updates are ENABLED
    2019-07-30 12:14:13 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2019-07-30 12:14:13 | [main][i]Reader thread started
    2019-07-30 12:14:13 | [time][i]Synchronizing time via NTP
    2019-07-30 12:14:13 | [master][i]Starting processing thread
    2019-07-30 12:14:13 | [reader][i]Initializing reader
    2019-07-30 12:14:13 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    2019-07-30 12:14:13 | [reader][e]Could not connect to tcp://127.0.0.1:30005
    2019-07-30 12:14:13 | [time][e]Failed to synchronize time
    2019-07-30 12:14:13 | [main][w]Failed to synchronize time, waiting 5 seconds
    2019-07-30 12:14:18 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    2019-07-30 12:14:18 | [reader][e]Could not connect to tcp://127.0.0.1:30005
    2019-07-30 12:14:18 | [time][i]Synchronizing time via NTP
    2019-07-30 12:14:19 | [time][e]Failed to synchronize time
    2019-07-30 12:14:19 | [main][w]Failed to synchronize time, waiting 5 seconds
    2019-07-30 12:14:23 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    2019-07-30 12:14:23 | [reader][e]Could not connect to tcp://127.0.0.1:30005
    2019-07-30 12:14:24 | [time][i]Synchronizing time via NTP
    2019-07-30 12:14:24 | [time][e]Failed to synchronize time
    2019-07-30 12:14:24 | [main][w]Failed to synchronize time, waiting 5 seconds
    2019-07-30 12:14:28 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    2019-07-30 12:14:28 | [reader][e]Could not connect to tcp://127.0.0.1:30005
    2019-07-30 12:14:29 | [time][i]Synchronizing time via NTP
    2019-07-30 12:14:33 | [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005)
    2019-07-30 12:14:33 | [reader][i]Connected to the receiver, configuring
    2019-07-30 12:14:33 | [reader][i]Configured, processing messages
    dump1090-mutability log file
    Code:
    Tue Jul 30 12:15:10 2019 BST  dump1090-mutability v1.15~dev starting up.
    Using sample converter: UC8, integer/table path
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
    rtlsdr_read_reg failed with -7
    rtlsdr_write_reg failed with -7
    rtlsdr_read_reg failed with -7
    rtlsdr_write_reg failed with -7
    rtlsdr_read_reg failed with -7
    rtlsdr_write_reg failed with -7
    rtlsdr_read_reg failed with -7
    rtlsdr_write_reg failed with -7
    No supported tuner found
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    Enabled direct sampling mode, input 1
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    Max available gain is: 0.00 dB
    Setting gain to: 0.00 dB
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_demod_write_reg failed with -7
    rtlsdr_demod_read_reg failed with -7
    rtlsdr_write_reg failed with -7
    rtlsdr_write_reg failed with -7
    Gain reported by device: 0.00 dB
    Allocating 15 zero-copy buffers
    Tue Jul 30 12:15:28 2019 BST  No data received from the dongle for a long time, it may have wedged
    Tue Jul 30 12:17:28 2019 BST  No data received from the dongle for a long time, it may have wedged
    Tue Jul 30 12:18:28 2019 BST  No data received from the dongle for a long time, it may have wedged
    Tue Jul 30 12:19:29 2019 BST  No data received from the dongle for a long time, it may have wedged
    Tue Jul 30 12:20:29 2019 BST  No data received from the dongle for a long time, it may have wedged
    OrionOptics 12" 1200mm + Tele Vue x 2 Powermate + Canon EOS 50D

    My Photo Album

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,052
    Unfortunately the answer is staring at you in those last logs.


    Either the stick is faulty. Or not enough power to drive it.

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Passenger
    Join Date
    Sep 2012
    Location
    North Dorset
    Posts
    49
    Thanks for the quick reply Oblivian.

    I don't think that's the answer because I have just connected another different dongle and get the same messages. The light on the device is on and I'm using the official power supply for the RPi. I was using this dongle on Windows a few weeks ago and it worked fine.

    BTW, it receives messages when I change the settings to AVR-TCP and Port 30002. So maybe it's something to do with that?

    Code:
    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-07-30 13:12:17.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EGDY50.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (12 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!
    OrionOptics 12" 1200mm + Tele Vue x 2 Powermate + Canon EOS 50D

    My Photo Album

  4. #4
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,862
    Pi4 has problem of compatibility with RTL devices. There were attempt to fix the bug in firmware, but only partial success. Please Google "Pi4 RTL device".

    https://www.raspberrypi.org/forums/v...c.php?t=243982

    .
    Last edited by abcd567; 2019-07-30 at 14:31.

  5. #5
    Passenger
    Join Date
    Sep 2012
    Location
    North Dorset
    Posts
    49
    Quote Originally Posted by abcd567 View Post
    Pi4 has problem of compatibility with RTL devices. There were attempt to fix the bug in firmware, but only partial success. Please Google "Pi4 RTL device".

    https://www.raspberrypi.org/forums/v...c.php?t=243982

    .
    Ok thanks so it doesn’t work on the Pi4 at the moment. It’s a shame there’s no mention of this on the fr24 website. I will take the Pi4 back to the shop and get a Pi3.

    Thanks for your help.
    OrionOptics 12" 1200mm + Tele Vue x 2 Powermate + Canon EOS 50D

    My Photo Album

  6. #6
    Captain
    Join Date
    Apr 2018
    Posts
    870
    You can do the following

    sudo apt install rpi-update
    sudo rpi-update

    confirm with yes.

    sudo reboot

    It will get you the development version of the kernel.
    With that new version the rtl-sdr dongles and dump1090 work fine.

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,862
    Apart from RTL device compatability (which now seems to have a workaround of using development kernel as suggested by wiedehopf), the Pi4 has another issue: HEAT.

    In many installations, it needs a heat sink and/or fan.
    Last edited by abcd567; 2019-07-30 at 15:38.

  8. #8
    Passenger
    Join Date
    Sep 2012
    Location
    North Dorset
    Posts
    49
    Quote Originally Posted by wiedehopf View Post
    You can do the following

    sudo apt install rpi-update
    sudo rpi-update

    confirm with yes.

    sudo reboot

    It will get you the development version of the kernel.
    With that new version the rtl-sdr dongles and dump1090 work fine.
    That's solved it, now working and feeding to FR24. Thanks

    Code:
    pi@raspberrypi:~ $ sudo fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-07-30 15:56:48.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-EGDY50.
    [ ok ] FR24 Tracked AC: 2.
    [ ok ] Receiver: connected (2870 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!
    OrionOptics 12" 1200mm + Tele Vue x 2 Powermate + Canon EOS 50D

    My Photo Album

  9. #9
    Passenger
    Join Date
    Sep 2012
    Location
    North Dorset
    Posts
    49
    Ok I will keep an eye on the temp, so far so good.
    OrionOptics 12" 1200mm + Tele Vue x 2 Powermate + Canon EOS 50D

    My Photo Album

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •