Results 1 to 7 of 7

Thread: Pi stopped feeding on 6/27

  1. #1
    Passenger
    Join Date
    Sep 2013
    Posts
    15

    Pi stopped feeding on 6/27

    Despite having flightradar24 set to notify me if there is no reporting for 1 hour my Pi apparently stopped transmitting data at 23:18:10 on June 26th, and I only noticed it today when I went to use the FR24 app and it said I only had a Basic account.

    When I checked the status it is showing as Online, but no data is being sent. In fact for the last 7 days it is showing 100% uptime.

    I checked another system's data (my weather station) and on the 26th there was no power or internet interruptions, so I am wondering what is going on. Does a Raspberry Pi need to be rebooted on occasion? It has only been running since June 2nd. Nobody was anywhere near that house on the 26th to tinker with anything, so it isn't likely that somebody bumped the antenna or anything.

    The Pi is at my second home and I did not go there today but I will be there tomorrow, I will restart it and see if that resolves the problem, but is this a normal thing to happen? If it is I can plug the Pi into a wifi switch so I can do a power cycle remotely. But just seems odd that it is online, but not sending anything.

  2. #2
    Captain
    Join Date
    Apr 2018
    Posts
    695
    Most likely it's a power problem, that is the dongle stops working correctly because the power supply for the RPi isn't designed specifically for the Pi.
    I'd recommend getting the "Official RPi Power Supply".

    This can occur with phone chargers or no-name power supplies which degrade over time.

    The outage detection apparently doesn't detect lack of data because that may cause too many false positives for stations with no traffic at night.

    Could also be a faulty dongle of course.
    If it was just the insufficient power supply, a restart will fix it, at least for a time.
    Faulty dongles are generally more consistent and stop working completely but there is no sure way to know.

    Before you do a reboot you can run this script and it should tell you if the power supply is unstable or if the dongle works.
    At least the output might tell me something if you post it:
    Code:
    sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/adsb-wiki/master/rtl_test.sh)"

  3. #3
    Passenger
    Join Date
    Sep 2013
    Posts
    15
    My power supply came with my kit- official Pi one. Kano computer kit (Raspberry Pi 3 Model B, case, power supply, 16GB MicroSD card and keyboard).

    I will take my laptop with me and see what I get.

  4. #4
    Captain
    Join Date
    Apr 2018
    Posts
    695
    Cana kit? Haven't heard any complaints about their power supply.

    Normally the RPi doesn't need to be rebooted.
    But you can add a cronjob to reboot the RPi every week or even every night which might not be a bad idea if you don't have easy access.
    If you just want to do that, that's easy:
    Code:
    sudo echo -e '0 3 1-31/3 * * root /sbin/reboot\n' >/etc/cron.d/reboot
    It will reboot the RPi at 3 in the morning every 3rd day.

    fr24feed by default uses the quite outdated dump1090-mutability 1.14
    If anything like this happens again, the logs would be more easily accessible using dump1090-fa if you want to try that:

    https://github.com/wiedehopf/adsb-wi...for-dump1090fa
    (install and configuration of fr24feed to use dump1090-fa is automated as well as returning to the previous configuration)

  5. #5
    Passenger
    Join Date
    Sep 2013
    Posts
    15
    This is the kit I purchased, got it on clearance for $35. Maybe I should have bought 2 of them.

    https://www.amazon.com/Kano-Computer...dp/B073VTCS66/

    I'll report back tonight after I do some troubleshooting.

  6. #6
    Captain
    Join Date
    Apr 2018
    Posts
    695
    This is the official power supply:
    https://www.amazon.com/Official-Rasp.../dp/B01LCNF8FU

    If you have the screen or keyboard connected, you can consider removing them as they also draw power.

  7. #7
    Passenger
    Join Date
    Sep 2013
    Posts
    15
    Well when I went there yesterday the Pi was not responding to my attempts to access it from my laptop. Pulled power, plugged it back in and it started updating to Flightradar24 again.

    Have it now plugged into a TP-Link wifi outlet. When I got home last night I looked on FR24 and it was not reporting again... so I had to do a power-cycle and it has been good since.

    Makes me worry something is going wrong though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •