Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: RASPBERRY PI DEBIAN Buster will not connect to planeplotter

  1. #11
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,719
    airmail:

    Have you installed the planeplotter on Windows Computer, or on Raspberry Pi?

    The method I have given in my post above is for planeplotter installed on Windows Computer.

  2. #12
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,957
    Quote Originally Posted by wiedehopf View Post
    I believe planeplotter needs to be compiled from dump1090-mutability.
    This compilation no longer works for Buster.

    airmale: Showing actual error messages would be very helpful.
    Also error messages along the install of planeplotter.
    I'll laugh if this ends up on wine like abcd has just asked.

    Plane plotter is 'doze and non reliant on any particular build or compile. It has about 13 different feed types it can connect to (still sbs even.. unlike something nearby..) including Avr/beast outputs. Need to check my copy if it actually has bundled 1090 (windows again)

    But sure has standard dump1090 tcp/network option too.

    The main guides show building an old Mr version, but I should still work with remote beast format fine. Is how I've had mine going for 6yrs or so after I took it away from direct USB.

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #13
    Captain
    Join Date
    Apr 2018
    Posts
    691
    Ah then he probably just didn't add the --net option to the fr24feed settings.

    Oh well in that case i'll just recommend this:
    https://github.com/wiedehopf/adsb-wi...for-dump1090fa

    No --net option you can fail to configure for that ...

  4. #14
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,957
    OK So the planeplotter RTL/Dump1090 Options, attempts to connect to 31001 by default.

    So unless whatever version is running on Pi opens that port or --net-ro-port 31001 is specified, it won't like it. But 30005/beast will be cause all the other feeds use that.


    So my suggestion still stands. Tell it its beast TCP, get it from 30005 just like everything else is.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •