sudo apt install lighttpd
sudo apt purge lighttpd
sudo apt install lighttpd

At this point you might need to purge and reinstall your dump1090 version as well.

sudo lighty-enable-mod dump1090

Deleting the whole /etc/lighttpd directory is a really bad idea.