Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: Dump1090 mutability 1-15 on Mint linux

  1. #1
    Passenger
    Join Date
    Apr 2015
    Posts
    24

    Dump1090 mutability 1-15 on Mint linux

    I'd like to first install dump1090-mutability on my Linux laptop (Mint 19) for testing receivers and antennas. Should I follow the instructions posted here?

    Thanks,
    SpacePilot

  2. #2
    Captain
    Join Date
    Apr 2018
    Posts
    691
    Quote Originally Posted by Space Pilot View Post
    I'd like to first install dump1090-mutability on my Linux laptop (Mint 19) for testing receivers and antennas. Should I follow the instructions posted here?

    Thanks,
    SpacePilot
    Should work in principal.

    You can't install the fr24feed pi version which is mentioned in this thread.
    But compiling and installing dump1090 should be more or less the same no matter the system (that is if you have apt-get, which Mint apparently has)

  3. #3
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,719
    Quote Originally Posted by Space Pilot View Post
    I'd like to first install dump1090-mutability on my Linux laptop (Mint 19) for testing receivers and antennas. Should I follow the instructions posted here?

    Thanks,
    SpacePilot
    Quote Originally Posted by wiedehopf View Post
    Should work in principal.

    You can't install the fr24feed pi version which is mentioned in this thread.
    But compiling and installing dump1090 should be more or less the same no matter the system (that is if you have apt-get, which Mint apparently has)
    To install FR24 feeder on Lnux Mint installed on Laptop, follow the instructions here:

    https://forum.flightradar24.com/thre...l=1#post116967


    .

  4. #4
    Passenger
    Join Date
    Apr 2015
    Posts
    24
    I thought so, thanks for confirmation. Dump1090-mutability on my laptop is just for experimentation (different RF hardware setups, Open Street Map). Later I'll install the FR24 feeder on a Raspberry Pi.

    Thank you very much!

    SpacePilot
    Last edited by Space Pilot; 2019-04-05 at 18:57.

  5. #5
    Passenger
    Join Date
    Apr 2015
    Posts
    24
    No luck so far...

    Step 4:
    ...
    sudo dpkg-buildpackage -b

    dpkg-shlibdeps: Fehler: keine Abhängigkeitsinformationen für /usr/local/lib/librtlsdr.so.0 (verwendet von debian/dump1090-mutability/usr/bin/dump1090-mutability) gefunden

    which more or less translates to

    "Error: No dependency information found for /usr/local/lib/librtlsdr.so.0 (used by debian / dump1090-mutability / usr / bin / dump1090-mutability)"

    I don't have my dpkg-shlibdeps manpages handy - can anybody help me please?

    TIA
    SpacePilot
    Last edited by Space Pilot; 2019-04-05 at 19:07.

  6. #6
    Captain
    Join Date
    Apr 2018
    Posts
    691
    If you use a self compiled library you'll have to override the dependency checks.

    Try this command before starting the build:
    Code:
    export DEB_DH_SHLIBDEPS_ARGS_ALL=--dpkg-shlibdeps-params=--ignore-missing-info
    Or you can uninstall the local library you installed.

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,719
    (1) Edit file debian/rules and disabled dh_shlibdeps:
    Code:
    cd dump1090 
    
    sudo nano debian/rules 
    
    # In file debian/rules, the last two lines are:
    
    %: 
            dh $@ --with=systemd 
    
    #Below last line, add following two lines, then Save & Close file:
    
    override_dh_shlibdeps: 
            dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
    Note: Indenting of last line (which starts with dh_shlibdeps) to be done by pressing Tab key

    (2) Run build command:
    Code:
    dpkg-buildpackage -b -d
    Last edited by abcd567; 2019-04-05 at 20:37.

  8. #8
    Passenger
    Join Date
    Apr 2015
    Posts
    24
    That worked, thanks a lot!

    Just one little thing: dpkg-buildpackage: Warning: UNRELEASED build not signed; use --force-sign to override

    I tried to build again with --force-sign

    dpkg-buildpackage: Error: Signing .buildinfo-File failed
    Last edited by Space Pilot; 2019-04-05 at 21:01.

  9. #9
    Captain
    Join Date
    Apr 2018
    Posts
    691
    You don't need a signed package for a local install.

    Signing is for verifying cryptographically that the package comes from debian when the package is distributed via apt.

  10. #10
    Passenger
    Join Date
    Apr 2015
    Posts
    24
    oh, I see, thanks again. Will set up the wireless hardware now :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •