Page 4 of 28 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 280

Thread: Windows Setup/Feed Migration (virtualVM) Assistance

  1. #31
    Captain
    Join Date
    Apr 2018
    Posts
    752
    You could also use this as the content of the udev file instead.
    https://raw.githubusercontent.com/fl...-splitter.udev

    But you would need to change the path to /dev/beast in the /etc/fr24feed.ini and add the fr24 user to the group beast (and create the group beast).

    That is a little more targeted and elegant than giving everyone access to /dev/ttyUSB

  2. #32
    First officer
    Join Date
    Dec 2014
    Posts
    225
    For some reason it can no longer connect to ttyUSB0, although the ls command shows it is present. My sudo usermod line doesn't fix it, nor does wiedehopf's custom udev rule. That'll do for this morning, thanks all. Noted the comment Oblivian about PP config, I'll try it later without the wizard.

  3. #33
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,008
    Currently working (as seen by background greens)

    planeplotter.jpg

    If I accidentally set to a wrong port, or wrong IP (or USB direct) = crash

    Which is what is happening when FR24 decides to stop accepting connections on me and it retries (grrr!)
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  4. #34
    First officer
    Join Date
    Dec 2014
    Posts
    225
    Quote Originally Posted by Oblivian View Post
    Currently working (as seen by background greens)

    planeplotter.jpg

    If I accidentally set to a wrong port, or wrong IP (or USB direct) = crash

    Which is what is happening when FR24 decides to stop accepting connections on me and it retries (grrr!)
    Now if I could get FR24feed talking to ttyUSB0 again I'd replicate those settings.......

  5. #35
    Captain
    Join Date
    Apr 2018
    Posts
    752
    Maybe just do a reboot and check if ttyUSB0 is still present?
    this will show it present:
    ls /dev/ttyUSB*

  6. #36
    First officer
    Join Date
    Dec 2014
    Posts
    225
    Quote Originally Posted by wiedehopf View Post
    Maybe just do a reboot and check if ttyUSB0 is still present?
    this will show it present:
    ls /dev/ttyUSB*
    Yes, still shows present. Whether its related I don't know, but Ubuntu is throwing up an unspecified software error now and asking if I want to report it. There is no clue as to what the error or software is.

  7. #37
    Captain
    Join Date
    Apr 2018
    Posts
    752
    Just in case remove the file with the udev rule. Maybe it's complicating something.

    Then do another reboot.

  8. #38
    First officer
    Join Date
    Dec 2014
    Posts
    225
    It appears it may be related to the fr24feed auto-start. On rebooting I entered 'fr24feed -status' and saw that it was creating the FR24 feed and then trying to connect to the Beast via ttyUSB0. So after a minute or two of connecting attempts, I opened another terminal and ran 'sudo service fr24feed stop'. The original terminal continued to show connection attempts. In the second terminal I then ran 'sudo fr24feed' and everything came up and running. I'll have to look back through a few posts to find out what steps I used.

    I've configured Planeplotter as per Oblivian's settings, and also activated the software. Getting shared traffic, but yet to get the local traffic.
    Last edited by Stealth; 2019-03-30 at 05:34.

  9. #39
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,008
    fr24feed -status

    Will re-run a second copy. Default install is run-as-service =conflict of devices

    the proper command is

    sudo fr24feed-status.... no space! Or it runs the command 'fr24feed' on it's own (ignoring the 2nd portion as no valid option record)

    I'm advised the .deb install version requires sudo fr24feed --status
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  10. #40
    First officer
    Join Date
    Dec 2014
    Posts
    225
    Ahhhh, that could be the issue. I think that's confirmed when I browse to localhost:8745 and it tells me no aircraft have been uploaded, but FR web site is showing traffic being uploaded.

    EDIT
    Tried:
    sudo fr24feed-status
    sudo fr24feed--status

    Both gave unknown command

    sudo fr24feed --status >brought up fr24feed, appeared that it had started the app

    localhost:8745 now shows it running correctly with MLAT

    Planeplotter is now showing local traffic.

    EDIT No.2 Planefinder is also now working (linux not wine)
    Last edited by Stealth; 2019-03-30 at 06:29.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •