Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Raspian OS on Asus eee

  1. #1
    Passenger
    Join Date
    Dec 2018
    Posts
    11

    Arrow Raspian OS on Asus eee

    Dear all,
    I am a fr24 feeder since few years. I have been feeding the system via windows, when my computer was on till now. I want to create a stand alone solution using an old Asus eee box, instead of buying a raspberry pi. I've installed raspian OS on this small computer and try to configure the USB dongle installing the fr24feed. I try to install the repo via command line
    PHP Code:
    sudo bash -"$(wget -O - #####repo-feed.flightradar24.com/install_fr24_rpi.sh)" 
    but it seems it cannot find the fr24feed software. So I downloaded the .tgz package and I did uncompressed it, but if I double click on the fr24feed the command line open up and close again very fast that I cannot see what's going on. Someone can help me? Thanks a lot in advance

  2. #2
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,768
    With Raspbian OS, the best way is to install by .deb package, as it performs all necessary configuration also.

    The standard Raspbian OS is for CPU architecture armhf. What is the CPU of your Ausus eee?

    Seems you have installed Raspbian Desktop for PC & Mac (Raspbian Stretch x86 rpd), which is for x64 & x86.

    For cpu architecture x64 & x86, try this


    Code:
    sudo apt update
    
    sudo apt install wget libc6 libstdc++6 zlib1g libusb-1.0-0  libudev1 dirmngr
    
    sudo wget https://repo-feed.flightradar24.com/linux_x86_binaries/fr24feed_1.0.18-5_i386.deb  
    
    sudo dpkg -i  fr24feed_1.0.18-5_i386.deb
    If above fails, give following commands:

    Code:
    sudo apt --fix-broken install  
    
    sudo dpkg -i  fr24feed_1.0.18-5_i386.deb
    Last edited by abcd567; 2018-12-25 at 04:14.

  3. #3
    Passenger
    Join Date
    Dec 2018
    Posts
    11
    Thanks very much for your quick answer. It looks like the first solution works. Now I'm trying to configure the small usb stick, can you just give me few more tips to get to the end? I'm not a master using linux and I don't know what's next. thanks again and merry christmas2018-12-25-100825_1920x1080_scrot.jpg

  4. #4
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,008
    You chose MicroADSB.

    It's not a microADSB stick. You have a DVBT stick.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  5. #5
    Passenger
    Join Date
    Dec 2018
    Posts
    11
    Oh yes, that's right. I haven't seen it because it was on the top This is what I have done, but it told me the email was wrong, but I never inserted the email address in the configuration process, I do I check the status of the fr24feed after I start the service? thanks2018-12-25-105848_1920x1080_scrot.jpg
    Last edited by Luwolfu; 2018-12-25 at 12:35.

  6. #6
    Passenger
    Join Date
    Dec 2018
    Posts
    11
    in the status window it gives me this issue Attachment 9988

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,768
    Open file fr24feed.ini for editing.
    Code:
    sudo nano /etc/fr24feed.ini
    Delete whatever is in this file (except the feeder key, if it is there)
    Copy-paste following into the file fr24feed.ini.
    replace xxxxxxxxxxxxxxxx by your actual feeder key.
    Your actual feeder key is saved in fr24 windows feeder's fr24feed.ini file


    Code:
    receiver="beast-tcp"
    fr24key="xxxxxxxxxxxxxxxx"
    host="127.0.0.1:30005"
    bs="no"
    raw="no"
    logmode="0"
    windowmode="0"
    mpx="no"
    mlat="yes"
    mlat-without-gps="yes"
    use-http=yes
    http-timeout=10
    After copy-paste, Save (Ctrl+o) and Close (Ctrl+x)
    Then restart fr24feed
    Code:
    sudo systemctl restart fr24feed


    GET YOUR KEY FROM HERE
    fr24 windows ini file.png
    Last edited by abcd567; 2018-12-25 at 13:52.

  8. #8
    Passenger
    Join Date
    Dec 2018
    Posts
    11
    this is the error I get now2018-12-25-150228_1920x1080_scrot.jpg

  9. #9
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,768
    This shows that you have NOT installed any DECODER (dump1090-mr or dump1090-mutability or dump1090-fa or modeSDeco2 etc).
    You have two ways to do that:


    METHOD - A

    (1) Open file "/etc/fr24feed.ini" for editing
    Code:
    sudo nano /etc/fr24feed.ini
    (2) Change
    receiver="beast-tcp"
    to
    receiver="dvbt"

    (3) Save (Ctrl+o) and Close (Ctrl+x) the file

    (4) Restart fr24feed
    Code:
    sudo systemctl restart fr24feed
    Setting receiver=dvbt will cause fr24feeder to install dump1090-mutability.


    METHOD - B
    Leave the setting at receiver="beast-tcp"
    Manually install dump1090-mutability by method given here:

    How to Install dump1090-mutability_1.15~dev on RPi.
    Last edited by abcd567; 2018-12-25 at 18:02.

  10. #10
    Passenger
    Join Date
    Dec 2018
    Posts
    11
    ok, thanks for your patience and answers. I've been trying the dump1090 solution, this what I get 2018-12-25-202004_1920x1080_scrot.jpg

    back at the first solution, the one with "dvbt" this is the error the status page show me 2018-12-25-202136_1920x1080_scrot.jpg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •