Results 1 to 7 of 7

Thread: Installation issue...

  1. #1
    Passenger
    Join Date
    Jan 2018
    Posts
    24

    Installation issue...

    Hello

    I try to install fr24feed but get this error.
    I try Stretch workaround, dirmngr is running...

    I launch sudo bash -c command (sorry no link allowed, user too new...)

    gpg: keyserver receive failed: No keyserver available

    Any idea ?

  2. #2
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,876
    Few days ago, I also faced exactly same problem when using bash script on Raspbian STRETCH

    Code:
    pi@raspberrypi:~ $ sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    .............
    gpg: keyserver receive failed: Server indicated a failure
    GPG key problem encountered on STRETCH only, NOT on JESSIE.

    Solved GPG key problem by manually installing the key. Had to switch from pi to root to install the key. In Raspbian (Jessie & Stretch) root password is not set. First I had to set the root password, the changed user from pi to root using this password. After completing gpg task, switched back to user pi using user pi's password.
    Code:
    #Added password of my choice to user root
    pi@raspberrypi:~ $ sudo passwd root
    Enter new UNIX password:
    Retype new UNIX password:
    passwd: password updated successfully
    
    #Switched from user pi to user root, using new root password whichwas set as above.
    pi@raspberrypi:~ $ su root
    Password:
    
    #Started manual install of gpg key
    root@raspberrypi:/home/pi# gpg --keyserver pool.sks-keyservers.net --recv-keys 40C430F5
    root@raspberrypi:/home/pi# gpg --armor --export 40C430F5 | apt-key add -  
    root@raspberrypi:/home/pi# mv /etc/apt/sources.list /etc/apt/sources.list.bak 
    root@raspberrypi:/home/pi# grep -v flightradar24 /etc/apt/sources.list.bak > /etc/apt/sources.list || echo OK
    root@raspberrypi:/home/pi# echo 'deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable' >> /etc/apt/sources.list
    After installing gpg key manually, switched back to user pi, and ran the bash script again.
    Code:
    #Switch back to user pi
    root@raspberrypi:/home/pi# su pi
    
    #Run bash script
    pi@raspberrypi:~ $ sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

  3. #3
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,876
    If AFTER manual installation of gpg keys, the bash script again fails to install fr24feed, then try this method

    Code:
    sudo apt-get update
    sudo apt-get install dirmngr
    sudo apt-get install fr24feed

  4. #4
    Passenger
    Join Date
    Jan 2017
    Posts
    3
    [QUOTE/]
    root@raspberrypi:/home/pi# gpg --keyserver pool.sks-keyservers.net --recv-keys 40C430F5
    root@raspberrypi:/home/pi# gpg --armor --export 40C430F5 | apt-key add -
    [/code]

    [/QUOTE]

    after trying this commands, still the same error shows.
    gpg: keyserver receive failed: connection refused.

    problem happened since the time I installed VPN on my pi using static IP and DNS for it. can it be a reason?
    Last edited by nhrad; 2019-02-06 at 18:57.

  5. #5
    Captain
    Join Date
    Apr 2018
    Posts
    881
    wow this forum software is sure suboptimal about deleted posts making the thread look unread -.-

    Oh just making this post fixed it.
    Well that's good to know.

  6. #6
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,057
    It was an auto moderated post. I approved it.

    User decided to edit it, boom. Auto moderated again.

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  7. #7
    Captain
    Join Date
    Apr 2018
    Posts
    881
    Quote Originally Posted by nhrad View Post
    after trying this commands, still the same error shows.
    gpg: keyserver receive failed: connection refused.

    problem happened since the time I installed VPN on my pi using static IP and DNS for it. can it be a reason?
    Just try the install script again. This looks to me like an overloaded key server or your IP is blacklisted for whatever reason.

    Apart from that you can do the installation in another way as well:
    Code:
    wget -O fr24.deb https://repo-feed.flightradar24.com/rpi_binaries/fr24feed_1.0.23-8_armhf.deb
    sudo dpkg -i fr24.deb
    sudo fr24feed --signup
    sudo systemctl restart fr24feed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •