Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: Pi24 Fails on startup.

  1. #31
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Toronto CYYZ

    Edit file lighttpd.conf, and change port number from default 80 to whatever number you want.

    STEP-1 of 4
    Open file in nano
    sudo nano /etc/lighttpd/lighttpd.conf
    STEP-2 of 4
    Scroll down to line "server.port =80"
    Change port number as you want

    server.modules = (
    server.document-root        = "/var/www/html"
    server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
    server.errorlog             = "/var/log/lighttpd/error.log"             = "/var/run/"
    server.username             = "www-data"
    server.groupname            = "www-data"
    server.port                 = 80
    index-file.names            = ( "index.php", "index.html", "index.lighttpd.html" )
    url.access-deny             = ( "~", ".inc" )
    static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
    STEP-3 of 4
    Save file (Ctrl+o) and close it (Crtl+x)

    STEP-4 of 4
    RESTART lighttpd to implement changes
    sudo systemctl restart lighttpd

    After changing port number from default 80 to 8036 in file lighttpd.conf, the address will be as follows:

    Above is an example for following case:
    (1) Port # 8036 is opened in router for your Pi and Application "HTTP" or "WEBSERVER"
    (2) In file lighttpd.conf, item server.port is changed from default 80 to 8036
    (3) Your Internet IP is
    Last edited by abcd567; 2018-09-11 at 18:11.

  2. #32
    Join Date
    Sep 2018
    Moore, OK USA
    As usual and expected this didnt go as planned lol
    I have tried opening lots of different ports and the only one I could get to open is 3389 for Remote Desktop. The last one I tried was actually the one I randomly selected above 8036 which im able to open for tcp only apparently.
    I change the port in the config file and neither the local address works as well as the internet IP address after that.
    I know for sure 3389 works because I use RDP but even trying that with this it still wouldnt load. The errors im getting are Connection_TimedOut
    For the record I am only using one router and have used port forwarding before. Either I have to have a very specific port number or something isnt set right in the Pi.

    After editing the file and restarting the Pi is there some type of command I can perform for the Pi to check the new port?

  3. #33
    Super Moderator
    Join Date
    May 2011
    T-NZCH1, PP:PH New Zealand
    Stop confusing things. Leave internal config files as is/as 80. Make the EXTERNAL whatever you please or router allows and point it to INTERNAL port 80

    Let the router do the work.

    Btw this should be in its own thread. Not continuing a not starting discussion

    Sent from my XT1092 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts