Results 1 to 8 of 8

Thread: Problem fetching data from dump1090

  1. #1
    Passenger
    Join Date
    Jun 2018
    Posts
    8

    Problem fetching data from dump1090

    Hello to everyone!

    I've made my own Pi24 box and it was working fine for more than a month now!
    The system is based on a Raspberry Pi B 3+, an RTL-SDR v3 dongle and a FlightAware filter together with the antenna.
    I haven't changed anything but since this morning I am getting this message:

    "Problem fetching data from dump1090.
    The data from dump1090 hasn't been updated in a while. Maybe dump1090 is no longer running?
    The displayed map data will be out of date"


    Where is the problem? Any help?

  2. #2
    Passenger
    Join Date
    Jun 2018
    Posts
    8
    Any help at all?

    The screen look like that:
    https://www.dropbox.com/s/torq7g42h7xl5gw/Pi24.png?dl=0

  3. #3
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,268
    Software auto updates and can over-write files

    Especially if you ever pick DVBT for fr24 source and later reboot for it to take effect. It will mess up all the feeders and dump1090

    https://forum.flightradar24.com/thre...hing#post96275
    https://forum.flightradar24.com/thre...light=fetching

    Theres far too many causes to help without some local testing further.

    Overritten dump1090 (fr24 dvbt setting)
    updating feed SW
    updating FA software
    updating RTLSDR package

    You name it. You need to check all the open/closed ports. Feed/dump1090 statuses and in/out data port settings locally first to narrow it down.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  4. #4
    Passenger
    Join Date
    Jun 2018
    Posts
    8
    Is it posible to totaly delete the full instalation and instal it again?

    Previously I've instaled the software by just using sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)" on a clean Raspbian Stretch Lite image

  5. #5
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,312
    Test if your RTL-SDR v3 dongle is working ok

    Is My DVB-T RTL SDR Dongle Healthy?
    USE OPTION-2: DVB-T Plugged into RPi

    If RTL-SDR v3 dongle is NOT working ok:
    (1) unplug and re-plug the RTL-SDR v3 dongle.
    (2) If you are using a USB extender cable between Pi and RTL-SDR v3 dongle, remove it and plugin dongle directly in the Pi
    (3) Change your 5V DC power supply. The dongle fails if power supply goes bad.

  6. #6
    Passenger
    Join Date
    Jun 2018
    Posts
    8
    When I type rtl_test -t it returns No supported devices found.

    It seems that my RTL-SDR dongle is broken somehow...

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,312
    Quote Originally Posted by john_kedros View Post
    When I type rtl_test -t it returns No supported devices found.

    It seems that my RTL-SDR dongle is broken somehow...
    1) Un-plug the dongle from Pi, then re-plug it firmly, then reboot Pi.

    2) If your dongle is connected to Pi using a USB cable, remove cable and plug the dongle directly into the Pi.

    3) Try another 5V DC adapter.
    Last edited by abcd567; 2018-08-08 at 16:26.

  8. #8
    Passenger
    Join Date
    Jun 2018
    Posts
    8
    It was a cold soldering joint inside the RTL-SDR v3 dongle!

    Everything is working fine now... but I was expecting better quality control from RTL-SDR!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •