Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Raspberry Pi 3 B vs Raspberry Pi Zero W

  1. #11
    Flight attendant majo's Avatar
    Join Date
    Nov 2014
    Location
    Bremen, Germany
    Posts
    56
    My testing of the FlightAware Pro Plus stick is interrupted by this error:

    pi@rpiz1:~ $ rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001000
    Using device 0: Generic RTL2832U
    usb_claim_interface error -6
    Failed to open rtlsdr device #0.

    Dump1090-mutability stopped:

    pi@rpiz1:~ $ sudo service dump1090-mutability status
    ● dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
    Loaded: loaded (/etc/init.d/dump1090-mutability; generated; vendor preset: enabled)
    Active: inactive (dead) since Thu 2018-08-09 02:43:17 CEST; 2min 57s ago
    Docs: man:systemd-sysv-generator(8)
    Process: 1078 ExecStop=/etc/init.d/dump1090-mutability stop (code=exited, status=0/SUCCESS)
    Process: 216 ExecStart=/etc/init.d/dump1090-mutability start (code=exited, status=0/SUCCESS)

    Aug 09 02:39:45 rpiz1 systemd[1]: Starting LSB: dump1090 daemon (mutability variant)...
    Aug 09 02:40:04 rpiz1 dump1090-mutability[216]: Not starting dump1090-mutability daemon, disabled via /etc/default/dump1090-mu
    Aug 09 02:40:04 rpiz1 systemd[1]: Started LSB: dump1090 daemon (mutability variant).
    Aug 09 02:43:17 rpiz1 systemd[1]: Stopping LSB: dump1090 daemon (mutability variant)...
    Aug 09 02:43:17 rpiz1 dump1090-mutability[1078]: start-stop-daemon: user 'dump1090' not found
    Aug 09 02:43:17 rpiz1 systemd[1]: Stopped LSB: dump1090 daemon (mutability variant).


    The stick even got some extra power via 3-element-OTG-cable.

    Any ideas?

  2. #12
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,850
    First stop ALL feeders and decoders
    Code:
    sudo systemctl stop fr24feed
    sudo systemctl stop piaware
    sudo systemctl stop pfclient
    
    sudo systemctl stop dump1090-mutability
    sudo systemctl stop dump1090-fa
    sudo systemctl stop dump1090

    Now test the dongle
    Code:
    rtl_test -t

    After test is over, reboot Pi to normalize the system, decoder and feeders
    Code:
    sudo reboot
    Last edited by abcd567; 2018-08-09 at 01:21.

  3. #13
    Flight attendant majo's Avatar
    Join Date
    Nov 2014
    Location
    Bremen, Germany
    Posts
    56
    Test worked after stopping feed AND dump:

    pi@rpiz1:~ $ rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001000

    Using device 0: Generic RTL2832U
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    [R82XX] PLL not locked!
    Sampling at 2048000 S/s.
    No E4000 tuner found, aborting.

  4. #14
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,046
    Then one of your setups is configured incorrect

    Both will be trying to start it, So whatever gets it first will. And as soon as you stop the 1st the 2nd will take it.

    Dump1090 should be the only thing configured for DVBT direct access
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  5. #15
    Flight attendant majo's Avatar
    Join Date
    Nov 2014
    Location
    Bremen, Germany
    Posts
    56
    Quote Originally Posted by Oblivian View Post
    Then one of your setups is configured incorrect

    Both will be trying to start it, So whatever gets it first will. And as soon as you stop the 1st the 2nd will take it.

    Dump1090 should be the only thing configured for DVBT direct access
    Configuration was mostly automatic.
    After installing Raspbian (PI24-image did not work on my Pi Zero) and deactivation of IPv6 I used "sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)".
    One abnormalty during installation was a message roughly like "There was no dump1090 found but after first start of fr24feed it will be installed automatically".

  6. #16
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,046
    Quote Originally Posted by majo View Post
    Configuration was mostly automatic.
    After installing Raspbian (PI24-image did not work on my Pi Zero) and deactivation of IPv6 I used "sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)".
    One abnormalty during installation was a message roughly like "There was no dump1090 found but after first start of fr24feed it will be installed automatically".
    That'd be it. If you follow the raw install but intend to run Dump1090 for other apps. It changes to Run-on-demand unless you do DUmp1090 install beforehand. The offshoot is it breaks anyone else who had dump1090 already if you don't chose network data source

    Thats why we say NEVER select 'DVBT' unless FR24 is the only feeder intended.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  7. #17
    Flight attendant majo's Avatar
    Join Date
    Nov 2014
    Location
    Bremen, Germany
    Posts
    56
    Thanks Oblivian,
    that motivates me to do a new manual installation.
    I hope this one is still working: https://forum.flightradar24.com/thre...-15-dev-on-RPi

  8. #18
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,850
    First check which version of dump1090 is installed
    Code:
    apt-cache policy dump1090-mutability
    If the output of above command says "installed ver 1.14", then it is the dump1090 installed by fr24 feeder. In this case the easiest way to set / change gain is to do it in the settings page in your browser at following address (IP-OF-PI is something like 192.168.0.21)

    IP-OF-PI:8754/settings.html

    In the settings page, in field "Process arguments", add "--gain xx" (where xx is desired value of gain). Then click Save, then restart buttons. Both buttons are at bottom-right of settings page. Please see screenshot below which shows how & where to add gain.

    fr24feed_setting_using_integral_dump1090-mutability_v1.14.png
    Last edited by abcd567; 2018-08-09 at 09:46.

  9. #19
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,850
    Quote Originally Posted by majo View Post
    Thanks Oblivian,
    that motivates me to do a new manual installation.
    I hope this one is still working: https://forum.flightradar24.com/thre...-15-dev-on-RPi
    Yes, this one is still valid and working.

    Since current version of Raspbian is Stretch, you will be required to do the workaround for missing rtl-sdr rules, as given in post #75 of that thread:

    https://forum.flightradar24.com/thre...ll=1#post96279
    Last edited by abcd567; 2018-08-09 at 09:57.

  10. #20
    Flight attendant majo's Avatar
    Join Date
    Nov 2014
    Location
    Bremen, Germany
    Posts
    56
    Pi Zero W is online again and feeding. While testing different gainsettings my meantime findings are:
    Just replacing a Pi3B with a Pi Zero W is not trouble-free.
    Pi24 image is obviously not yet compatible to Pi Zero W.
    Bash installation script first installs fr24 feeder and then dump1090 which leads into problems.
    A necessary micro-usb to usb adapter to connect the Pi Zero with the dvbt-stick might result into power problems.

    Let´s see what is next...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •