Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: RSSI Values compressed

  1. #1
    Passenger jackthom's Avatar
    Join Date
    May 2018
    Location
    Ponteland, Northumberland, EGNT
    Posts
    28

    RSSI Values compressed

    I'm not sure this qualifies as a hardware problem TBH but wondered if others are seeing a very limited range of RSSI values on their /dump1090/gmap.html webpage.

    I'm using only the software provided in the last week or so by FlightRadar24 for the Raspberry Pi.

    Mine only ever covers the range from approx -30.5 to -34 dbFS. This happens with two independent raspberry pi setups and regardless of the aerial in use, the dongle in use (I have four to choose from, one of which is a Flightaware Pro Stick Plus) and is largely independent of the range of the aircraft. I've also played around with gain settings as well as agc on and off, but the only thing that varies is the range and number of aircraft messages decoded.

    For example an aircraft around 2 miles away on final approach and which is clearly visible to me as well as to the aerial, might give a reading of -30 or so while those a good bit further away, even up to 150nm, can be anything from say -32 to -34.

    I have experimented with aerials including a coaxial colinear and a discone using a good low loss coax for 1090MHz, both of these on the roof of the house and with a very good take-off in all directions.

    Next step will be to add a filtered LNA at the antenna end of the feeder although I'm seriously wondering whether even that will make my range of RSSI values appear more sensible.
    Last edited by jackthom; 2018-05-28 at 11:22.

  2. #2
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,835
    @jackthom

    First check what RF signals are existing in your area and picked by your aerial.

    Do I need a Filter? - Find RF Signals In Area


    Here is what I get in my area

    Last edited by abcd567; 2018-05-28 at 14:55.

  3. #3
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,835
    @jackthom

    Here is a plot of Signal Strength and Noise Level in dBFS for last 24 hrs for my Receiver (FA Aerial + FA Filter + FA Pro Stick + Pi)
    dump1090-mutability v1.15~dev

    Last edited by abcd567; 2018-05-28 at 15:12.

  4. #4
    Passenger jackthom's Avatar
    Join Date
    May 2018
    Location
    Ponteland, Northumberland, EGNT
    Posts
    28
    Thanks abcd567. Here's a windows scan using my Jetvision dongle and the rooftop coco antenna. Looks like I definitely need some filtering before the LNA.




    It's the luck of the draw whether much 1090 activity is recorded but after a few passes it wasn't much better than this.

    Edit: I later tried the FlightAware Pro Stick Plus and its internal filter doesn't seem to make a great deal of difference to the 800MHz and 950MHz signals.
    Last edited by jackthom; 2018-05-30 at 18:06. Reason: Image Insertion

  5. #5
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,835
    Yes, for locations with strong GSM850 and EGSM900 signals, the internal filter of ProStick+ is not sufficient and an external filter is required.


  6. #6
    Passenger jackthom's Avatar
    Join Date
    May 2018
    Location
    Ponteland, Northumberland, EGNT
    Posts
    28
    Very useful info, thanks again.

    The FA Filter is certainly cheap enough so I'll have to give it a try.

    I'll report back when it arrives.

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,835
    What is your gain setting?

    If you have not changed it, then it will be default "max".

    Try few lower values of gain like 45, then 40, then 35, then 30. For each setting, for a while watch performance (Messages/sec, Number of planes, max distance aeroplanes are picked by your system). This way you will find the best gain setting for your system.

    Change gain setting by using your browser.

    (1) Go to settings page at address given below.
    For DVBT pligged into RPi:
    ip-of-pi:8754/settings.html

    For DVBT plugged into Windows computer (using windows feeder):
    localhost:8754/settings.html

    (2) In the field "Process Arguments" add argument --gain n, where n is the value of gain you want to set.

    (3) Click "Save" button, then "Restart" button. Both these buttons are at bottom-right of settings page.
    Last edited by abcd567; 2018-05-28 at 20:56.

  8. #8
    Passenger jackthom's Avatar
    Join Date
    May 2018
    Location
    Ponteland, Northumberland, EGNT
    Posts
    28
    Gain is set to max at present. I did try a few different lower settings by editing the entry in the Dump1090-mutability configuration file but I prefer the idea of using the extra arguments field in the web settings page.

    TBH I wasn’t entirely sure my gain entries had the correct syntax. Should the gain numbers in the config file be presented as a string within speech marks <gain=“number”>, as a following number ie <gain number> or in the form <gain=number>.

    I’ll certainly try out a few more alternative gain settings tomorrow.

  9. #9
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,835
    Quote Originally Posted by jackthom View Post
    TBH I wasn’t entirely sure my gain entries had the correct syntax. Should the gain numbers in the config file be presented as a string within speech marks <gain=“number”>, as a following number ie <gain number> or in the form <gain=number>.

    I’ll certainly try out a few more alternative gain settings tomorrow.
    In the file /etc/default/dump1090-mutability , l have used syntax:
    Gain="max"
    Gain=38

    I did not try
    Gain="38"

    After setting a value of gain in the above file and Saving the file, you can check if it is implemented or not by following command:
    Code:
    #First restart dump1090-mutability to pick the new settings
    sudo systemctl restart dump1090-mutability
    
    #Now check status
    sudo systemctl status dump1090-mutability -l
    The output of above status command will be several lines. One of the lines, which is longest line in the output, will have gain value in use.

    Code:
    /usr/bin/dump1090-mutability --measure-noise --net --device-index 0 --gain 38 ......
    Last edited by abcd567; 2018-05-29 at 01:23.

  10. #10
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,835
    Quote Originally Posted by jackthom View Post
    Gain is set to max at present. I did try a few different lower settings by editing the entry in the Dump1090-mutability configuration file but I prefer the idea of using the extra arguments field in the web settings page.
    The "Process Arguments" in the settings page ip-of-pi:8754/settings.html are passed to dump1090-mutability (installed by fr4feed), if "Receiver = DVBT" is used.

    If you are using a seperately installed dump1090-mutability, and using

    "Receiver=AVR(TCP), Host/IP=127.0.0.1:30002"
    or
    "Receiver=ModeS Beast (TCP), Host/IP=127.0.0.1:30005",

    then the "Process Arguments" will not be passed to your separetely installed dump1090-mutability.
    Last edited by abcd567; 2018-05-29 at 01:39.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •