Results 1 to 9 of 9

Thread: Dump1090 Mutability v1.14

  1. #1
    Purser
    Join Date
    Jun 2013
    Location
    Chelmsford, UK
    Posts
    103

    Dump1090 Mutability v1.14

    I have some confusion in my FR24 settings screen I have the lat and long arguments set and when viewing Dump1090 on my local IP it has range rings and my location and distance from a/c shown.

    Capture.PNG

    However if I go to sudo nano /etc/default/dump1090-mutability it shows:

    # If set, supplies a reference location for local position decoding.
    LAT=""
    LON=""

    I actually want to change the Gain setting from max to a lower value, but if I change this in the same file I get told the file is read only ?
    I have tried adding --gain="40" to the FR24 setting screen but it refuses the changes as well.

    Is there another file that FR24 uses instead ?

    Sorry abcd567 I know I have been here before with similar problems

    Millsey.
    T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    3,968
    Think FR24 runs a live config parameter or PROC_ARGS in its own launching script from setup.

    And shouldn't be an = or " sign used for additional command

    --gain 40
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Purser
    Join Date
    Jun 2013
    Location
    Chelmsford, UK
    Posts
    103
    Thanks Oblivian,

    After rebooting it accepts the settings, before rebooting still said "read only" and wouldn't change. Odd this, have encountered this before.

    Cannot understand why if I split the antenna feed to the Dump1090 SDR I see 700 msgs / sec and on RTL1090 SDR I get over 2000 msg / sec and 15-20 more A/C as well ?

    I thought I was overloading the Dump1090 SDR, but this is obviously not the case ? so I have removed the --gain 40 line and am I correct in assuming it will now reset to max ?
    addendum after post - (must do as --gain max totally stopped it receiving anything !!)

    I have a LN4ALL pre-amp feeding them through a MiniCircuits 1090 filter at present, at the SDR end of the coax, not at the mast.

    Millsey
    Last edited by milair; 2018-04-30 at 11:25.
    T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

  4. #4
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    3,968
    40.2 is the correct step. And can be minipulated by the front end gain too

    -10 is reported as Auto/AGC

    https://forum.flightradar24.com/showthread.php?t=11571

    Sent from my XT1092 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  5. #5
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,077
    @Mellsey
    If you want to use Gain="max"

    (1) Remove gain entry (--gain xx) from FR24 Screen (ip-of-pi:8754/settings.html) and save changes by clicking "Save" button.

    (2) Set Gain="max" in file /etc/default/dump1090-mutability.

    (3) Reboot Pi and check by following command:
    Code:
    sudo systemctl status dump1090-mutability -l
    Gain value in use will be displayed inside the output
    Last edited by abcd567; 2018-04-30 at 21:14.

  6. #6
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,077
    The order of precedence is like this:

    (1) FR24 feeder first looks to the file /etc/fr24feed.ini (same values as displayed on FR24 Screen ip-of-pi:8754/settings.html).

    If it finds a process argument entry there, it starts dump1090-mutability with those parameters.

    (2) If FR24 feeder does not find a parameter in file fr24feed.ini, It starts dump1090-mutability using that parameter in file /etc/default/dump1090-mutability.

    (3) If the any item of process arguments is missing in the file /etc/default/dump1090-mutability, then FR24 starts dump1090-mutability with dump1090-mutability's default value for the missing parameter.
    Last edited by abcd567; 2018-04-30 at 21:43.

  7. #7
    Purser
    Join Date
    Jun 2013
    Location
    Chelmsford, UK
    Posts
    103
    @abcd567

    Thanks for the info on order of precedence, makes more sense now
    Still have this weird "read only" problem when trying to edit files using sudo nano, but if I reboot it allows me to edit ok. If I try again the next day it has reverted to read only.

    As the feeds are working fine I'll leave well alone now methinks.

    Millsey
    T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

  8. #8
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,077
    @Millsey:

    This should solve your "read only" problem for both these files
    Code:
    sudo chmod a+rwx /etc/fr24feed.ini
    
    sudo chmod a+rwx /etc/default/dump1090-mutability

  9. #9
    Purser
    Join Date
    Jun 2013
    Location
    Chelmsford, UK
    Posts
    103
    Quote Originally Posted by abcd567 View Post
    @Millsey:

    This should solve your "read only" problem for both these files
    Code:
    sudo chmod a+rwx /etc/fr24feed.ini
    
    sudo chmod a+rwx /etc/default/dump1090-mutability
    Cheers for that, I'll give it a go at the weekend
    T-EGMC14 -- RTL2832U / R820T+ Raspberry Pi + Dump1090 with home made 8 element colinear 12m above ground level.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •