Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Feeder "online" but getting errors in the fr24feed status

  1. #1
    Passenger
    Join Date
    Aug 2017
    Posts
    12

    Feeder "online" but getting errors in the fr24feed status

    Hi,

    I am running a feeder on a Raspberry Pi and according to the FR website it is online but I am getting errors when I run
    Code:
    fr24feed status
    . The following is the error
    Code:
    [reader][i]Connecting to DVBT receiver via (exe:///usr/bin/dump1090-mutability  --raw --mlat)
    [reader][i]Connected to the receiver, configuring
    [reader][i]Configured, processing messages
    Tue Feb 13 22:02:00 2018 UTC  dump1090-mutability v1.14 starting up.
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
    usb_claim_interface error -6
    Error opening the RTLSDR device: Device or resource busy
    [reader][i]Connection terminated
    [main][i]Terminating child process 1075 with SIGTERM
    If I run
    Code:
    lsmod
    the dvb_usb_rtlxxx thing does not show up, I've also added
    Code:
    blacklist dvb_usb_rtl2832u
    blacklist dvb_usb
    into my /etc/modprobe.d/rtl-sdr-blacklist.conf file and rebooted but nothing works, please help

  2. #2
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,854
    Reboot the Pi

    After reboot, wait for 5 minutes, then:
    1. Check status
    Code:
    fr24feed-status
    2. In browser address bar type following address
    ip-of-pi:8754
    Note: in above address, replace ip-of-pi by your Pi's actual Local IP which will be something like 192.168.0.12
    Last edited by abcd567; 2018-02-13 at 22:50.

  3. #3
    Passenger
    Join Date
    Aug 2017
    Posts
    12
    Quote Originally Posted by abcd567 View Post
    Reboot the Pi

    After reboot, wait for 5 minutes, then:
    1. Check status
    Code:
    fr24feed-status
    2. In browser address bar type following address
    ip-of-pi:8754
    Note: in above address, replace ip-of-pi by your Pi's actual Local IP which will be something like 192.168.0.12
    If I run the fr24feed-status command I get the error FR24 MLAT: not running... failed!
    I can access the dashboard on the ip:8754 and it says the receiver is online

  4. #4
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,854
    Go to "Settings" page by following address
    ip-of-pi:8754/settings.html

    If MLAT is set to "NO", change it to "YES".
    Click "Save" button, and after save, click "Restart" button.
    Both these buttons are at bottom-right of settings page

    Wait for 5 minutes, then check status again.

  5. #5
    Passenger
    Join Date
    Aug 2017
    Posts
    12
    Quote Originally Posted by abcd567 View Post
    Go to "Settings" page by following address
    ip-of-pi:8754/settings.html

    If MLAT is set to "NO", change it to "YES".
    Click "Save" button, and after save, click "Restart" button.
    Both these buttons are at bottom-right of settings page

    Wait for 5 minutes, then check status again.
    MLAT is already set to yes and the live version is yes

  6. #6
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,854
    If MLAT is already set to YES, and you still get "FR24 MLAT: not running... failed!", then this is most likely a temporary situation. Please run fr24feed-status after 10 -15 minutes. Most likely MLAT will also show [OK].

  7. #7
    Passenger
    Join Date
    Aug 2017
    Posts
    12
    Quote Originally Posted by abcd567 View Post
    If MLAT is already set to YES, and you still get "FR24 MLAT: not running... failed!", then this is most likely a temporary situation. Please run fr24feed-status after 10 -15 minutes. Most likely MLAT will also show [OK].
    I've tried after 20 minutes and it still shoes failed, I am also still getting the original error that is above when I run fr24feed status

  8. #8
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,854
    One posibilty is missing latitude, longitude and antenna height info.

    You may try following command and signup again giving antenna latitude, longitude and elevation.
    Keep your fr24 key and email address handy to provide these when asked for:

    Code:
    sudo fr24feed --signup

  9. #9
    Passenger
    Join Date
    Aug 2017
    Posts
    12
    Quote Originally Posted by abcd567 View Post
    One posibilty is missing latitude, longitude and antenna height info.

    You may try following command and signup again giving antenna latitude, longitude and elevation.
    Keep your fr24 key and email address handy to provide these when asked for:

    Code:
    sudo fr24feed --signup
    I am 100% sure I added all 3 pieces of information when I signed up, I am in an area with no traffic at the moment, as it is night time, so could that affect it?

  10. #10
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,854
    No traffic definately affects. My feeder keeps on pinging during period 3am to 4am when traffic is almost zero.

    It is not only FR24 which is affected by low traffic. Planefinder feeder also keeps on shutting down and restarting during 3am to 4am every night due to almost zero traffic here during this period.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •