Results 1 to 8 of 8

Thread: RP3 FR24 image + integrated wifi not working

  1. #1
    Passenger
    Join Date
    Jan 2018
    Location
    Madrid, SP
    Posts
    2

    RP3 FR24 image + integrated wifi not working

    Hi guys!

    I ve a RP3 with the official FR24 image (Jessie Lite) install on it. I would like to connect by wifi. Is it possible?

    I have tried to connect by command line but is not working.

    pi.png
    Any idea?

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,930
    not even sure the lite image has wifi capability

    however it is a rpi thing more than a fr24 thing

    https://learn.adafruit.com/adafruits...h-occidentalis
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,688
    1. Create a new blank file /boot/wpa_supplicant.conf
      Code:
      sudo nano /boot/wpa_supplicant.conf
    2. Copy-paste following code into the blank file created in step 1.
      (Replace xxxxxxxx by your SSID and yyyyyyyyyy by your WiFi password)
      Replace CA by two letter code for your country.
      Code:
      country=CA 
      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 
      
      network={
          ssid="xxxxxxxxxx"
          psk="yyyyyyyy"
      }
    3. Save file (Ctrl+o) and close editor (Ctrl+x)

    4. Reboot
      Code:
      sudo reboot
    5. Enjoy WiFi
    Last edited by abcd567; 2019-06-11 at 19:26.

  4. #4
    Passenger
    Join Date
    Jan 2018
    Location
    Madrid, SP
    Posts
    2
    Quote Originally Posted by abcd567 View Post
    1. Create a new blank file /boot/wpa_supplicant.conf
      Code:
      sudo nano /boot/wpa_supplicant.conf
    2. Copy-paste following code into the blank file created in step 1.
      (Replace xxxxxxxx by your SSID and yyyyyyyyyy by your WiFi password)
      Code:
      network={
          ssid="xxxxxxxxxx"
          psk="yyyyyyyy"
      }
    3. Save file (Ctrl+o) and close editor (Ctrl+x)

    4. Reboot
      Code:
      sudo reboot
    5. Enjoy WiFi
    Yes! It works! but I had to change and add this line "wpa-conf /boot/wpa_supplicant.conf" to /etc/network/interfaces file.

    Thanks!

    Screen Shot 2018-01-19 at 18.35.33.png

  5. #5
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,688
    Glad to know it is working.

    Strange that you had to add a line in file /etc/network/interfaces file. I never had to do this on any of my Pi. Only followed steps in my above post.

    EDIT: Checked and found that adding a line "wpa-conf /boot/wpa_supplicant.conf" for wlan0 in file /etc/network/interfaces is required in Pi24 image., but is NOT required in Raspbian (Jessie and Stretch) images,

    The advantage of this method for Raspbian Jessie & Stretch images is that you can create the file /boot/wpa_supplicant.conf while the microSD card is still in the card slot of Windows/Mac computer, immediately after burning the Raspbian image (the /boot folder is visible in Windows/Mac computer). As a result, the WiFi is enabled on first boot, without a Wired connection, without SSH and without monitor/keyboard/mouse.
    Last edited by abcd567; 2018-01-20 at 08:09.

  6. #6
    Passenger
    Join Date
    Apr 2018
    Location
    Łdź, PL
    Posts
    6
    Hi, I've been trying to create this file in: /boot/wpa_supplicant.conf using sudo nano command. Text editor nano shows up, I can enter my wifi details, ctrl+o, ctr+x, sudo restart. After restart I have no file wpa_supplicant.conf in /boot/.
    I'm logged in over putty: pi/raspberry. I believe that during the first try it was "permission denied" or "write only" prompt.
    Many thanks for help!
    T-EPLL59

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,688
    Faddah:

    WiFi Activation
    When Pi reboots, it moves the file wpa_supplicant.conf from /boot folder to /etc/wpa_supplicant/ folder

    After reboot, open this file (if you want to edit it or see its contents) by following command

    Code:
    sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

    Please see STEP-3, item 3.5 of following thread:

    2019 - PI24 QuickStart Guide


    Read only file system error
    Pi24 often gives "read only file system" message. If you get this message, give following command to make file system "read and write".

    Code:
    sudo mount -o remount,rw /
    Last edited by abcd567; 2019-06-11 at 20:38.

  8. #8
    Passenger
    Join Date
    Apr 2018
    Location
    Łdź, PL
    Posts
    6
    Works like a charm Thanks!
    T-EPLL59

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •