Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Is My DVB-T RTL SDR Dongle Healthy?

  1. #1
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,747

    Is My DVB-T RTL SDR Dongle Healthy?

    How To Test If Your DVB-T RTL SDR Dongle Is Healthy

    Following two options are described below:

    OPTION-1: Dongle plugged into Windows Computer.
    OPTION-2: Dongle plugged into Raspberry Pi.

    .

    OPTION-1: Dongle plugged into Windows Computer.

    STEP 1 of 3:
    Install dvb-t rtl driver zadig if not yet done so, as detailed below.

    (1) Download Zadig 2.3.exe from http://zadig.akeo.ie/

    (2) Plug the DVB-T or ProStick in your Windows Computer.

    (3) Follow the steps below:

    (a) Double click Zadig 2.3.exe to run it.
    The window below will open.


    .

    (b) On main menu, click "Options".
    On the drop-down, place a check mark beside "List All Devices".


    .

    (c) From list of devices, select "RTL2838" which is actually DVB-T/ProStick.
    Now click button which will either say "Install Driver" or "Reinstall Driver"
    .
    .

    STEP 2 of 3:
    Download RelWithDebInfo.zip from here:
    Download Link: http://osmocom.org/attachments/downl...ithDebInfo.zip

    Web Page: https://osmocom.org/projects/sdr/wiki/rtl-sdr
    (scroll down to bottom of page to find download link)

    STEP 3 of 3:
    (a) First EXIT your Flightradar24 feeder, or dump1090, or RTL1090 or ModeSdeco2 or any other software which is using DVB-T to make the Dongle free for test.
    (b) Un-zip RelWithDebInfo.zip. It will create a folder RelWithDebInfo.
    Inside this folder there is another folder rtl-sdr-release which contains several files and 2 folders named x32 and x64.
    (c) Go to folder x32. You will find many rtl tools in it as shown in screenshot-1.
    (d) Double-click file rtl_test.exe to run it.
    A command console will open and if Dongle is OK, it will give output as shown in screenshot -2.

    SCREENSHOT-1



    SCREENSHOT-2


    .
    .
    .
    .
    .

    OPTION-2: Dongle plugged into Raspberry Pi.

    STEP-1:
    Install the test tools package rtl-sdr
    Code:
    sudo apt-get update
    sudo apt-get install rtl-sdr
    NOTE: If you have a PI24 image, the above commands sometimes fail to install rtl-sdr due to "read-only file system".
    In this case, issue following command to make the system "read and write", and after this, again run above commands to install rtl-sdr.
    Code:
    sudo mount -o remount ,rw /
    STEP-2:
    Stop dump1090 to free your Dongle for test

    Code:
    #choose one of the following commands,
    #depending on which version of dump1090 you have installed.
    #If you are not sure, issue all three one by one (some of these commands will say "not found")
    
    sudo systemctl stop fr24feed
    sudo systemctl stop dump1090
    sudo systemctl stop dump1090-fa
    sudo systemctl stop dump1090-mutability

    STEP-3:
    Now run the test command
    Code:
     rtl_test -t
    If your Dongle is OK,
    AND
    Properly connected to Pi,
    you will see this output
    Code:
    Found 1 device(s):
      0:  Realtek, RTL2832UFA, SN: 00001001
    
    Using device 0: Generic RTL2832U
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
    Sampling at 2048000 S/s.
    No E4000 tuner found, aborting.
    .

    STEP-4:
    Reboot your Raspberry Pi to restart dump1090 and all data feeders, and restore to normal operation state.
    Code:
     sudo reboot
    .
    Last edited by abcd567; 2019-04-10 at 17:36.

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,000
    Addendum:

    Common fault under Windows10 is the incorrect detection of 2 devices perceived as SDR devices. The real SDR is often the 2nd un-selected by default one

    Found 2 device(s):
    0: T■, ■, SN: T (currently selected)
    1: Realtek, RTL2838UHIDIR, SN: 00000001
    usb_open error -12
    Error opening the RTLSDR device: No error

    Where commands required
    --device-index 1 (for above)

    (same issue when running Windows10 FR24feed.exe but not output to screen other than disconnecting device)

    [reader][i]Connecting to DVBT receiver via (exe://mr-dump1090.exe --raw)
    [reader][i]Connected to the receiver, configuring
    [reader][i]Configured, processing messages
    [reader][i]Connection terminated
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,747
    Quote Originally Posted by Oblivian View Post
    Addendum:
    Common fault under Windows10 is the incorrect detection of 2 devices perceived as SDR devices. The real SDR is often the 2nd un-selected by default one

    Found 2 device(s):
    0: T■, ■, SN: T (currently selected)
    1: Realtek, RTL2838UHIDIR, SN: 00000001
    How to Change Serial Number of Dongle

    In tutorial below it will be changed from default 00000001 to 00000000. This may help solving Windows 10 problem

    (A) Dongle Plugged into Raspberry Pi

    STEP-1
    First stop the dump1090 to make Dongle free for use by rtl tools.
    Code:
    #Give one of the command according to version of dump1090 you have installed
    #If you are not sure of version, give all three commands one by one
    sudo systemctl stop dump1090
    sudo systemctl stop dump1090-mutability
    sudo systemctl stop dump1090-fa

    STEP-2
    Install package rtl-sdr, if not yet done.
    The tool rtl_eeprom is part of package rtl-sdr
    Code:
    sudo apt-get update
    sudo apt-get install rtl-sdr

    STEP-3
    Now give the command rtl_eeprom -s 00000000 to reset the serial number
    The last line of output will ask confirmation to go ahead with change.
    Type y and press Enter key
    Code:
    rtl_eeprom -s 00000000
    Found 1 device(s):
      0:  Generic RTL2832U OEM
    
    Using device 0: Generic RTL2832U OEM
    Found Rafael Micro R820T tuner
    
    Current configuration:
    __________________________________________
    Vendor ID:              0x0bda
    Product ID:             0x2838
    Manufacturer:           Realtek
    Product:                RTL2838UHIDIR
    Serial number:          00000001
    Serial number enabled:  yes
    IR endpoint enabled:    yes
    Remote wakeup enabled:  no
    __________________________________________
    
    New configuration:
    __________________________________________
    Vendor ID:              0x0bda
    Product ID:             0x2838
    Manufacturer:           Realtek
    Product:                RTL2838UHIDIR
    Serial number:          00000000
    Serial number enabled:  yes
    IR endpoint enabled:    yes
    Remote wakeup enabled:  no
    __________________________________________
    Write new configuration to device [y/n]? y
    
    #After typing y and pressing Enter key, you will get this confirmation message
    Configuration successfully written.
    Please replug the device for changes to take effect.
    .

    .


    (B) Dongle Plugged into Windows Computer

    STEP-1
    In folder x32, right-click and create New Text Document



    STEP-2
    Open the New Text Document and type
    rtl_eeprom -s 00000000




    STEP-3
    Save the file as change-serial.bat
    While saving, make sure that
    1. File name contains .bat at the end
    2. "Save as type" is selected "All Files"
    Please see screenshot below.




    STEP-4
    Double click the file change-serial.bat to run it



    STEP-5
    Upon double clicking the file change-serial.bat, command console will open, with last line asking confirmation to change serial number.
    Type y and press Enter key. The serial number will change and command console will close immediately.



    STEP-6
    To check if the number has actually changed, again double click the file change-serial.bat, and it will show changed serial number.
    Type n and press Enter key to close console



    Using RTL1090 on Windows

    Step-1: Open Command Promt, and give command C:\rtl1090>rtl1090.exe /eeprom
    (My rtl1090.exe is located in folder C:\rtl1090, that is why I have used this path. You have to use the path in your computer)

    Step-2: Click START button on RTL1090 window.

    Step-3: Set serial number and press Continue button.

    Last edited by abcd567; 2018-04-15 at 06:52.

  4. #4
    Passenger
    Join Date
    Dec 2016
    Posts
    2
    I got the following error messages:

    pi@raspberrypi:~ $ rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    usb_claim_interface error -6
    Failed to open rtlsdr device #0.

  5. #5
    Passenger
    Join Date
    Apr 2018
    Posts
    14
    Hi Im very new on here and trying to use my rpi model b with a usb dvbt receiver using the pi24img

    My status page shows:

    FR24 Link: Connected via TCP
    FR24 Radar Code: T-EGHJ8
    Local IP(s): 192.168.1.x
    Aircraft Tracked:
    (ModeS & ADS-B) 0
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: NO

    An rtf test shows:
    pi@raspberrypi:~ $ rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_read_reg failed with -1
    rtlsdr_write_reg failed with -1
    No supported tuner found
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_write_reg failed with -4
    rtlsdr_demod_read_reg failed with -4
    Supported gain values (1): 0
    rtlsdr_demod_write_reg failed with -4
    rtlsdr_demod_read_reg failed with -4
    WARNING: Failed to set sample rate.
    No E4000 tuner found, aborting.
    rtlsdr_write_reg failed with -4

    Any ideas please

  6. #6
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,747
    Quote Originally Posted by Mickeflygare View Post
    I got the following error messages:

    pi@raspberrypi:~ $ rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    usb_claim_interface error -6
    Failed to open rtlsdr device #0.
    Sorry for late reply. Have missed your post earlier.

    This error comes when rtl_test command is given while dump1090 is running.
    You have to STOP dump1090 by issuing one of following commands according to version of dump1090 you have
    (if you are not sure of version of dump1090, issue all the three commands)

    sudo systemctl stop dump1090
    sudo systemctl stop dump1090-fa
    sudo systemctl stop dump1090-mutability

  7. #7
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,747
    @Damianiw:

    Sorry for late reply. Have missed your post earlier.

    Following are possibilities
    (1) The Dongle is not properly plugged into Pi. Unplug and replug it, and reboot Pi.
    (2) If dongle is connected to Pi through a USB Cable, the cable is defective
    (3) AC to 5V DC Power adapter is not good.
    (4) Dongle is defective.

  8. #8
    Passenger
    Join Date
    Apr 2018
    Posts
    14
    Thanks - I did try a repost earlier but doesnt seem to have been approved (or declined) by mods.

    I have changed PSU and also used the "All to Easy" install, I have found that upon boot it will work for about 30 seconds then stops working not tracking - at this point even if I execute sudo systemctl stop dump1090-mutability and then the rtl_test -t I will get the error about not being able to lock the device, if I physically unplug the USB DVBT stick and replug then the rtl_test -t will give this result:

    root@raspberrypi:~# rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000000

    Using device 0: Generic RTL2832U OEM
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    Sampling at 2048000 S/s.
    No E4000 tuner found, aborting.
    root@raspberrypi:~# exit

    If I then do a sudo systemctl start dump1090-mutability I get data showing in the dump map for about 30 seconds

    I then get

    Sun Apr 22 18:08:23 2018 BST dump1090-mutability v1.15~dev starting up.
    Using sample converter: UC8, integer/table path
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000000 (currently selected)
    Found Rafael Micro R820T tuner
    Using automatic gain control.
    Gain reported by device: 0.00 dB
    cb transfer status: 1, canceling...
    Sun Apr 22 18:08:29 2018 BST Warning: lost the connection to the RTLSDR device.
    Sun Apr 22 18:08:30 2018 BST No data received from the dongle for a long time, it may have wedged
    Sun Apr 22 18:08:34 2018 BST Trying to reconnect to the RTLSDR device..
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000000 (currently selected)
    Found Rafael Micro R820T tuner
    r82xx_write: i2c wr failed=-1 reg=0f len=1
    r82xx_init: failed=-1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    r82xx_write: i2c wr failed=-1 reg=05 len=1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    Using automatic gain control.
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    r82xx_write: i2c wr failed=-1 reg=17 len=1
    r82xx_set_freq: failed=-1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    Gain reported by device: 0.00 dB
    weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 26 2144 bytes)

    weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
    Sun Apr 22 18:08:35 2018 BST No data received from the dongle for a long time, it may have wedged



    I am using a Rpi Model B, I have changed to a different 2.1a 5v PSU with the same issue and tried a different fresh SD card, I purchased my DVBT off ebay and the seller is kindly shipping another for me to try in case it is faulty.

  9. #9
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,000
    To answer Damianiw - @ signs and some code triggers anti-spam under a threshold.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  10. #10
    Passenger
    Join Date
    Apr 2018
    Posts
    14
    Second dvb stick had the same issues so I tested on windows 10 which worked fine, I am thinking the raspberry pi model b isn’t giving enough power so will try a powered usb hub if not I’ll need to invest in a newer pi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •