Page 7 of 11 FirstFirst ... 56789 ... LastLast
Results 61 to 70 of 108

Thread: Raspberry PI installation made too easy with extra feature.

  1. #61
    First officer
    Join Date
    Apr 2018
    Posts
    301
    Basically you want to change the fr24feed.ini to what i posted (except the key)
    Just change it and save it.

    Then you need to install dump1090-fa
    Code:
    wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.6.3_all.deb
    sudo dpkg -i piaware-repository_3.6.3_all.deb
    sudo apt-get update
    sudo apt-get install dump1090-fa
    sudo lighty-disable-mod dump1090
    sudo reboot
    That should do it. You don't need piaware for dump1090-fa to work.
    Last edited by wiedehopf; 2019-02-12 at 05:52.

  2. #62
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,599
    I spy type=dvbt

    And we all know what that does...

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #63
    Passenger
    Join Date
    Jan 2019
    Posts
    36
    Quote Originally Posted by wiedehopf View Post
    Basically you want to change the fr24feed.ini to what i posted (except the key)
    Just change it and save it.

    Then you need to install dump1090-fa
    Code:
    wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.6.3_all.deb
    sudo dpkg -i piaware-repository_3.6.3_all.deb
    sudo apt-get update
    sudo apt-get install dump1090-fa
    sudo lighty-disable-mod dump1090
    sudo reboot
    That should do it. You don't need piaware for dump1090-fa to work.
    Thanks! Will try this during the day today and see how it works. Looking forward to optimizing my setup!

  4. #64
    Passenger
    Join Date
    Jan 2019
    Posts
    36
    Quote Originally Posted by Oblivian View Post
    I spy type=dvbt

    And we all know what that does...

    Sent from my EML-L09 using Tapatalk
    I don't know.... Can you clarify? Something else I should change while optimizing my setup?

  5. #65
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,599
    Quote Originally Posted by anydanow1 View Post
    I don't know.... Can you clarify? Something else I should change while optimizing my setup?
    It blindly installs fr24s dump1090 on-top of any other app/setting already there.

    Often breaking maps etc or causing conflicts with the stick depending on what starts first. The other add-ons will often fail as a result.

    Is why the suggested options given earlier say "DO NOT CHOSE DVBT"

    But we can't unfortunately control other people's blogs/guides for older versions of the software where this change wasn't implemented

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  6. #66
    First officer
    Join Date
    Apr 2018
    Posts
    301
    If you change /etc/fr24feed.ini to what i posted, what Oblivian mentioned won't be a problem.

    Also following the guide he followed, which basically only installs fr24feed, using dvbt as a type is perfectly fine as it does not mention separate installation of dump1090.


    Apart from that you should read this thread on optimizing the small antennas that come with the dongle:
    https://forum.flightradar24.com/thre...h-DVB-T-Dongle

  7. #67
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,599
    I read the map API warning and
    It's all running reliably now...and THEN I found this forum and what seem like better options for viewing my personal receiver data.

    Is there any way to "fix" what I've already done to give me the better looking dump1090-fa output, or do I have to wipe out my whole Pi setup and start from scratch?

    My ini file looks like this:

    receiver="dvbt"

    fr24key="
    As the remainder of instructions (here) have/are possibly been followed while still in dvbt and needed to be fixed

    Just wanted to make sure the start point is infact the 3rd party guide position (and no further adjustments in abcds guide tried.)

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  8. #68
    Passenger
    Join Date
    Jan 2019
    Posts
    36
    Quote Originally Posted by wiedehopf View Post
    Are you using the pi24 image right now?

    I would recommend option 3 or option 4 from here: https://forum.flightradar24.com/thre...24-Data-Feeder

    In option 3 using dump1090-fa is probably easier than dump1090-mutability 1.15 as the second one needs to be compiled.
    Anyway it is all explained quite well in the thread.

    If you are currently using the sd-card image from this thread then you probably used the DVBT(USB) option in the fr24 configuration. That is the wrong option, it leads to installation of an old version of dump1090 with the mentioned google maps. (the new versions use openstreetmap)

    (/etc/fr24feed.ini should look like this:

    Code:
    receiver="beast-tcp"
    fr24key="xxxxxxx_your_key_xxxxxx"
    host="127.0.0.1:30005"
    bs="no"
    raw="no"
    logmode="1"
    logpath="/var/log/"
    mlat="yes"
    mlat-without-gps="yes"
    use-http=yes
    http-timeout=20
    )
    Hi wiedehopf....In your ini file changes above, the line host="127.0.0.1:30005" should be changed to host="myPiIP:30005", is that correct?

    Thanks, John

  9. #69
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,516
    Quote Originally Posted by anydanow1 View Post
    .... the line host="127.0.0.1:30005" should be changed to host="myPiIP:30005", is that correct?
    Wrong.
    It should remain host="127.0.0.1:30005"


    .

  10. #70
    Passenger
    Join Date
    Jan 2019
    Posts
    36
    Quote Originally Posted by abcd567 View Post
    Wrong.
    It should remain host="127.0.0.1:30005"


    .
    OK, thanks abcd......I'm definitely not a developer and I'm just learning the ropes, so I appreciate the quick feedback.

    John

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •