Which RPi version are you using?

The image is most likely too old to support the 3A+ for example, not sure about other hardware versions.

If you want an image that comes with a current version of dump1090, try for example OPTION 4 mention in this post:
https://forum.flightradar24.com/thre...ll=1#post64528

You can also just start with a Raspbian Stretch Lite and install dump1090-fa like mentioned in OPTION 3 of above link.
dump1090-fa is the continuation of the dump1090-mutability development.