Page 16 of 17 FirstFirst ... 614151617 LastLast
Results 151 to 160 of 168

Thread: Automated Installation of Dump1090-Mutability, Data Feeders, and Performance Graphs

  1. #151
    Passenger
    Join Date
    Jan 2018
    Location
    Kerry, Ireland
    Posts
    18
    Quote Originally Posted by abcd567 View Post
    Wiedehop has recently written a script which installs graphs only (no web portal). Give a look here:

    https://github.com/wiedehopf/graphs1090#graphs1090

    .
    Thanks! I'll keep that as an option for future installs. For now, I have used Joe Prochazka's image-based install and that is working fine for me
    T-EIKY1 | T-EICK1

  2. #152
    Flight attendant magnum's Avatar
    Join Date
    Jun 2010
    Location
    35 miles west of FRA
    Posts
    73
    Quote Originally Posted by abcd567 View Post
    Wiedehop has recently written a script which installs graphs only (no web portal). Give a look here:

    .
    To avoid misunderstandings for beginners: The graphs do have a web interface which can be launched by http://<Raspi-IP>/graphs1090 or http://<Raspi-IP>/perf

  3. #153
    Passenger
    Join Date
    Aug 2019
    Location
    Italy
    Posts
    5
    Hello everybody, nice to meet you all.
    I'm a kind of "otaku" for flight tracking, but i'm almost totally zero for what concerns software and linux. Please excuse me if i ask for the obvious or write wrong things...

    I stumbled on this thread and i got attracted by the cool things that i could actually see on my pc with "just" a reinstall.

    I'm feeding data to Fr24 since a couple of years using their package and a leftover raspberry i had on the lab.
    Everything was ok... i mean, no issues but hey, no cool maps and graphs!! what i've been missing for so long!

    So i decided to give a try. (sorry, i cant paste direct links, as a newbie this is forbdden by forum rules).
    At first i used "10232-How-to-Install-dump1090-mutability_1-15-dev-on-RPi" procedure and it worked, but it had no graphs and i could not figure out if i can add them "after" or not.

    I retried from scratch with 10597-Automated-Installation-of-Dump1090-Mutability-Data-Feeders-and-Performance-Graphs (that should give both, maps and graphs) but the procedure fails.

    I'm installing on the currently available raspbian ( specifically, Raspbian Buster Lite released on july 10,2019). Before starting i do update/upgrade as a good boy

    The last thing i can capture from the procedure log screen is as follows (sorry i cant post a proper screenshot).

    **
    gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION="v1.15~dev" -g -O2 -fdebug-prefix-map=/home/luca/adsb-receiver/build/dump1090-mutability/dump1090=. -fstack-protector-strong -Wformat -Werror=format-security -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH="/usr/share/dump1090-mutability/html" -DMODES_DUMP1090_VARIANT="dump1090-mutability" -c convert.c -o convert.o
    gcc -g -o dump1090 dump1090.o anet.o interactive.o mode_ac.o mode_s.o net_io.o crc.o demod_2400.o stats.o cpr.o icao_filter.o track.o util.o convert.o -lpthread -lm -lrt `pkg-config --libs librtlsdr libusb-1.0` -Wl,-z,relro -Wl,-z,now
    /usr/bin/ld: dump1090.o: in function `rtlsdrCallback':
    ./dump1090.c:414: undefined reference to `rtlsdr_cancel_async'
    /usr/bin/ld: dump1090.o: in function `verbose_device_search':
    ./dump1090.c:867: undefined reference to `rtlsdr_get_device_count'
    /usr/bin/ld: ./dump1090.c:874: undefined reference to `rtlsdr_get_device_usb_strings'
    /usr/bin/ld: ./dump1090.c:890: undefined reference to `rtlsdr_get_device_usb_strings'
    /usr/bin/ld: ./dump1090.c:894: undefined reference to `rtlsdr_get_device_name'
    /usr/bin/ld: dump1090.o: in function `modesInitRTLSDR':
    ./dump1090.c:287: undefined reference to `rtlsdr_get_device_count'
    /usr/bin/ld: ./dump1090.c:295: undefined reference to `rtlsdr_get_device_usb_strings'
    /usr/bin/ld: ./dump1090.c:303: undefined reference to `rtlsdr_open'
    /usr/bin/ld: ./dump1090.c:310: undefined reference to `rtlsdr_set_tuner_gain_mode'
    /usr/bin/ld: ./dump1090.c:316: undefined reference to `rtlsdr_get_tuner_gains'
    /usr/bin/ld: ./dump1090.c:323: undefined reference to `rtlsdr_get_tuner_gains'
    /usr/bin/ld: ./dump1090.c:358: undefined reference to `rtlsdr_set_tuner_gain'
    /usr/bin/ld: ./dump1090.c:365: undefined reference to `rtlsdr_set_freq_correction'
    /usr/bin/ld: ./dump1090.c:367: undefined reference to `rtlsdr_set_center_freq'
    /usr/bin/ld: ./dump1090.c:368: undefined reference to `rtlsdr_set_sample_rate'
    /usr/bin/ld: ./dump1090.c:370: undefined reference to `rtlsdr_reset_buffer'
    /usr/bin/ld: ./dump1090.c:372: undefined reference to `rtlsdr_get_tuner_gain'
    /usr/bin/ld: ./dump1090.c:366: undefined reference to `rtlsdr_set_agc_mode'
    /usr/bin/ld: dump1090.o: in function `verbose_device_search':
    ./dump1090.c:900: undefined reference to `rtlsdr_get_device_usb_strings'
    /usr/bin/ld: ./dump1090.c:910: undefined reference to `rtlsdr_get_device_usb_strings'
    /usr/bin/ld: ./dump1090.c:917: undefined reference to `rtlsdr_get_device_name'
    /usr/bin/ld: dump1090.o: in function `readerThreadEntryPoint':
    ./dump1090.c:612: undefined reference to `rtlsdr_read_async'
    /usr/bin/ld: ./dump1090.c:629: undefined reference to `rtlsdr_close'
    /usr/bin/ld: ./dump1090.c:618: undefined reference to `rtlsdr_close'
    collect2: error: ld returned 1 exit status
    make[2]: *** [Makefile:54: dump1090] Error 1
    make[2]: Leaving directory '/home/luca/adsb-receiver/build/dump1090-mutability/dump1090'
    dh_auto_build: make -j1 "EXTRACFLAGS=-DHTMLPATH=\\"/usr/share/dump1090-mutability/html\\" -DMODES_DUMP1090_VARIANT=\\"dump1090-mutability\\"" returned exit code 2
    make[1]: *** [debian/rules:21: override_dh_auto_build] Error 2
    make[1]: Leaving directory '/home/luca/adsb-receiver/build/dump1090-mutability/dump1090'
    make: *** [debian/rules:30: build] Error 2
    dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

    Configuring dump1090-mutability to start automatically....
    Installing the dump1090-mutability package...

    dpkg: error: cannot access archive '/home/luca/adsb-receiver/build/dump1090-mutability/dump1090-mutability_1.15~dev_*.deb': No such file or directory

    Checking that the dump1090-mutability package was installed properly...

    INSTALLATION HALTED!
    UNABLE TO INSTALL A REQUIRED PACKAGE.
    SETUP HAS BEEN TERMINATED!

    The package "-mutability" could not be installed.

    ------------------------------------------------------------------------------
    Dump1090-mutability setup halted.

    Press enter to continue...



    **


    Can anyone provide insight/help?
    Thanks in advance and thanks for the person who created the threads in any case.

  4. #154
    Passenger
    Join Date
    Aug 2019
    Location
    Italy
    Posts
    5
    I forgot to mention that i tried to install 1090 mutabilty using the pre cooked package that worked in the other proicedure....
    but after that, while i could pass beyond the first obstacle, i get a second error tryong to install PHP(well, i guess).
    what i seen is ...

    ****
    INSTALLATION HALTED!
    UNABLE TO INSTALL A REQUIRED PACKAGE.
    SETUP HAS BEEN TERMINATED!

    The package "php7.0-cgi" could not be installed in 5 attempts.

    ANY FURTHER SETUP AND/OR INSTALLATION REQUESTS HAVE BEEN TERMINIATED

    ***

    suggestions welcomed

    thank you all.

  5. #155
    Captain
    Join Date
    Apr 2018
    Posts
    742
    The graphs by the adsb-receiver project script can be installed without installing other things.
    Just select the webinterface only in the installation routine.

    You'd have to modify the script to change the php7.0-cgi to php-cgi.

    But if you don't need the php webinterface, just the graphs:
    https://github.com/wiedehopf/graphs1090#graphs1090

    As for dump1090, i'd go with dump1090-fa:
    https://github.com/wiedehopf/adsb-sc...for-dump1090fa

    For dump1090-fa i've also done some work on improving the webinterface, it has different map layers and a few other features:
    https://github.com/wiedehopf/tar1090#tar1090


    While you are at it, just start fresh with a Raspbian Buster Lite image.
    Last edited by wiedehopf; 2019-08-25 at 11:09.

  6. #156
    Passenger
    Join Date
    Aug 2019
    Location
    Italy
    Posts
    5
    Hello, wiedehopf

    Thank you for the suggestions. I will try wo edit the install script and change the line you suggested.
    It would be great to (let's say) patch the problem without a fresh reinstall. I just reinstalled it this morning while I had a few hours alone (and i dont know when i'll be so lucky again ^^; )

    let's see what happens

    have a nice afternoon.

  7. #157
    Captain
    Join Date
    Apr 2018
    Posts
    742
    Yeah if you're not into patching stuff, use the other install scripts i linked.
    I maintain them and at least currently they are all up to date.

    They should also work with your current installation, they will for the most part overwrite parts of what you already installed with the script.
    (Not sure what the adsb receiver script did before it quit on you)
    Last edited by wiedehopf; 2019-08-25 at 16:52.

  8. #158
    Passenger
    Join Date
    Aug 2019
    Location
    Italy
    Posts
    5
    Hi again!
    It was a bit difficult for me (the script is pretty "elaborate" and as far as i could understand, several things are downloaded according the software version on the raspi.)

    However, with a bit of brute force (lets call it so) i edited the .sh file in the "portal" directory every time the install halted.
    ~/adsb-receiver/bash/portal $
    I had to edit it for php-cgi, php-xml and php-json.
    before each retry I installed the packages manually in advance so to have a positive check but no actual install process...

    but hey, somehow it ended without errors and it works! thank you for addressing me to the solution!

    Now i must ....
    1) find a way to make a backup of the SD as it is (you know, im not sure if i can do that again!)
    2) change the network to use graph to wlan0 and temperatures to celcius
    if you have suggestions....

    For today, i feel very satisfied, in any case!

    thanhs again for the precious suggestions and have a nice evening!

    L.

  9. #159
    Captain
    Join Date
    Apr 2018
    Posts
    742
    In that case i'd recommend to use my graphs, they can be configured for Celsius and automatically add the traffic from wlan and Ethernet

    You can just overwrite the current installation.
    But i'd recommend removing the data after installing my graphs because they save finer grained data which looks nicer in some instances. (sudo rm -r /var/lib/collectd/rrd/localhost/)
    It will automatically recreate the data files.
    Last edited by wiedehopf; 2019-08-25 at 17:45.

  10. #160
    Passenger
    Join Date
    Aug 2019
    Location
    Italy
    Posts
    5
    Hi,

    backup first!
    I'll take a look at yours, i promise. for today , better go sleep happy!

    have a good night!
    L.

    * edit 2019/9/2
    I did try , but something went bad and raspberry did not boot afterwards.... maybe I should have tried a fresh install.
    Luckily i had the backup, so no problems. I also found that i could change measure units and interface on the original setup, from the admin pages.

    Now i'll focus on the range improvement, i seen some interesting post on how to build dirt cheap antennas

    it's all for the update.
    bye
    Last edited by belldandy; 2019-09-02 at 17:45. Reason: tried the suggested procedure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •