Results 1 to 10 of 10

Thread: Can't activate my Pi24 on the website

  1. #1
    Passenger
    Join Date
    Sep 2016
    Posts
    3

    Can't activate my Pi24 on the website

    Hello

    I spent my time yesterday making (trying to make) a wireless Pi24, I used a pi zero and as i didn't have an usb ethernet adaptor i used an enc28j60 ethernet module, connected to gpio.Had a hard time, but finally managed to make it work properly.
    The i activated my raspberry pi on the website, and it worked, but as i tried to connect a wifi dongle, the pi restarted, and i noticed a second pi24 was added to the list.
    Then after hours trying to setting wifi (i finally gave up), i come back too the flightradar website "/activate-raspberry-pi" and no more pi in the list but "device not found".
    My statistics are tracked on feed-stats/?id=17206 but it seems i can't activate my raspberry pi, i tried refreshing the page but still "device not found" will i be booted after 3 days?.

    Also i have another problem, maybe it is the cause, i can't have a static IP, i can do all the nano setting nothing work, my ip is 192.168.0 and a number +1 at every reboot can it pose a problem to track my stats??
    I spent 2 days trying to find a way to fix my problems, I don't know what to do.
    Can someone please help me?

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,055
    If you have an ID, activation is done.

    The 'activate' is just scanning your local network for a heartbeat from the image. But if you have been assigned a code and can see it when logging in. Job done.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Super Moderator Amper's Avatar
    Join Date
    Oct 2013
    Location
    Delta Bravo Victor
    Posts
    742
    Quote Originally Posted by Fabrice View Post

    Also i have another problem, maybe it is the cause, i can't have a static IP, i can do all the nano setting nothing work, my ip is 192.168.0 and a number +1 at every reboot can it pose a problem to track my stats??
    I spent 2 days trying to find a way to fix my problems, I don't know what to do.
    Can someone please help me?
    Try this tutorial
    Code:
    https://www.modmypi.com/blog/tutorial-how-to-give-your-raspberry-pi-a-static-ip-address
    For official support use Contact Form

  4. #4
    Passenger
    Join Date
    Sep 2016
    Location
    New Bern, NC
    Posts
    22
    Fabrice: I had the same issue. Been at it about a week.

    My entire installation appears to be "perfect" but I continue to get "device not found" at the same place you do. I have stopped worry about it.

  5. #5
    Passenger
    Join Date
    Sep 2016
    Posts
    3
    OK; thanks for answering
    I'll give a try,

  6. #6
    Team FR24
    Join Date
    Feb 2015
    Posts
    221
    Quote Originally Posted by jcinnb View Post
    Fabrice: I had the same issue. Been at it about a week.

    My entire installation appears to be "perfect" but I continue to get "device not found" at the same place you do. I have stopped worry about it.
    Do you already have registered a feed or you are trying for the first time ever? If you have done it already then all you need to do is setup the software with the sharing key you were provided. If you are doing it for the first time, then signup for a new account while setting up the software. You can use this command for that: sudo fr24feed --signup
    --

  7. #7
    Passenger
    Join Date
    Sep 2016
    Location
    New Bern, NC
    Posts
    22
    I got a key and have been feeding data. I just never got the device to show up from the "click" on the web site. I just started last week, got my key and off I went, but even after the key, I have never seen the device show up. I dunno.

  8. #8
    Team FR24
    Join Date
    Feb 2015
    Posts
    221
    That doesn't mean that there is a problem. Since a lot of receivers are uploading data and the website can only show one receiver with an aircraft, the one with the latest data is selected. It's very common not to see your code connected to aircraft. You should use Radarview to see your data.
    --

  9. #9
    Passenger
    Join Date
    Sep 2016
    Posts
    3
    My pi can't connect to internet suddenly, my ip wasn't beginning by 192.168 anymore, something happened.
    I finally found out how to get a static IP adress on an ethernet connection:
    sudo nano /etc/dhcpcd.conf

    Then type in the following lines into the file, file was just filled with notes:

    #for ethernet:
    interface eth0
    static ip_address=192.168.0.34
    static routers=192.168.0.1
    static domain_name_servers=192.168.0.1

    #for wifi:
    interface wlan0
    static ip_address=same as above
    static routers=same as above
    static domain_name_servers=same as above

    then "sudo reboot" to take effect.

    But now even if i got a static IP, I can ping my gateway, but cant access the internet.My feed is offline and I cant even do a sudo apt-get update...
    Looks like the "interface" file technique to get an IP never worked for me.

  10. #10
    Passenger
    Join Date
    Sep 2016
    Location
    New Bern, NC
    Posts
    22
    Quote Originally Posted by Khan View Post
    That doesn't mean that there is a problem. Since a lot of receivers are uploading data and the website can only show one receiver with an aircraft, the one with the latest data is selected. It's very common not to see your code connected to aircraft. You should use Radarview to see your data.

    I apologize, I was not clear. It is no big deal, but just to clarify, I was referring to the instructions on setting up the RPi.

    This part here is where I get the error:

    On your computer, or LAN connected smartphone/tablet, click on the following link and our system will automatically detect your Pi24 and as you to register it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •