Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Micro ads-b connected to Raspberry Pi 3b

  1. #1
    Passenger
    Join Date
    Mar 2013
    Location
    Oslo, Norway
    Posts
    5

    Question Micro ads-b connected to Raspberry Pi 3b

    Hi all

    Does the micro ads-b USB dongle work with the fr24 software for Raspian?
    Or is it only for dvb-t dongle?

  2. #2
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,743
    Quote Originally Posted by Oslo85 View Post
    Hi all

    Does the micro ads-b USB dongle work with the fr24 software for Raspian?
    Or is it only for dvb-t dongle?
    In theory.

    I would need to update mine and test to confirm. But prior during setup it was an option

    Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):

    1 - DVBT Stick (USB)
    -----------------------------------------------------
    2 - SBS1/SBS1er (USB/Network)
    3 - SBS3 (USB/Network)
    4 - ModeS Beast (USB/Network)
    5 - AVR Compatible (DVBT over network, etc)
    6 - microADSB (USB/Network)
    7 - SBSx via Basestation (localhost:30006)
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  3. #3
    Passenger
    Join Date
    Mar 2013
    Location
    Oslo, Norway
    Posts
    5
    Quote Originally Posted by Oblivian View Post
    In theory.

    I would need to update mine and test to confirm. But prior during setup it was an option
    Thank for answering. Let me know when you tested

    The latest micro adsb usb is V3.1.

  4. #4
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,743
    I don't have one that new. I have original generation.

    However it doesn't look good thus far.. (but could be my settings)

    Code:
    2016-08-01 21:09:47 | [main][i]FR24 Feeder/Decoder
    2016-08-01 21:09:47 | [main][i]Version: 1.0.18-7/generic
    2016-08-01 21:09:47 | [main][i]Built on Jul 11 2016 09:24:44 (HEAD-91e2757.git/Linux/armv7l)
    2016-08-01 21:09:47 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-08-01 21:09:47 | [main][i]http://flightradar24.com
    2016-08-01 21:09:47 | [main][i]DNS mode: LIBC
    2016-08-01 21:09:47 | [main][i]Automatic updates are DISABLED
    2016-08-01 21:09:47 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-08-01 21:09:47 | [main][i]Reader thread started
    2016-08-01 21:09:47 | [reader][i]Initializing reader
    2016-08-01 21:09:47 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@115200)
    2016-08-01 21:09:47 | [reader][e]Could not connect to avr:///dev/ttyUSB0@115200
    2016-08-01 21:09:47 | [mlat][i]Waiting for MLAT configuration
    2016-08-01 21:09:47 | [master][i]Starting processing thread
    2016-08-01 21:09:47 | [mlat][e]Receiver not compatible with MLAT, timestamps in wrong format![main][i]MLAT data feed started
    2016-08-01 21:09:48 | [time][i]Synchronizing time via NTP
    2016-08-01 21:09:51 | [time][i]Time synchronized correctly, offset +0.0001 seconds
    2016-08-01 21:09:51 | [main][i]Feed Network client started
    2016-08-01 21:09:51 | [feed][i]Downloading configuration
    2016-08-01 21:09:52 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyUSB0@115200)
    2016-08-01 21:09:52 | [reader][e]Could not connect to avr:///dev/ttyUSB0@115200
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  5. #5
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,743
    Might also be because I forgot to plug it in... lets try that again
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  6. #6
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,743
    Thats a bit more like it. Confirmed with tracked output too of something my other receiver had.

    Needed to give it a bit of a tickle, it didn't like the default device so needed to do a LSUSB -t and work out the ACM modem was the thing to attach to

    so device in config set as /dev/ttyACM0 (case sensitive)

    Code:
    pi@raspberrypi /dev $ sudo fr24feed start
    2016-08-01 21:32:15 | [main][i]FR24 Feeder/Decoder
    2016-08-01 21:32:15 | [main][i]Version: 1.0.18-7/generic
    2016-08-01 21:32:15 | [main][i]Built on Jul 11 2016 09:24:44 (HEAD-91e2757.git/Linux/armv7l)
    2016-08-01 21:32:15 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-08-01 21:32:15 | [main][i]http://flightradar24.com
    2016-08-01 21:32:15 | [main][i]DNS mode: LIBC
    2016-08-01 21:32:15 | [main][i]Automatic updates are DISABLED
    2016-08-01 21:32:15 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-08-01 21:32:15 | [main][i]Reader thread started
    2016-08-01 21:32:15 | [reader][i]Initializing reader
    2016-08-01 21:32:15 | [main][i]MLAT data feed started
    2016-08-01 21:32:15 | [reader][i]Connecting to microADSB receiver via (avr:///dev/ttyACM0@115200)
    2016-08-01 21:32:15 | [master][i]Starting processing thread
    2016-08-01 21:32:15 | [mlat][i]Waiting for MLAT configuration
    2016-08-01 21:32:15 | [mlat][e]Receiver not compatible with MLAT, timestamps in wrong format![reader][i]Connected to the receiver, configuring
    2016-08-01 21:32:15 | [reader][i]Configured, processing messages
    2016-08-01 21:32:16 | [time][i]Synchronizing time via NTP
    2016-08-01 21:32:19 | [time][i]Time synchronized correctly, offset +0.0002 seconds
    2016-08-01 21:32:19 | [main][i]Feed Network client started
    2016-08-01 21:32:19 | [feed][i]Downloading configuration
    2016-08-01 21:32:20 | [feed][c]Interval: 5s
    2016-08-01 21:32:20 | [feed][c]GND: YES
    2016-08-01 21:32:20 | [feed][c]NonADSB: YES
    2016-08-01 21:32:20 | [feed][c]Timestamps: optional
    2016-08-01 21:32:20 | [feed][c]Max range AIR: 350.0nm
    2016-08-01 21:32:20 | [feed][c]Max range GND: 100.0nm
    2016-08-01 21:32:20 | [stats][i]Stats thread started
    2016-08-01 21:32:20 | [feed][i]defined 5 servers
    2016-08-01 21:32:20 | [feed][n]NZCH26@83.140.21.87:8099/UDP
    2016-08-01 21:32:20 | [feed][n]connecting
    2016-08-01 21:32:21 | [feed][n]connected via UDP (fd 9)
    2016-08-01 21:32:21 | [feed][n]working
    2016-08-01 21:32:51 | [feed][n]ping 1
    2016-08-01 21:32:52 | [feed][n]syncing stream result: 1
    2016-08-01 21:32:58 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:05 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:10 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:16 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:22 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:28 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:34 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:40 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:46 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:51 | [feed][i]sent 1,0 AC
    2016-08-01 21:33:58 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:05 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:10 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:16 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:22 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:28 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:33 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:39 | [feed][i]sent 1,0 AC
    2016-08-01 21:34:44 | [feed][i]sent 1,0 AC
    I just realised my primary feeder has ground data turned off from server side. Rude :P
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  7. #7
    Passenger
    Join Date
    Mar 2013
    Location
    Oslo, Norway
    Posts
    5
    Nice! Great to hear that it works.

  8. #8
    Passenger
    Join Date
    Apr 2019
    Posts
    2
    I try to install (on raspian)with a microADSB usb dongle,and during setup I'm asked for com port/device path.How do I enter the com port \device path in the settings?

  9. #9
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    4,743
    Quote Originally Posted by sumec View Post
    I try to install (on raspian)with a microADSB usb dongle,and during setup I'm asked for com port/device path.How do I enter the com port \device path in the settings?
    https://forum.flightradar24.com/thre...ll=1#post85177

    Sent from my EML-L09 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  10. #10
    Passenger
    Join Date
    Apr 2019
    Posts
    2
    Thanks!Workin now(use a USB stick from MicroADSB)The only issue now is MLAT not running but activated in settings
    .Is there a way to check what's wrong?Use raspian image,but have same issue on flightradar image

    i@raspberrypi:~ $ fr24feed-status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2019-04-12 16:53:19.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-ENMS1.
    [ ok ] FR24 Tracked AC: 1.
    [ ok ] Receiver: connected (946 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •