Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Activating Pi24 error?

  1. #1
    Passenger
    Join Date
    Nov 2014
    Posts
    6

    Activating Pi24 error?

    I have configured a Pi24 unit and I have received the following e-mail: Thank you for connecting to Flightradar24! We are now receiving and processing live data from your receiver.

    Running "sudo service fr24feed status" I get:

    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2016-07-22 12:18:02.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-OMDW6.
    [ ok ] FR24 Tracked AC: 1.
    [ ok ] Receiver: connected (6186 MSGS/0 SYNC).
    [ ok ] FR24 MLAT: ok [UDP].
    [ ok ] FR24 MLAT AC seen: 0.

    But on the "Activate new receiver" webpage I get the error that "No devices found". My Pi24 receiver is in the same network as my web browser.

    Checking the "Share statistics" webpage for the UAE there are only 14 users and my receiver is not listed (even it could be placed last).

    The latest log file reads:

    2016-07-22 12:22:53 | [feed][n]ping 6
    2016-07-22 12:22:54 | [feed][n]syncing stream result: 1
    2016-07-22 12:23:01 | [mlat][i]No ADS-B time reference available (0/0)
    2016-07-22 12:23:08 | [mlat][i]Pinging the server
    2016-07-22 12:23:08 | [mlat][i]Stats 68/0
    2016-07-22 12:23:11 | [mlat][i]No ADS-B time reference available (0/0)

    Any advice? BTW how to I clear the "No ADS-B time reference available" error?

    Thanks in advance.

  2. #2
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,836
    1) Yesterday I burned Pi24 img on my microSD card, and inserted into RPi and powered up. After finishing configuration, when I checked /var/log/fr24feed.log file, I found "No ADS-B time reference available" error. I did not do anything. After few hours when I checked the log file again, this error has disappeared.

    2) Type the following in your browser to see your settings. The first entry on top left is your sharing key. If it is blank, enter the sharing key provided to you by Flightradar24, and click Save and then Restart buttons at bottom right of the page.

    http://xxx.xxx.xx.xx:8754/settings.html (replace xxx.xxx.xx.xx by your RPi's IP address on your local network). See screenshot below:

    Pi24 Settings.png

    You can configure your feed either by above page in browser, or by command line below:
    Code:
    #If sharing key is not already entered & saved
    sudo fr24feed --reconfigure --fr24key=YOUR SHARING KEY
    #Replace "YOUR SHARING KEY" by the actual sharing key provided to you by Flightradar24.
    
    #If sharing key is already entered & saved, but want to change configuration
    sudo fr24feed --reconfigure
    
    #Complete the configuration wizard. 
    #When asked for additioal arguments for dump1090, enter following: 
    
    --net --net-http-port 8080
    
    #After completing configuration, restart the feed
    
    sudo service fr24feed restart
    Last edited by abcd567; 2016-07-22 at 14:28.

  3. #3
    Passenger
    Join Date
    Nov 2014
    Posts
    6
    Thanks for the advice and I have basically just copied out as in your snapshot:

    1. Receiver was AVT (TCP) changed to DVBT Stick
    2. Process arguments added: --net --net-http-port 8080
    3. RAW data (30002/30334) was "No" changed to "Yes"
    4. Decoded data (30003) was "No" changed to "Yes"

    pi24.jpg

  4. #4
    Passenger
    Join Date
    Nov 2014
    Posts
    6
    So now when I checked the status there is an error:

    $ sudo service fr24feed status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp:.
    [FAIL] FR24 Link: unknown ... failed!
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    So I ran the reconfigure command via command line. Everything went well until the end where there is this submitting form error now:

    ...
    ...
    Submitting form data...ERROR

    Invalid email provided!

    Would you like to try again?

    Saving settings to /etc/fr24feed.ini...OK
    Settings saved, please run "sudo service fr24feed restart" to use new configuration.

    $ sudo service fr24feed restart
    [ ok ] Stopping FR24 feeder: fr24feed.
    [ ok ] Starting FR24 feeder: fr24feed.

    $ sudo service fr24feed status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp:.
    [FAIL] FR24 Link: unknown ... failed!
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    Any advice?

  5. #5
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,836
    Quote Originally Posted by nickkraal View Post
    So I ran the reconfigure command via command line. Everything went well until the end where there is this submitting form error now:
    ...
    ...
    Submitting form data...ERROR
    Invalid email provided!
    Would you like to try again?
    ....
    ....
    Yes, I checked configuration by command line "sudo fr24feed --reconfigure", and it gives same problem of "invalid email provided. Would you like to try again?", but log file is showing everything is ok. Checked my stats page https://www.flightradar24.com/accoun...stats/?id=xxxx, and stats are updating.

    TRY:
    Code:
    sudo fr24feed --signup

  6. #6
    Passenger
    Join Date
    Nov 2014
    Posts
    6
    Thanks for this advice. I actually reinstalled fr24feed and this this is why you probably saw that the stats were updating.

    I ran the "sudo fr24feed --signup" command and chose "No" for "Would you like to use autoconfig (*yes*/no)" and enter the manual configuration settings in. Checking the fr24feed status:

    $ sudo service fr24feed status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2016-07-22 16:50:55.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-OMDW6.
    [ ok ] FR24 Tracked AC:.
    [FAIL] Receiver: down ... failed!
    [FAIL] FR24 MLAT: not running ... failed!

    https://www.flightradar24.com/accoun...stats/?id=xxxx showed an "offline" status.

    So I ran the "sudo fr24feed --signup" command again and chose "Yes" for "Would you like to use autoconfig (*yes*/no)". Checking the fr24feed status now shows:

    $ sudo service fr24feed status
    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2016-07-22 16:56:18.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-OMDW6.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (2 MSGS/0 SYNC).
    [ ok ] FR24 MLAT: ok [UDP].
    [ ok ] FR24 MLAT AC seen: 0.

    https://www.flightradar24.com/accoun...stats/?id=xxxx showed an "online" status.

    Below is the seemingly working configuration:

    fr2345.jpg

  7. #7
    Passenger
    Join Date
    Mar 2014
    Posts
    1
    Having the same problem as you, not being able to activate raspberry pi. If I check my status it says online and it's been collecting and send data just fine.

  8. #8
    Flight attendant Wolli's Avatar
    Join Date
    Dec 2014
    Location
    Germany
    Posts
    82
    I have a problem nearly similar to the above stated one.

    Preliminary remarks:
    Since nearly 2 years I am feeding FR24 als follows: DVB-T-Stick, Windows Notebook, dump1090 (Malcolm Robb), FR24-feeding-software. Running fine.
    Now I bought a RPi 3 Model B to feed FR24 from now on from the Rpi and no more from the Notebook.

    Although I am a RPi-Newbie and also not a linux/raspbian specialist, all setups obviously worked fine, as one can see:
    1) FR24-feeder-setup via SSH...
    -> $ sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    ...finally displayed these 3 lines:
    Saving settings to /etc/fr24feed.ini...OK
    Settings saved, please run "sudo service fr24feed restart" to use new configuration.
    Installation and configuration completed!

    2) Then Feeder-Restart:
    $ sudo service fr24feed restart

    3) Feeder Status...
    $ sudo service fr24feed status
    ...displays:
    * fr24feed.service - LSB: Flightradar24 Decoder & Feeder
    Loaded: loaded (/etc/init.d/fr24feed)
    Active: active (running) since Fr 2016-10-28 12:33:02 CEST; 2h 59min ago
    Process: 555 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/fr24feed.service
    |-686 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --...
    `-707 /usr/lib/fr24/dump1090 --net --fix --raw --mlat

    Okt 28 12:33:02 raspberrypi fr24feed[555]: Starting FR24 feeder: fr24feed.
    Okt 28 12:33:02 raspberrypi systemd[1]: Started LSB: Flightradar24 Decoder &....
    Hint: Some lines were ellipsized, use -l to show in full.

    ...which also seems to be normal and OK.

    BUT:
    $ tail -f /var/log/fr24feed.log
    ...SHOWS this loop:
    2016-10-28 15:36:08 | [mlat][i]Terminating connection
    2016-10-28 15:36:09 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-10-28 15:36:09 | [mlat][i]Registering MLAT station
    2016-10-28 15:36:09 | [mlat][i]Registering MLAT station: SUCCESS
    2016-10-28 15:36:13 | [feed][i]sent 0,5 AC
    2016-10-28 15:36:19 | [feed][i]sent 0,3 AC
    2016-10-28 15:36:24 | [feed][i]sent 0,6 AC
    2016-10-28 15:36:25 | [mlat][i]No ADS-B time reference available (0/2)
    2016-10-28 15:36:29 | [feed][i]sent 0,5 AC
    2016-10-28 15:36:34 | [feed][i]sent 0,4 AC
    2016-10-28 15:36:39 | [feed][i]sent 0,3 AC
    2016-10-28 15:36:41 | [mlat][i]No ADS-B time reference available (0/1)
    2016-10-28 15:36:41 | [mlat][i]Pinging the server
    2016-10-28 15:36:41 | [mlat][w]Could not ping MLAT server, result=-1000, number of errors=1
    2016-10-28 15:36:44 | [feed][i]sent 0,4 AC
    2016-10-28 15:36:49 | [feed][i]sent 0,3 AC
    2016-10-28 15:36:54 | [feed][i]sent 0,3 AC
    2016-10-28 15:36:57 | [mlat][i]No ADS-B time reference available (0/1)
    2016-10-28 15:37:00 | [feed][i]sent 0,4 AC
    2016-10-28 15:37:05 | [feed][i]sent 0,2 AC
    2016-10-28 15:37:06 | [feed][i]filtering out 5 overlapping AC (saving bandwidth)
    2016-10-28 15:37:10 | [feed][i]sent 6,2 AC
    2016-10-28 15:37:13 | [mlat][i]No ADS-B time reference available (0/0)
    2016-10-28 15:37:13 | [mlat][i]Pinging the server
    2016-10-28 15:37:14 | [mlat][w]Could not ping MLAT server, result=-1000, number of errors=2
    2016-10-28 15:37:14 | [mlat][i]Terminating connection
    2016-10-28 15:37:15 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    Note that the first two lines are identical to the last two lines. This sequence ist repeating and repeating and...

    A)
    Curious (in my Newbie eyes) seems: "Could not ping MLAT server".
    With SSH under user 'pi' I can ping...
    $ sudo ping mlat-1.fr24.com
    ...which answers:
    PING wro.fr24.com (83.140.21.66) 56(84) bytes of data.
    64 bytes from 83.140.21.66: icmp_seq=1 ttl=53 time=70.3 ms
    64 bytes from 83.140.21.66: icmp_seq=2 ttl=53 time=71.3 ms
    64 bytes from 83.140.21.66: icmp_seq=3 ttl=53 time=69.9 ms
    So obviously not a firewall problem.

    B)
    The message "No ADS-B time reference available" seems also strange, as every 5-10 minutes (or so) the following lines appear in the file fr24feed.log:
    2016-10-28 15:53:50 | [time][i]Synchronizing time via NTP
    2016-10-28 15:53:50 | [mlat][i]No ADS-B time reference available (0/2)
    2016-10-28 15:53:51 | [feed][i]sent 3,6 AC
    2016-10-28 15:53:54 | [time][i]Time synchronized correctly, offset +0.0004 seconds, drift -0.0000 seconds/minute
    So at least also NTP seems to work fine.

    Here my feeder settings:
    Feeder-Settings.jpg

    Any ideas? Thank you very much in advance. -Wolli-

  9. #9
    Purser
    Join Date
    Apr 2015
    Location
    Switzerland
    Posts
    129
    i sugest you to change: receiver > avr/tcp and in host/ip > localhost:30002 save settings and restart, share your feedback.
    cheers

    Sent from my SM-N910F using Tapatalk

  10. #10
    Flight attendant Wolli's Avatar
    Join Date
    Dec 2014
    Location
    Germany
    Posts
    82
    Hi mrcarlos, and thank you very much for your reply.

    I just tried your suggestions:

    Attempt #1:
    receiver > avr/tcp and host/ip > localhost:30002 - then stop and start
    The feeder then produced error messages:
    2016-10-30 12:02:49 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://localhost:30002)
    2016-10-30 12:02:49 | [reader][e]Could not connect to avr-tcp://localhost:30002


    Attempt #2:
    Additionally to the changes performed in attempt #1 I changed the field "RAW data (30002/30334)" to "YES" - then stop and start. Just to see what happens.
    Result: The feeder produced the same error messages (of course new timestamps):
    2016-10-30 12:07:00 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://localhost:30002)
    2016-10-30 12:07:00 | [reader][e]Could not connect to avr-tcp://localhost:30002


    So now I performed a "fallback" to the "original" configuration (receiver: DVBT-stick - Host/IP: -empty-) - then stop and start.

    BTW: When I switch MLAT off in the config (then stop and start), the feeder is running fine. So I think I don't have a basic problem here on my RPi.

    Kind regards, -Wolli-

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •