Results 1 to 8 of 8

Thread: Feeding to FR24 and ALSO to Virtualradar?

  1. #1
    Passenger
    Join Date
    Apr 2010
    Posts
    7

    Feeding to FR24 and ALSO to Virtualradar?

    Hi All,

    I have just connected a USB dongle receiver to a Raspberry Pi 3, downloaded/installed the FR24 image and started feeding data to FR24. No problems here, all is well - and I even had the "Business" upgrade. Sweet.

    Before this, I used to have the USB stick receiver directly connected to my (Windows) computer and was running RTL1090 + VirtualRadar and would see all the local traffic near my home, as received by my own Rx. This went on for well over a year, until I got the Raspberry and started feeding to FR24 a few days ago.

    So here is the question (I did search, promise): Is it possible to continue feeding FR24 with the USB stick Rx connected to the Raspberry and at the same time see my own traffic (i.e, as received by my Rx) on my computer using VirtualRadar?

    When the Rx was directly connected to the computer via USB I would first run RTL1090 and then start VirtualRadar, then click in the "127.0.0.1" link on that program, which opened a web browser with map. Am I correct in my assumption that it is possible to point Virtualradar not to 127.0.0.1, but rather to the PI's network address and fetch the data from there, while the Raspberry continues to feed to FR24? if so, can someone please point me to the right direction? I did try a few different setting in VirtuaRadar's Tools > Options page, but I don't really know what should be set.

    As it is, VirtualRadar only shows the map (no aircraft) while the Raspberry is happily sending away data to FR24.

    Any info would be greatly appreciated.

    TIA,
    Bruno
    Last edited by brunobl; 2019-07-26 at 18:08. Reason: typos corrected.
    T-SSBL3

  2. #2
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,749
    STEP-1: In Virtual Radar Server:

    IP address:
    Instead of 127.0.0.1, use IP-of-Pi
    (Example: my IP-of-Pi is 192.168.0.21)

    Port number: 30005
    Format: AVR or Beast

    Please see screenshots below
    VRS Setting for RPi - 1.png VRS Setting for RPi - 2.png


    STEP-2: In FR24 settings page at IP-of-Pi:8754/settings.html:
    This step is applicable to PI24 image only.
    For Raspbian image or Piaware image, do NOT do this step.


    In the field "Process arguments", add --net, click Save button, then restart button. Both these buttons are at bottom right corner of settings page.

    Please see screenshot below
    Pi24 Settings-2.png
    Last edited by abcd567; 2019-07-27 at 00:00.

  3. #3
    Captain
    Join Date
    Apr 2018
    Posts
    744
    Just in case you like the more map options without necessarily starting VRS:

    https://github.com/wiedehopf/adsb-wi...for-dump1090fa

    (this setup also has port 30005 open for use with VRS)

  4. #4
    Passenger
    Join Date
    Apr 2010
    Posts
    7
    Many thanks abcd567 and wiedehopf.
    Got best of both worlds now: feeding FR24 and seeing my own received acft.
    ...You guys rock!
    T-SSBL3

  5. #5
    First officer LN-MOW's Avatar
    Join Date
    Mar 2010
    Location
    Coal Mountain GA
    Posts
    278
    --- pls delete - problem solved
    Last edited by LN-MOW; 2019-07-26 at 22:59. Reason: Never mind ..

  6. #6
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,749
    Quote Originally Posted by LN-MOW View Post
    Hmm .. followed the steps above and I'm getting ....

    3‹�pM)�4
    ȿ –�3‹‘€ˆ“XE6Y}S[12‹\]8[2‹^’ˆ0\3‹œ*Y�‡XgˆŸ‰2k3‹;:q�5XEby7p \2‹ǯ1 ��/™3‹ǧ)�™‰
    p”˜M3‹ˆec�‡-X\�2‹5Rˆpg2‹;`I˜8š\2‹FS]s3‹ z �™ 8d"wX2‹
    GŸn]54<2‹ \3{ � RI{2‹ | { � RI{3‹ ” *�$™ PR˜2‹ œ�{ � RI{2‹ { � RI{2‹ | � RI{2‹ € � RI{2‹ €| �
    Seems in your browser you have typed following address:

    IP-of-Pi:30005

  7. #7
    First officer LN-MOW's Avatar
    Join Date
    Mar 2010
    Location
    Coal Mountain GA
    Posts
    278
    Quote Originally Posted by abcd567 View Post
    Seems in your browser you have typed following address:

    IP-of-Pi:30005
    Yeah .. I first thought that was the correct address.

  8. #8
    Passenger
    Join Date
    Aug 2019
    Posts
    31
    nice, it worked for me, i want to check if i can add all my receiver at the same time

    edit:

    there is an option to add combined receivers so it works, great tutorial :P
    Last edited by AlejandroM; 2019-08-26 at 15:17.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •