Page 8 of 12 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 120

Thread: How to Install dump1090-mutability_1.15~dev on RPi

  1. #71
    Flight attendant
    Join Date
    May 2014
    Posts
    83
    Quote Originally Posted by abcd567 View Post
    I installed it by wiedehopf's method (which he gave in above post.)


    Before wiedehopf created his method, I used to install graphs by installing "web portal" of JProchazka's "adsb receiver project".

    However as wiedehopf's "graphs only" are simpler than J Prochazka's full "web portal", I have now started using wiedehopf's method.

    The installation of wiedehopf graphs is done simply by issueing following command:
    (Scroll right to see full command. The command is very long)
    Code:
    sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/graphs1090/master/install.sh)"
    After installation, wait for 15 minutes for enough data to be collected by the process (rrdtools+collectd) to create the graphs.

    See the graphs in browser at:
    IP-of-Pi/graphs1090/
    Hi.

    I like to install wiedehopf's method
    how can uninstall Prochazka's full "web portal"
    is there a way to install after that the "System Information" ?

    sysinfo.jpg

  2. #72
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,837
    JUNE 22, 2019:
    ADDED PRE-BUILT PACKAGE INSTALL TO FIRST POST




    METHOD-1:
    Install pre-built package of dump1090-mutability_1.15~dev on RPi/Raspbian


    Code:
    sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/dump1090/master/install_dump1090_mut_1.15.sh)"

    METHOD-2:
    Built & install dump1090-mutability_1.15~dev from source code

    STEP (1): UPDATE THE OPERATING SYSTEM & INSTALL PRE REQUISIT PACKAGES (needed to build, and needed to fulfill dependencies)
    ......................
    ......................

  3. #73
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,037
    abcd - think I should de-sticky this one now that it is mostly included in the https://forum.flightradar24.com/thre...24-Data-Feeder ?
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  4. #74
    Captain
    Join Date
    Apr 2018
    Posts
    850
    There seems to be a package now for Buster, so no need to compile it.

    You can install it like this:

    sudo apt install dump1090-mutability


    Otherwise you can always use dump1090-fa: https://github.com/wiedehopf/adsb-wi...for-dump1090fa

  5. #75
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,037
    Quote Originally Posted by ramimz View Post
    Hi.
    i'm getting an error after step 3 and 4

    Code:
    make[2]: *** [Makefile:54: dump1090] Error 1
    make[2]: Leaving directory '/home/pi/build-dump-mut/dump1090'
    dh_auto_build: make -j1 "EXTRACFLAGS=-DHTMLPATH=\\\"/usr/share/dump1090-mutability/html\\\" -DMODES_DUMP1090_VARIANT=\\\"dump1090-mutability\\\"" returned exit code 2
    make[1]: *** [debian/rules:21: override_dh_auto_build] Error 2
    make[1]: Leaving directory '/home/pi/build-dump-mut/dump1090'
    make: *** [debian/rules:30: build] Error 2
    dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
    
    pi@raspberrypi:~/build-dump-mut/dump1090 $ cd ~/build-dump-mut
    pi@raspberrypi:~/build-dump-mut $ sudo dpkg -i dump1090-mutability_1.15~dev_*.deb
    dpkg: error: cannot access archive 'dump1090-mutability_1.15~dev_*.deb': No such file or directory
    pi@raspberrypi:~/build-dump-mut $
    i'm with the new release - Linux 10 (buster) 7/10/19

    Code:
    pi@raspberrypi:~/build-dump-mut $ cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="10"
    VERSION="10 (buster)"
    VERSION_CODENAME=buster
    ID=raspbian
    ID_LIKE=debian
    HOME_URL="http://www.raspbian.org/"
    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
    pi@raspberrypi:~/build-dump-mut $
    You can't build Dump1090 on buster. But need the full package.

    or wiedehopfs fa-dump1090 installer

    /edit - snap!
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  6. #76
    Flight attendant
    Join Date
    May 2014
    Posts
    83
    Cool...... so just to ignore step 3 ?

  7. #77
    Super Moderator
    Join Date
    May 2011
    Location
    T-NZCH1, PP:PH New Zealand
    Posts
    5,037
    Quote Originally Posted by ramimz View Post
    Cool...... so just to ignore step 3 ?
    Essentially.

    But note there was 2 methods - you took the long one 1st one would have worked with it pre-compiled

    I've made the note to make NOT BUSTER clear. But the 1st option was always the preferred (which is why abcd edited it in June)
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

  8. #78
    Captain
    Join Date
    Apr 2018
    Posts
    850
    And replace step 4 with the install command mentioned.

    Try if it works, i'm not 100 % sure.
    If the install works, then you don't need steps 3 and 4.

    Anyway if you have anymore trouble i would just recommend the bundle i linked.
    It has both the old style dump1090 map and the newer dump1090-fa style map.

    Also it will automatically adjust the gain.

  9. #79
    Flight attendant
    Join Date
    May 2014
    Posts
    83
    Thanks Oblivian & wiedehopf

    so that's what i did on method-2 by abcd567

    step 1....as is
    step 2....as is
    step 3....pass
    step 4....replaced with the command "sudo apt install dump1090-mutability" by wiedehopf
    step 5....as is
    step 6....as is
    step 7....I normally pass that one
    step 8....as is
    step 9....I normally pass that one
    step 10...as is

    so far it's working great

  10. #80
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,837
    [S O L V E D ]
    Workaround for Raspbian Buster


    The problem is caused because Buster's Apt installs latest versions of packages librtlsdr-dev and librtlsdr0.
    The dump1090-mutability code has not been upgraded yet to use these latest versions and fails.

    The solution is that in First Post's STEP (1), remove from 2nd "apt-get install" line the package "librtlsdr-dev", and instead download and install older version from Debian package repository, as shown in (2) below.

    If you already have run the STEP (1) of First Post, then do (1) below to purge newly installed packages from Buster repository.

    (1) Purge librtlsdr-dev (0.6-1+rpt1) and librtlsdr0 (0.6-1+rpt1) installed from Buster's apt during execution of STEP (1) of First Post

    Code:
    sudo apt purge librtlsdr-dev
    sudo apt purge librtlsdr0
    (2) Download and install older versions of librtlsdr0 (0.5.3-11) and librtlsdr-dev (0.5.3-11) from Debian Package repository

    Code:
    wget -O ~/librtlsdr0_0.5.3-11+b2_armhf.deb "http://ftp.us.debian.org/debian/pool/main/r/rtl-sdr/librtlsdr0_0.5.3-11+b2_armhf.deb"
    sudo dpkg -i librtlsdr0_0.5.3-11+b2_armhf.deb
    
    wget -O ~/librtlsdr-dev_0.5.3-11+b2_armhf.deb "http://ftp.us.debian.org/debian/pool/main/r/rtl-sdr/librtlsdr-dev_0.5.3-11+b2_armhf.deb"
    sudo dpkg -i librtlsdr-dev_0.5.3-11+b2_armhf.deb
    (3) Build & Install dump1090-mutability v1.15~dev package

    Code:
    ~/build-dump-mut/dump1090
    sudo dpkg-buildpackage -b
    
    cd ../
    sudo dpkg -i dump1090-mutability_1.15~dev_armhf.deb
    
    sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
    
    sudo dpkg-reconfigure dump1090-mutability
    
    sudo reboot
    Last edited by abcd567; 2019-07-17 at 15:15.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •