Page 4 of 12 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 112

Thread: How to Install dump1090-mutability_1.15~dev on RPi

  1. #31
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    If you are using Raspbian STRETCH, you will get this notice on map:
    Problem fetching data from dump1090.
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date
    • The solution is to add a file "rtl-sdr.rules" with proper entries in folder /etc/udev/rules.d

    • Blacklisting is NOT required.


    Use this simple one-step solution:
    Code:
    sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
    
    sudo reboot
    NOTE:
    I have worked out the bove simplified solution based on solutions posted by jaxxtheone, Randstad, and thehague.
    Last edited by abcd567; 2017-09-01 at 22:10.

  2. #32
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    [SOLVED] BUGS IN RASPBIAN STRETCH [SOLVED]

    (1) dump1090-mutability fails to open DVB-T. Gives following error:
    Code:
    Problem fetching data from dump1090.
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date.
    Reason: Missing rtl-sdr.rules.


    Workaround:
    Code:
    sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
    
    sudo reboot
    .
    .
    .

    (2) FlightRadar24's fr24feed fails to install by bash script.

    Reason: Missing package "dirmngr".


    Workaround:
    Code:
    sudo apt-get update
    sudo apt-get install dirmngr
    
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
    #Enter details when prompted.
    .
    .
    .

    (3) RadarBox24's rbfeeder fails to install by bash script
    Code:
    sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"
    .........
    W: GPG error: http://apt.rb24.com jessie Release: The following signatures were invalid: A7E7D5E3786CA2212A3A5F4769D62C99357DF51A
    W: The repository 'http://apt.rb24.com jessie Release' is not signed.
    .........
    WARNING: The following packages cannot be authenticated!
      rbfeeder
    .....
    Failed to start rbfeeder.service: Unit rbfeeder.service not found.

    Workaround:
    Code:
    sudo apt-get update
    sudo apt-get install rbfeeder
    Ignore following warning during install and say y
    Code:
    WARNING: The following packages cannot be authenticated!
      rbfeeder
    Install these packages without verification? [y/N]
    Last edited by abcd567; 2017-09-21 at 21:23.

  3. #33
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    Currently dump1090-mutability uses Open Steert Map.

    If someone wants dump1090-mutability v1.15~dev which has Google map, he has to install an older version which was released earlier than the switch to Open Street map. Here is how to do this:

    Step-By-Step Method for Installing June 8, 2016 version of dump1090-mutability v1.15~dev (The last version which had Google Map).

    STEP-1: Install build tools and dependencies
    Code:
    $ sudo apt-get update
    $ sudo apt-get install librtlsdr-dev libusb-1.0-0-dev pkg-config debhelper
    $ sudo apt-get install lighttpd 
    $ sudo apt-get install git

    STEP-2: Clone source code from GitHub
    Code:
    $ git clone https://github.com/mutability/dump1090.git
    $ cd dump1090

    STEP-3: Reset git to the last version which had Google Map.
    Code:
    $ git reset --hard dfe3d7af12
    HEAD is now at dfe3d7a Merge pull request #126 from rxseger/osx

    STEP-4: Build .deb package from source code
    Code:
    $ sudo dpkg-buildpackage -b

    STEP-5: Install the .deb package
    Code:
    $ cd ../
    $ sudo dpkg --install dump1090-mutability_1.15~dev_armhf.deb
    $ sudo lighty-enable-mod dump1090
    $ sudo /etc/init.d/lighttpd force-reload

    STEP-6: Configure settings
    Code:
    $ sudo dpkg-reconfigure dump1090-mutability
    $ sudo systemctl restart dump1090-mutability
    $ sudo reboot

    STEP-7: Enjoy the Google Map
    dump1090-mutability-GoogleMap-Commit 8 June 2016.png

  4. #34
    Passenger
    Join Date
    Aug 2017
    Posts
    7
    Hello

    I getting this error message after i followed all steps described in post #1 [ i'm running : Raspbian GNU/Linux 9 (stretch) ]

    Problem fetching data from dump1090.
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    The displayed map data will be out of date.
    The following instructions did not fix it, i'm still getting the message when browsing : ip/dump1090/gmap.html

    Code:
    sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
    sudo /etc/init.d/dump1090-mutability restart
    sudo reboot
    I'm newbie,
    dump1090-fa is NOT installed so far, as post#1 does not mention to do so.
    Should i have dump1090-fa installed or dump1090-mutability is the only one needed ?

    Code:
    apt-cache policy dump1090-fa
    dump1090-fa:
    Installed: (none)
    Candidate: 3.5.3
    Version table:
    3.5.3 500
    500 http://flightaware.com/adsb/piaware/files/packages jessie/piaware armhf Packages
    Code:
    apt-cache policy dump1090-mutability
    dump1090-mutability:
    Installed: 1.15~dev
    Candidate: 1.15~dev
    Version table:
    *** 1.15~dev 100
    100 /var/lib/dpkg/status
    Code:
    apt-cache policy piaware
    piaware:
    Installed: 3.5.3
    Candidate: 3.5.3
    Version table:
    *** 3.5.3 500
    500 http://flightaware.com/adsb/piaware/files/packages jessie/piaware armhf Packages
    100 /var/lib/dpkg/status
    Would you please help me ?
    Last edited by lcn; 2018-03-01 at 09:29.

  5. #35
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    First of all I apologize for late reply. I missed your post, and just now noticed it.

    Quote Originally Posted by lcn View Post
    I getting this error message after i followed all steps described in post #1 [ i'm running : Raspbian GNU/Linux 9 (stretch) ]
    Most likely this is a hardware problem. Either the dongle is not plugged into Pi properly and firmly, or is defective. Another possibility is that the dongle is not getting enough current due to bad or undersized 5v DC power adapter.

    1. Unplug the dongle from Pi, then replug the dongle into Pi firmly, reboot, and check again.

    2. Check and tighten antenna cable connection to dongle.

    3. If above does not solve the problem, test your dongle by method given in this thread:
      Is My DVB-T RTL SDR Dongle Healthy?.

      Use OPTION-2, which is much easier as you have dongle plugged into Raspberry Pi

    4. If all above fails, try another larger capacity 5V DC adapter.



    Quote Originally Posted by lcn View Post
    dump1090-fa is NOT installed so far, as post#1 does not mention to do so.
    Should i have dump1090-fa installed or dump1090-mutability is the only one needed ?
    Only one dump1090 is necessary. As you already have dump1090-mutability v1.15~dev installed you dont need dump1090-fa or any other version. Infact installing more than one type of dump1090 causes clash between the dumps, and results in malfunction.
    Last edited by abcd567; 2018-03-16 at 22:20.

  6. #36
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    @jrf

    I could install debhelper on 2018-03-13-raspbian-stretch-lite.img, which I downloaded today.

    pi@raspberrypi:~ $ cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
    .................................................. ...............
    .................................................. ...............


    pi@raspberrypi:~ $ cat /boot/issue.txt
    Raspberry Pi reference 2018-03-13
    .................................................. ...............


    pi@raspberrypi:~ $ apt-cache policy debhelper
    debhelper:
    Installed: (none)
    Candidate: 10.2.5
    .................................................. ...............
    .................................................. ...............


    pi@raspberrypi:~ $ sudo apt-get install debhelper
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    .................................................. ..............
    .................................................. ..............
    Setting up debhelper (10.2.5) ...
    Setting up dh-strip-nondeterminism (0.034-1) ...
    Processing triggers for libc-bin (2.24-11+deb9u3) ...
    pi@raspberrypi:~ $

  7. #37
    Flight attendant
    Join Date
    Feb 2016
    Location
    South Germany
    Posts
    52
    @abcd567
    Thx, installed again (Lite image), installation went through with no error messages. I have no clue why I did not work before. I had the following error that was corrected with the below command and a reboot:
    AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
    Code:
    sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
    I will add the data feeders for FR24 and FA, but first need to figure out what to do to keep my sharing keys for both data feeds the same (replacing the still running "old" RPi).
    JRF: T-EDNY19
    South Germany

  8. #38
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    Quote Originally Posted by jrf View Post
    I will add the data feeders for FR24 and FA, but first need to figure out what to do to keep my sharing keys for both data feeds the same (replacing the still running "old" RPi).
    FlightRadar24:
    Sharing code (fr24key) is in file /etc/fr24feed.ini .
    SSH to OLD Pi, open this file, and copy paste the sharing code to a text file in your Desktop/laptop. Save text file.

    Here is output from my Pi. I have replaced sharing key by "xxxxxxxxxxxxx" for privacy reasons.
    Code:
    pi@raspberrypi:~ $ cat /etc/fr24feed.ini
    
    receiver="beast-tcp"
    host="127.0.0.1:30005"
    fr24key="xxxxxxxxxxxxxxx"
    bs="no"
    raw="no"
    logmode="1"
    windowmode="0"
    mpx="no"
    mlat="yes"
    mlat-without-gps="yes"

    Alternatively you can find the fr24 key on OLD Pi's page <ip-of-OLD-Pi>:8754/settings.html


    FlightAware:
    Go to your Flightaware "My ASDSB" page of OLD Pi while logged-in to Flightaware
    Copy your "Unique Identifier" from there, and paste it in a text file in your Desktop/Laptop. Save text file.
    Here is the detailed method:
    For Begginers - How to Get Back Existing Station Number in A Fresh Install


    Alternatively you can also get your UUID (or feeder id) by SSH to OLD Pi, and giving command sudo piaware-config -show feeder-id
    Copy-paste feeder-id from SSH terminal to a text file on Desktop/Laptop, and save the text file.

    Output from my Pi.
    For privacy reasons, I have replaced actual value by xxxxxx
    Code:
    pi@raspberrypi:~ $ sudo piaware-config -show feeder-id
    
    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

  9. #39
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,770
    Quote Originally Posted by jrf View Post
    1) What I do not understand: I think to remember from a post I read somewhere that "max" and "-10" are basically the same, but the outcome for me is a big difference.
    The setting "max" sets gain to "Maximum Available" setting of the dongle, which is 49.6 dB.
    The setting "-10" does NOT set any gain value. It is a switch. It switches the dongle to AGC (automatic gain control) which theoretically should continuously adjust the gain according to prevailing signal level.


    Quote Originally Posted by jrf View Post
    2) What do the different colors (green, purple) in the plane list in map gmap.html mean?
    I don't know. I never paid any attention to color of Plane Icons.
    May be it is related to altitude of the plane, but I am not sure.

  10. #40
    Flight attendant
    Join Date
    Feb 2016
    Location
    South Germany
    Posts
    52
    Quote Originally Posted by abcd567 View Post
    I don't know. I never paid any attention to color of Plane Icons.
    May be it is related to altitude of the plane, but I am not sure.
    Color is coming from config.js. See:
    Code:
    cd ~
    cd /usr/share/dump1090-mutability/html
    sudo nano config.js
    Code:
    // These settings control the coloring of aircraft by altitude.
    // All color values are given as Hue (0-359) / Saturation (0-100) / Lightness (0-100)
    ColorByAlt = {
            // HSL for planes with unknown altitude:
            unknown : { h: 0,   s: 0,   l: 40 },
    
            // HSL for planes that are on the ground:
            ground  : { h: 120, s: 100, l: 30 },
    
            air : {
                    // These define altitude-to-hue mappings
                    // at particular altitudes; the hue
                    // for intermediate altitudes that lie
                    // between the provided altitudes is linearly
                    // interpolated.
                    //
                    // Mappings must be provided in increasing
                    // order of altitude.
                    //
                    // Altitudes below the first entry use the
                    // hue of the first entry; altitudes above
                    // the last entry use the hue of the last
                    // entry.
                    h: [ { alt: 2000,  val: 20 },    // orange
                         { alt: 10000, val: 140 },   // light green
                         { alt: 40000, val: 300 } ], // magenta
                    s: 85,
                    l: 50,
            },
    
            // Changes added to the color of the currently selected plane
            selected : { h: 0, s: -10, l: +20 },
    
            // Changes added to the color of planes that have stale position info
            stale :    { h: 0, s: -10, l: +30 },
    
            // Changes added to the color of planes that have positions from mlat
            mlat :     { h: 0, s: -10, l: -10 }
    };

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •