Page 3 of 19 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 188

Thread: How to Install dump1090-mutability_1.15~dev on RPi

  1. #21
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,391
    Quote Originally Posted by Sam26K View Post
    Hi abcd567,

    Thanks for the follow up reply. Make a long story short, I built up the RPi using the 'Noobs' image and went from there, starting with installing FR24feed and 'remote desktop' for remote control.

    I have no idea why so many instances are showing up. Is there a way to 'wild card' remove all the references and re-install? I just don't want to corrupt RPi to the point that the remote desktop control doesn't work anymore.

    TIA .
    The best way to achieve what you want is to format microSD card, and freshh install in following order:

    1) OS - I will recommend Jessie Lite. For ADSB, it is better than Noobs.

    You can directly SSH from your computer on first boot and dont need to connect a monitor, keyboard & mouse to your RPi.

    Note:
    To SSH from Windows computer, you have to install on Windows computer a SSH client like PuTTy (free of cost)

    To SSH from Mac or Linux computer, use its terminal and type ssh pi@xxx.xxx.xx.xx where xxx.xxx.xx.xx is IP address of your RPi.


    2) Dump1090-mutability v1.15~dev (omit dump & librtlsdr removal/purging steps as you have not yet installed these, either directly, or indirectly when you install data feeders of FA & FR24).

    3) Piaware data feeder add-on, WITHOUT step 1 which installs FA copy of dump1090. Start from step 2 on this page:
    http://flightaware.com/adsb/piaware/install

    4) FR24 data feeder using bash script on this page:
    https://www.flightradar24.com/raspberry-pi

    The trick is that when you install the dump1090-mutability BEFORE installing data feeders, the subsequent installs of data feeders find a working dump1090 and do not install unnecessary copies of their dupms.
    Last edited by abcd567; 2016-07-25 at 16:10.

  2. #22
    Passenger
    Join Date
    Mar 2016
    Posts
    15
    any idea

    ~/install-dump/dump1090 $ sudo dpkg-buildpackage -b
    dpkg-buildpackage: source package dump1090-mutability
    dpkg-buildpackage: source version 1.15~dev
    dpkg-buildpackage: source changed by Oliver Jowett <oliver@mutability.co.uk>
    dpkg-buildpackage: host architecture armhf
    dpkg-source --before-build dump1090
    dpkg-checkbuilddeps: Unmet build dependencies: librtlsdr-dev
    dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
    dpkg-buildpackage: warning: (Use -d flag to override.)

  3. #23
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,391
    @nick223
    dpkg-checkbuilddeps: Unmet build dependencies: librtlsdr-dev

    When you were in Step 3, did the command below execute successfully? Repeat this command and carefully watch the output.
    Code:
    sudo apt-get install -y librtlsdr-dev

  4. #24
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,391
    Quote Originally Posted by nick223 View Post
    I'm using wheezy is that the issue?
    Wheezy should not be an issue. If you have updated wheezy by running the command sudo apt-get update, it should be ok on wheezy.

    Possibly librtlsdr-dev did not get installed for some reson. May be you missed that command while doing step 3.

    repeate:
    sudo apt-get install -y librtlsdr-dev

    then try again step 5:
    cd ~/install-dump/dump1090
    sudo dpkg-buildpackage -b
    Last edited by abcd567; 2016-07-26 at 22:28.

  5. #25
    First officer
    Join Date
    Mar 2015
    Location
    T-KSJC28
    Posts
    339
    Hi abcd567,

    Thanks again for all the useful information, I haven't given up yet and have made progress. Went through all the steps to get the external lighty webserver working and now the <localhost>/dump1090/gmap works. All the feeders are working too now.

    Previously I had uninstalled and re-installed the librtlsdr* and dump1090-mutability* a couple of times and what I found was that the commands to re-install those files in step 3 above were not working. It's as if the O/S was looking at a config file for install status that I hadn't deleted (the commands in step 3 above all returned something like 'latest ver already installed..."). I force installed the librtlsdr and dumP1090-mutability with this other command sequence for both the librtlsdr, rtl-sdr and dump1090-mutability files from your post back in March:

    abcd567_March

    2b- Install RTL-SDR Drivers
    Code:
    git clone git://git.osmocom.org/rtl-sdr.git
    cd rtl-sdr
    mkdir build
    cd build
    cmake ../ -DINSTALL_UDEV_RULES=ON
    make
    sudo make install
    sudo ldconfig
    cd ~
    sudo cp ./rtl-sdr/rtl-sdr.rules /etc/udev/rules.d/
    sudo reboot


    etc for each reinstall using the related specific name arguments in your post 1 step 3 above.

    Then went through the commands to reconfigure dump1090-mutability with location info and the other settings according to your post 1 here.

    Long story short, everything is working now but the <localhost>/dump1090/gmap doesn't show the mlat planes. Not sure I care though since I use VRS anyway.
    For others who might care it would be interesting to fix though.

    Thanks Again!

    PS Lesson learned here is to buy a faster SD card from the get go. Will save a ton of time if you have to fiddle with things.

    PPS: for VRS mlat receiver, courtesy of a post by Oblivion recently, setting format to "BaseStation" with address <localhost>:30106 fixed my MLAT VRS map problem. I think the problem with the <localhost>/dump1090/gmap is related to not receiving the mlat data reflected from piaware.

    i.e. To those who maybe confused, the VRS 'mlat' receiver is a virtual receiver and not a physical DVB-T stick or an actual physical receiver. The virtual receiver is merged with the physical receiver to create a virtual 'merged' receiver that you can feed to VRS.
    Last edited by Sam26K; 2016-07-27 at 05:37.

  6. #26
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,391
    @Sam26K
    Piaware feeds MLAT data to port 30104.
    Check settings of dump1090 mutability. By default it has setting of "Ports for Beast-format input connections" as 30004,30104.

    Use command below to check, and add 30104 if not already there:
    Code:
    sudo dpkg-reconfigure dump1090-mutability
    Reboot for new setting to take effect. Reload/refresh the gmap page.

    Also configure your Piaware data feeder to feed MLAT input to port 30104, and to make port 30106 available for feeding MLAT to VRS in case you want to display piawre's MLAT planes on VRS. This is done using port 30106 (ext_basestation,listen,30106)

    Code:
    #Configuration command
    ~ $ sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104  ext_basestation,listen,30106"
    
    #Check if configuration has actually taken place
    ~ $ sudo piaware-config -show
    
    #Above command will show contents of piaware config file '/root/.piaware' as follows:
    mlatResultsFormat {beast,connect,localhost:30104  ext_basestation,listen,30106}
    password xxxxxxxx
    user xxxxxxxx
    
    #Now restart piaware so that new configuration starts operating
    ~ $ sudo piaware-config -restart
    
    #Above command will give following output:
    invoking: /etc/init.d/piaware restart
    [ ok ] Restarting piaware (via systemctl): piaware.service.
    
    #Now reboot RPi
    ~ $ sudo reboot
    Last edited by abcd567; 2016-07-27 at 17:17.

  7. #27
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,391
    Quote Originally Posted by Sam26K View Post
    ....
    PS Lesson learned here is to buy a faster SD card from the get go. Will save a ton of time if you have to fiddle with things.
    ......
    The best is to have more than one microSD card, one running in the Pi, other for experimenting. In this way one can do a fresh install of anything new without disturbing his stable running card. I have 6 microSD cards, 3 operating in the 3 Pis, 3 for experimenting.

    Also I have formatted each of these microSD cards several times during last 3 years for making a fresh install of OS img, and none of these has worn out, contrary to common belief that multiple formattings will quickly wear out a card.
    Last edited by abcd567; 2016-07-27 at 14:33.

  8. #28
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,391
    Quote Originally Posted by nick223 View Post
    I'm using wheezy is that the issue?
    Thanks to Oliver Jowett (writer of dump1090-mutability), whom I consulted yesterday, and he promptly confirmed following:

    "Means that there is no packaged version of librtlsdr installed. Wheezy does not provide one. You need to build a package (not just install from source) or use the one I provide from repo.mutability.co.uk"

    In view of above reply, please run following additional commands to download & install package for librtlsdr-dev on Wheezy:
    Code:
    wget https://github.com/mutability/librtlsdr/releases/download/v0.5.4_git-1/librtlsdr0_0.5.4.git-1_armhf.deb
    wget https://github.com/mutability/librtlsdr/releases/download/v0.5.4_git-1/librtlsdr-dev_0.5.4.git-1_armhf.deb
    sudo dpkg -i librtlsdr0_0.5.4.git-1_armhf.deb
    sudo dpkg -i librtlsdr-dev_0.5.4.git-1_armhf.deb
    Now try again step 5:
    Code:
    cd ~/install-dump/dump1090
    sudo dpkg-buildpackage -b
    Last edited by abcd567; 2016-07-27 at 20:25.

  9. #29
    First officer
    Join Date
    Mar 2015
    Location
    T-KSJC28
    Posts
    339
    Quote Originally Posted by abcd567 View Post

    Also configure your Piaware data feeder to feed MLAT input to port 30104, and to make port 30106 available for feeding MLAT to VRS in case you want to display piawre's MLAT planes on VRS. This is done using port 30106 (ext_basestation,listen,30106)

    Code:
    #Configuration command
    ~ $ sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104  ext_basestation,listen,30106"
    
    #Check if configuration has actually taken place
    ~ $ sudo piaware-config -show
    
    
    #Now restart piaware so that new configuration starts operating
    ~ $ sudo piaware-config -restart
    
    #Above command will give following output:
    invoking: /etc/init.d/piaware restart
    [ ok ] Restarting piaware (via systemctl): piaware.service.
    
    #Now reboot RPi
    ~ $ sudo reboot
    Success! Everything is working now. My error was in the piaware configuration and corrected with your commands above.


    Thanks Again, abcd567!

    PS: Now that everything is working I will probably want to expand it more .

    PPS: My specific error was in the data format in "....ext_basestation,listen,30106"" I had something other than basestation.

    PPPS: abcd567 Quote:

    "Check settings of dump1090 mutability. By default it has setting of "Ports for Beast-format input connections" as 30004,30104.".

    I was also missing that extra port for dump1090 mutability port 30104 settings which I think fixed the <localhost>/dump1090 MLAT map problem.
    Last edited by Sam26K; 2016-07-29 at 08:18.

  10. #30
    First officer
    Join Date
    Mar 2015
    Location
    T-KSJC28
    Posts
    339
    Suggested follow up on this thread would be "which port is what and how should it be configured?" .

    I.E. A list of ports and how they should be configured for each app. TIA .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •