Page 10 of 20 FirstFirst ... 89101112 ... LastLast
Results 91 to 100 of 195

Thread: How to Install dump1090-mutability_1.15~dev on RPi

  1. #91
    Flight attendant
    Join Date
    Feb 2016
    Location
    South Germany
    Posts
    57
    @abcd567: Installation did work in RPi in my office (and I added PlaneFinder), I put the SD card in my live installation (removed old SD card, put in the newly installed), booted up: disppointment. Range dropped from 190 nm to 100 nm, no hardware changes done.
    Old SD card: mutability v1.14 from FR24 installation.
    I shutdown and put in the old SD card: back up to 190 nm. Do I have to fiddle with GAIN then?
    JRF: T-EDNY19
    South Germany

  2. #92
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,653
    Quote Originally Posted by jrf View Post
    Do I have to fiddle with GAIN then?
    Most likely it is gain setting which made the difference.
    What gain setting you have in v1.14? Use the same value in v1.15

    You can also try gain max, -10, and few values like 50, 45, 40, 35 and see which gives best result.

  3. #93
    Passenger
    Join Date
    Apr 2015
    Location
    Smedsby, Korsholm, Finland
    Posts
    21
    Quote Originally Posted by abcd567 View Post
    Most likely it is gain setting which made the difference.
    What gain setting you have in v1.14? Use the same value in v1.15

    You can also try gain max, -10, and few values like 50, 45, 40, 35 and see which gives best result.
    According to this discussion , the extra argument --aggressive has no effect in version 1.15~dev
    https://github.com/mutability/dump1090/issues/227
    If you test v. 1.14 with and without --aggressive you may see a noticeable difference in max. distance and messages received.

  4. #94
    Flight attendant
    Join Date
    Feb 2016
    Location
    South Germany
    Posts
    57
    Still noticing less data, I saw when I used command "sudo piaware-config -showall":
    Code:
    #adept-serverhosts             "piaware.flightaware.com piaware.flightaware.com {REMOVED}" # using default value
    #adept-serverport              1200                           # using default value
    #allow-auto-updates            no                             # using default value
    #allow-dhcp-duid               yes                            # using default value
    #allow-manual-updates          no                             # using default value
    #allow-mlat                    yes                            # using default value
    #allow-modeac                  yes                            # using default value
    #beast-baudrate                <unset>                        # no value set and no default value
    feeder-id                      REMOVED # value set at /etc/piaware.conf:7
    #flightaware-password          <unset>                        # no value set and no default value
    #flightaware-user              <unset>                        # no value set and no default value
    #force-macaddress              <unset>                        # no value set and no default value
    #http-proxy-host               <unset>                        # no value set and no default value
    #http-proxy-password           <unset>                        # no value set and no default value
    #http-proxy-port               <unset>                        # no value set and no default value
    #http-proxy-user               <unset>                        # no value set and no default value
    #image-type                    <unset>                        # no value set and no default value
    #manage-config                 no                             # using default value
    #mlat-results                  yes                            # using default value
    #mlat-results-anon             yes                            # using default value
    #mlat-results-format           "beast,connect,localhost:30104 beast,listen,30105 ext_basestation,listen,30106" # using default value
    #priority                      <unset>                        # no value set and no default value
    #radarcape-host                <unset>                        # no value set and no default value
    #receiver-host                 <unset>                        # no value set and no default value
    #receiver-port                 30005                          # using default value
    #receiver-type                 rtlsdr                         # using default value
    #rfkill                        no                             # using default value
    #rtlsdr-device-index           0                              # using default value
    #rtlsdr-gain                   -10                            # using default value
    #rtlsdr-ppm                    0                              # using default value
    #wired-address                 <unset>                        # no value set and no default value
    #wired-broadcast               <unset>                        # no value set and no default value
    #wired-gateway                 <unset>                        # no value set and no default value
    #wired-nameservers             "8.8.8.8 8.8.4.4"              # using default value
    #wired-netmask                 <unset>                        # no value set and no default value
    #wired-network                 yes                            # using default value
    #wired-type                    dhcp                           # using default value
    #wireless-address              <unset>                        # no value set and no default value
    #wireless-broadcast            <unset>                        # no value set and no default value
    #wireless-gateway              <unset>                        # no value set and no default value
    #wireless-nameservers          "8.8.8.8 8.8.4.4"              # using default value
    #wireless-netmask              <unset>                        # no value set and no default value
    #wireless-network              no                             # using default value
    #wireless-password             <unset>                        # no value set and no default value
    #wireless-ssid                 <unset>                        # no value set and no default value
    #wireless-type                 dhcp                           # using default value
    So I everything hashed: Okay, whre is the problem then?
    Then I used the command "sudo nano /etc/default/dump1090-mutability" and noticed that I saw that gain there was set to "max". I changed that to "-10", restarted mutability and now I have around the same range as with the mutabiliy 1.14 installation. I will let it run for a while to see the development of the feeded data...
    Last edited by jrf; 2018-04-08 at 10:47. Reason: Misunderstandig, corrected
    JRF: T-EDNY19
    South Germany

  5. #95
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,653
    @jrf
    Piaware config controls Dongle Gain ONLY if you are using Piaware SD Card image downloaded from Flightaware.

    If you are using Raspbian Image and then have installed dump1090 (fa or mutability) and installed Piaware data feeder, the following commands do NOT change device index or Gain settings:
    sudo piaware-config rtlsdr-device-index 0
    sudo piaware-config rtlsdr-gain xx

    Only editing file "/etc/default/dump1090-mutability" or "/etc/default/dump1090-fa", as the case may be, will implement changes.

    On the other hand if you are using Piaware SD Card image, modifications to file "/etc/default/dump1090-fa" are overwritten by piaware-config by values set by "sudo piaware-config" command or entered in file "/boot/piaware-config.txt".
    Please note that file "/boot/piaware-config.txt" is only part of Piaware SD card image, and does not exist in Raspbian image with Piaware add-on install.
    Last edited by abcd567; 2018-04-08 at 19:15.

  6. #96
    Flight attendant
    Join Date
    Feb 2016
    Location
    South Germany
    Posts
    57
    Thx abcd567, as it is the mutability 1.15 thread I have changed "/etc/default/dump1090-mutability" from gain "max" to "-10" getting back to the range I had before (as stated above).
    1) What I do not understand: I think to remember from a post I read somewhere that "max" and "-10" are basically the same, but the outcome for me is a big difference.
    2) What do the different colors (green, purple) in the plane list in map gmap.html mean?
    Last edited by jrf; 2018-04-08 at 21:26. Reason: Addition
    JRF: T-EDNY19
    South Germany

  7. #97
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,653
    Quote Originally Posted by jrf View Post
    1) What I do not understand: I think to remember from a post I read somewhere that "max" and "-10" are basically the same, but the outcome for me is a big difference.
    The setting "max" sets gain to "Maximum Available" setting of the dongle, which is 49.6 dB.
    The setting "-10" does NOT set any gain value. It is a switch. It switches the dongle to AGC (automatic gain control) which theoretically should continuously adjust the gain according to prevailing signal level.


    Quote Originally Posted by jrf View Post
    2) What do the different colors (green, purple) in the plane list in map gmap.html mean?
    I don't know. I never paid any attention to color of Plane Icons.
    May be it is related to altitude of the plane, but I am not sure.

  8. #98
    Flight attendant
    Join Date
    Feb 2016
    Location
    South Germany
    Posts
    57
    Quote Originally Posted by abcd567 View Post
    I don't know. I never paid any attention to color of Plane Icons.
    May be it is related to altitude of the plane, but I am not sure.
    Color is coming from config.js. See:
    Code:
    cd ~
    cd /usr/share/dump1090-mutability/html
    sudo nano config.js
    Code:
    // These settings control the coloring of aircraft by altitude.
    // All color values are given as Hue (0-359) / Saturation (0-100) / Lightness (0-100)
    ColorByAlt = {
            // HSL for planes with unknown altitude:
            unknown : { h: 0,   s: 0,   l: 40 },
    
            // HSL for planes that are on the ground:
            ground  : { h: 120, s: 100, l: 30 },
    
            air : {
                    // These define altitude-to-hue mappings
                    // at particular altitudes; the hue
                    // for intermediate altitudes that lie
                    // between the provided altitudes is linearly
                    // interpolated.
                    //
                    // Mappings must be provided in increasing
                    // order of altitude.
                    //
                    // Altitudes below the first entry use the
                    // hue of the first entry; altitudes above
                    // the last entry use the hue of the last
                    // entry.
                    h: [ { alt: 2000,  val: 20 },    // orange
                         { alt: 10000, val: 140 },   // light green
                         { alt: 40000, val: 300 } ], // magenta
                    s: 85,
                    l: 50,
            },
    
            // Changes added to the color of the currently selected plane
            selected : { h: 0, s: -10, l: +20 },
    
            // Changes added to the color of planes that have stale position info
            stale :    { h: 0, s: -10, l: +30 },
    
            // Changes added to the color of planes that have positions from mlat
            mlat :     { h: 0, s: -10, l: -10 }
    };

  9. #99
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,653
    Quote Originally Posted by abcd567 View Post
    May be it is related to altitude of the plane, but I am not sure.


    Quote Originally Posted by jrf View Post
    Code:
    // These settings control the coloring of aircraft by altitude.
    
                    // These define altitude-to-hue mappings
                    
                    h: [ { alt: 2000,  val: 20 },    // orange
                         { alt: 10000, val: 140 },   // light green
                         { alt: 40000, val: 300 } ], // magenta


    @jrf:
    Thanks for pointing out.
    So my assumtion was right that colors likely represent altitude.
    Last edited by abcd567; 2018-04-16 at 21:09.

  10. #100
    Captain abcd567's Avatar
    Join Date
    Sep 2013
    Location
    Toronto CYYZ
    Posts
    2,653
    RTL-SDR V3 Dongle
    Enabling Auto Switch-ON of Bias-T in dump1090-mutability v1.15~dev.


    There is a method posted on the RTL-SDR Blog on April 28, 2018, which is applicable to Piaware/dump1090-fa and uses bias-t start command through file dump1090-fa.service.


    This method does not apply to dump1090-mutability v1.15~dev, as the dump1090-mutability.service files are automatically generated by "systemd-sysv-generator", and all the changes made by user are overwritten at restart / reboot.

    The dump1090-mutability.service starts dump1090-mutability through the file /etc/init.d/dump1090-mutability, which is not overwritten at reboot/restart. I have therefore added bias-t start and logging script in that file, and it works OK.

    STEP-1:

    Build package rtl_biast

    Code:
    #First installed Packages needed to build and to fulfill dependencies 
    
    sudo apt-get install git  
    sudo apt-get install cmake 
    sudo apt-get install libusb-1.0 
    
    #Now build rtl_biast 
    git clone https://github.com/rtlsdrblog/rtl_biast 
    cd rtl_biast 
    sudo mkdir build 
    cd build 
    sudo cmake .. 
    sudo make 
    
    #TEST-1 
    cd src 
    ./rtl_biast -b 1 
    usb_claim_interface error -6 
    
    #TEST-2 
    sudo systemctl stop dump1090-mutability 
    ./rtl_biast -b 1 
    Found Rafael Micro R820T tuner

    STEP-2:

    (1) Open file /etc/init.d/dump1090-mutability in editor.

    Code:
    sudo nano /etc/init.d/dump1090-mutability
    (2) In the file opened, scroll down to following portion of code
    (You can quickly reach there by pressing Ctrl+w, then typing do_start then pressing Enter Key).

    Code:
    # Function that starts the daemon/service 
    # 
    do_start() 
    { 
    
         #      Return 
         #      0 if daemon has been started 
         #      1 if daemon was already running 
         #      2 if daemon could not be started
    (3) Insert following 2 lines
    Code:
    /home/pi/rtl_biast/build/src/rtl_biast -b 1 >> /var/log/biast.log 2>&1 
    
    date >> /var/log/biast.log
    The lines should be inserted at location shown below:


    Code:
    # Function that starts the daemon/service 
    # 
    do_start() 
    {
    
              /home/pi/rtl_biast/build/src/rtl_biast -b 1 >> /var/log/biast.log 2>&1 
              date >> /var/log/biast.log  
    
             #   Return        
             #      0 if daemon has been started 
             #      1 if daemon was already running 
             #      2 if daemon could not be started
    (4) Save file (Ctrl+o) and Close editor (Ctrl+x)

    (5) Reload daemon to incorporate changes, then restart dump1090-mutability.
    Code:
    sudo systemctl daemon-reload 
    sudo systemctl restart dump1090-mutability
    Check log
    Code:
    cat /var/log/biast.log 
    Found Rafael Micro R820T tuner 
    Tue May 1 14:25:06 EDT 2018
    .

    Explanation of code:
    "/home/pi/rtl_biast/build/src/rtl_biast -b 1" switches on the bias t
    ">> /var/log/biast.log 2>&1" sends output (stdout+stderr) to file /var/log/biast.log
    "date >> /var/log/biast.log" timestamps the log

    .

    If you are interested only in switching-on the bias-t, and are not interested in creating biast log, then only one short line (i.e. /home/pi/rtl_biast/build/src/rtl_biast -b 1) need to be added as shown below:

    Code:
    # Function that starts the daemon/service 
    #
    do_start() 
    { 
             /home/pi/rtl_biast/build/src/rtl_biast -b 1 
    
             #   Return 
             #      0 if daemon has been started 
             #      1 if daemon was already running 
             #      2 if daemon could not be started
    Last edited by abcd567; 2018-05-05 at 06:50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •