Results 1 to 5 of 5

Thread: New installation on RPi not sending

  1. #1
    Passenger
    Join Date
    Apr 2016
    Location
    Denmark, Vissenbjerg
    Posts
    9

    Question New installation on RPi not sending

    It seems that my RPi is not able to send anything

    I DL the Raspberry Pi image, booted the RPi and ran the install script. When else to do?

    Status:
    FR24 Link: Connected via TCP
    FR24 Radar Code: T-EKOD12
    Aircraft Tracked (ModeS & ADS-B): 0
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: NO



    My log:

    2016-04-18 16:54:20 | [main][i]FR24 Feeder/Decoder
    2016-04-18 16:54:20 | [main][i]Version: 1.0.18-5/generic
    2016-04-18 16:54:20 | [main][i]Built on Mar 4 2016 15:21:10 (HEAD-d11ca48.git/Linux/armv7l)
    2016-04-18 16:54:20 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-04-18 16:54:20 | [main][i]flightradar24.com
    2016-04-18 16:54:20 | [main][i]DNS mode: LIBC
    2016-04-18 16:54:20 | [main][i]Automatic updates are DISABLED
    2016-04-18 16:54:20 | ERROR
    2016-04-18 16:54:20 | [main][i]Reader thread started
    2016-04-18 16:54:20 | [main][i]Socket server started
    2016-04-18 16:54:20 | [main][i]MLAT data feed started
    2016-04-18 16:54:20 | [bs][i]Initializing server
    2016-04-18 16:54:20 | [bs][i]Starting server on 0.0.0.0:30003
    2016-04-18 16:54:20 | [mlat][i]Waiting for MLAT configuration
    2016-04-18 16:54:20 | [reader][i]Initializing reader
    2016-04-18 16:54:20 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090 --raw --mlat)
    2016-04-18 16:54:20 | [reader][i]Connected to the receiver, configuring
    2016-04-18 16:54:20 | [master][i]Starting processing thread
    2016-04-18 16:54:20 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-04-18 16:54:20 | [reader][i]Configured, processing messages
    2016-04-18 16:54:21 | [time][i]Synchronizing time via NTP
    2016-04-18 16:54:26 | [time][i]Time synchronized correctly, offset -0.0003 seconds
    2016-04-18 16:54:26 | [main][i]Feed Network client started
    2016-04-18 16:54:26 | [main][i]RAW data server started
    2016-04-18 16:54:26 | [raw][i]Initializing server
    2016-04-18 16:54:26 | [raw][i]Starting server on 0.0.0.0:30002
    2016-04-18 16:54:26 | [feed][i]Downloading configuration
    2016-04-18 16:54:26 | [feed][c]Interval: 5s
    2016-04-18 16:54:26 | [feed][c]Latitude: 55.3866
    2016-04-18 16:54:26 | [feed][c]Longitude: 10.1720
    2016-04-18 16:54:26 | [feed][c]GND: YES
    2016-04-18 16:54:26 | [feed][c]NonADSB: YES
    2016-04-18 16:54:26 | [feed][c]Timestamps: optional
    2016-04-18 16:54:26 | [feed][c]Max range AIR: 350.0nm
    2016-04-18 16:54:26 | [feed][c]Max range GND: 100.0nm
    2016-04-18 16:54:26 | [feed][i]defined 4 servers
    2016-04-18 16:54:26 | [feed][n]EKOD12@83.140.21.112:28099/UDP
    2016-04-18 16:54:26 | [feed][n]connecting
    2016-04-18 16:54:26 | [stats][i]Stats thread started
    2016-04-18 16:54:26 | [feed][n]connected via UDP (fd 12)
    2016-04-18 16:54:26 | [feed][n]working
    2016-04-18 16:54:56 | [feed][n]ping 1
    2016-04-18 16:54:57 | [feed][n]syncing stream: 1



    ...and then it just continues pinging
    Attached Images Attached Images

  2. #2
    Team FR24
    Join Date
    Feb 2015
    Posts
    221
    Quote Originally Posted by Wassini View Post
    It seems that my RPi is not able to send anything

    I DL the Raspberry Pi image, booted the RPi and ran the install script. When else to do?

    Status:
    FR24 Link: Connected via TCP
    FR24 Radar Code: T-EKOD12
    Aircraft Tracked (ModeS & ADS-B): 0
    Aircraft Uploaded: N/A
    Receiver: dvbt, Connected
    MLAT running: NO



    My log:

    2016-04-18 16:54:20 | [main][i]FR24 Feeder/Decoder
    2016-04-18 16:54:20 | [main][i]Version: 1.0.18-5/generic
    2016-04-18 16:54:20 | [main][i]Built on Mar 4 2016 15:21:10 (HEAD-d11ca48.git/Linux/armv7l)
    2016-04-18 16:54:20 | [main][i]Copyright 2012-2016 Flightradar24 AB
    2016-04-18 16:54:20 | [main][i]flightradar24.com
    2016-04-18 16:54:20 | [main][i]DNS mode: LIBC
    2016-04-18 16:54:20 | [main][i]Automatic updates are DISABLED
    2016-04-18 16:54:20 | ERROR
    2016-04-18 16:54:20 | [main][i]Reader thread started
    2016-04-18 16:54:20 | [main][i]Socket server started
    2016-04-18 16:54:20 | [main][i]MLAT data feed started
    2016-04-18 16:54:20 | [bs][i]Initializing server
    2016-04-18 16:54:20 | [bs][i]Starting server on 0.0.0.0:30003
    2016-04-18 16:54:20 | [mlat][i]Waiting for MLAT configuration
    2016-04-18 16:54:20 | [reader][i]Initializing reader
    2016-04-18 16:54:20 | [reader][i]Connecting to Beast receiver via (exe:///usr/lib/fr24/dump1090 --raw --mlat)
    2016-04-18 16:54:20 | [reader][i]Connected to the receiver, configuring
    2016-04-18 16:54:20 | [master][i]Starting processing thread
    2016-04-18 16:54:20 | [httpd][i]Server started, listening on 0.0.0.0:8754
    2016-04-18 16:54:20 | [reader][i]Configured, processing messages
    2016-04-18 16:54:21 | [time][i]Synchronizing time via NTP
    2016-04-18 16:54:26 | [time][i]Time synchronized correctly, offset -0.0003 seconds
    2016-04-18 16:54:26 | [main][i]Feed Network client started
    2016-04-18 16:54:26 | [main][i]RAW data server started
    2016-04-18 16:54:26 | [raw][i]Initializing server
    2016-04-18 16:54:26 | [raw][i]Starting server on 0.0.0.0:30002
    2016-04-18 16:54:26 | [feed][i]Downloading configuration
    2016-04-18 16:54:26 | [feed][c]Interval: 5s
    2016-04-18 16:54:26 | [feed][c]Latitude: 55.3866
    2016-04-18 16:54:26 | [feed][c]Longitude: 10.1720
    2016-04-18 16:54:26 | [feed][c]GND: YES
    2016-04-18 16:54:26 | [feed][c]NonADSB: YES
    2016-04-18 16:54:26 | [feed][c]Timestamps: optional
    2016-04-18 16:54:26 | [feed][c]Max range AIR: 350.0nm
    2016-04-18 16:54:26 | [feed][c]Max range GND: 100.0nm
    2016-04-18 16:54:26 | [feed][i]defined 4 servers
    2016-04-18 16:54:26 | [feed][n]EKOD12@83.140.21.112:28099/UDP
    2016-04-18 16:54:26 | [feed][n]connecting
    2016-04-18 16:54:26 | [stats][i]Stats thread started
    2016-04-18 16:54:26 | [feed][n]connected via UDP (fd 12)
    2016-04-18 16:54:26 | [feed][n]working
    2016-04-18 16:54:56 | [feed][n]ping 1
    2016-04-18 16:54:57 | [feed][n]syncing stream: 1



    ...and then it just continues pinging
    Maybe your antenna is not picking up any signals? Assuming you are running only FR24 on the PI and no other sharing program and you are seeing only pings then it suggests that no data is being received by your receiver.
    --

  3. #3
    Passenger
    Join Date
    Apr 2016
    Location
    Denmark, Vissenbjerg
    Posts
    9
    Maybe it's not getting enough power from the RPi via the USB port. I'll try to add an USB hub with power....
    Lars Bo Wassini
    T-EKOD12

  4. #4
    Passenger
    Join Date
    Apr 2016
    Location
    Denmark, Vissenbjerg
    Posts
    9
    It seems that the HUB made a difference. At least I'm now getting a complete other error in the log file:

    2016-04-19 20:14:02 | [mlat][i]Registering MLAT station
    2016-04-19 20:14:02 | [mlat][i]Registering MLAT station: FAILURE
    2016-04-19 20:16:19 | [feed][i]removed 2 of 3 AC
    2016-04-19 20:16:19 | [feed][i]sent 1, filtered 0 AC in 1 packet
    2016-04-19 20:16:19 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-04-19 20:16:19 | [mlat][i]Registering MLAT station
    2016-04-19 20:16:19 | [mlat][i]Registering MLAT station: FAILURE
    2016-04-19 20:16:20 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-04-19 20:16:20 | [mlat][i]Registering MLAT station
    2016-04-19 20:16:20 | [mlat][i]Registering MLAT station: FAILURE
    2016-04-19 20:16:21 | [feed][n]syncing stream: 1
    2016-04-19 20:16:21 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    2016-04-19 20:16:21 | [mlat][i]Registering MLAT station
    2016-04-19 20:16:21 | [mlat][i]Registering MLAT station: FAILURE
    2016-04-19 20:16:22 | [mlat][i]Configuring UDP connection udp://mlat-1.fr24.com:19788
    Lars Bo Wassini
    T-EKOD12

  5. #5
    Passenger
    Join Date
    Apr 2016
    Location
    Denmark, Vissenbjerg
    Posts
    9
    Despite the errors - it seems that it's uploading just fine!
    Just reported 6 aircraft in 2 minutes :-)
    Lars Bo Wassini
    T-EKOD12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •