Announcement

Collapse
No announcement yet.

RPi Model B V 1.2 - Not Booting Pi24

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RPi Model B V 1.2 - Not Booting Pi24

    Hi Folks,

    I've spent two days trying to sort this issue before asking for help. Apologies to those who can find the answer in seconds, but I promise I tried.

    I've been data sharing to FR24 for a while (radar T-EGAC143) and was initially up and running very quickly.

    Hardware is RPi Model B V 1.2 with RadarBox ADS-B reciever & commercial antenna, and it had been running perfectly until a few days ago. I had to switch off the RPi (along with everything else) due to the electrical supply to the property being temporarily disconnected/re-connected several times over a short space of time. When I plugged it back in, it just wouldn't boot (unfortunately because if the location of the RPi I couldn't see the status LEDs to see any error codes). I thought perhaps some part of the file system had become corrupted so I wiped the MicroSD card, downloaded Pi24 from FR24, re-imaged using Balena etcher, configured my sharing key/wifi details and rebooted. However all I'm getting is 7 quick flashes which suggest the RPi can't find kernel.img. When unpacked the Pi24 package only create kernel8.img & kernel_2712.img.

    I tried adding the line kernel=kernel8.img to config.txt but this made no difference.

    When booting, I get to the rainbow test screen and that's it - seven flashes of the green led over and over and over.

    In terms of resolving - I have changed the power supply to the RPi, I bought a new (second hand) RPi, used different MicroSD cards and nothing makes a difference. I have booted the RPi into other OSs so I know the RPi is good. I've also tried writing the image tio the MicroSD card using the official RaspberryPi Imager, and have tried writing the image at least 6 times but nada, zip!

    I really haven't a clue why it worked so effortlessly before, and now it just refuses to boot. I'm susepcting there has been an update to Pi24 which is someway incompatible with the RPi that I have, but figuring it out, is well above my paygrade.

    Has anyone else had a similar issue or can anyone shine a light on what I'm missing, or would anyone have an older version of Pi24 from around August 2023 when I know for sure it was working with my setup.

    Thanks in advance

    Mark

  • #2
    Just use a raw lite os and build/add to it from there. The custom images are always focused on how they want it set-up and may not cover every person's scenario
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Thanks Oblivian.

      I gave up with the custom image and followed this guide : https://forum.flightradar24.com/foru...15-dev-on-RPi=

      All working as before, but still no closer to knowing why it didn't work, but a win's a win!
      Last edited by k2sul; 2024-07-11, 09:52.

      Comment

      Working...
      X