Announcement

Collapse
No announcement yet.

FA Stick Pro - MLAT not working with --gain -10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FA Stick Pro - MLAT not working with --gain -10

    Hi people,
    i'm using a Raspberry Pi 3, FA Stick Pro and FR24 image Setup.
    When i'm using the "--gain -10" the MLAT feature is stopping to work. At the same time no Aircraft is tracked and uploaded. When i turn the Parameter back to any other value MLAT is starting to work againg.
    Has anybody an idea what the Problem coud be? Is the gain value to high with this automatic Setting for the internal tuner? But why is MLAT stop working.
    Until a few days i was using a well working (Raspberry, FR24 Setup, NooElec) Setup.
    Thanks for any ideas to my Problem!
    Best breze09

  • #2
    Keyword search for 'gain' and you will find a number of recent threads asking similar, with solutions to test for the better settings in your area using rtl-test.

    And one outlining -10 is not the same as automatic and can cause adverse effects.

    Sent from my XT1092 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Thanks for your Reply! I used the search but no post i found explains why MLAT stops working with the "--gain -10". Naturally i can set the value to suggested reduced values e.g. 30 but i want to know why MLAT isn't working with -10. I think i could use any wrong value but i don't understand the effect on the MLAT feature. You're right, automatic was the wrong discription, sorry.
      Thanks so far.

      Comment


      • #4
        basically the Prostick is pre-optimized.

        The version of dump1090 may react differently explicitly demanding -10 over the default settings (which I believe does other auto options) and stop the data that FR24feedw wants (potentially ignoring the --raw flags)

        Likewise using this with dump1090 some auto options don't go down so well with the prostick. You have to tune your system as it has built in preamps and filters that takes care of a lot of that work.

        https://forum.flightradar24.com/thre...ization-Script



        https://forum.flightradar24.com/thre...ain#post103765
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          Thanks for your Interpretation of the behaviour of the -10 value for MLAT! I appreciate it! I hoped everybody say with -10 it isn't working. Now i see it's a kind of a black box.

          Comment


          • #6
            The --gain -10 is not a blackbox.
            Neither it disables MLAt.
            I have Pi24 with gain set as -10, and MLAT still works and plane are shown on map.


            .PI24 - gain -10 - screenshot 1.png . PI24 - gain -10 - screenshot 2.png . PI24 - gain -10 - screenshot 3.png
            Last edited by abcd567; 2018-09-09, 06:22.

            Comment


            • #7
              The "--gain -10" sets FA Pro Stick to more than maximum (49.6) i.e. to say 53.
              Such a high gain can overload dongle if strong Cell/Mobile signals exist in the area.

              Reduce gain to say 40 and see if it helps.

              Comment


              • #8
                Thanks a lot for your additional help abcd567! I don't know why but the "gain -10" value ist the only one which stops MLAT working. I can set any other value without Problems. This Problem startet as i mentioned using the FA Pro Stick. With the Nooelec i hadn't hat Problem.
                One new problem is that my tracked aircrafts drops every few hours from 200-300 to 20-30. After half an hour it becomes normal.
                I'm still trying to solve the issue.
                Last edited by brez09; 2018-09-09, 12:22.

                Comment


                • #9
                  Originally posted by brez09 View Post
                  I don't know why but the "gain -10" value ist the only one which stops MLAT working. I can set any other value without Problems.

                  This Problem startet as i mentioned using the FA Pro Stick. With the Nooelec i hadn't hat Problem.
                  As the setting "--gain -10" sets the gain "more than maximum setting of 49.6", it usually sets it around 53 to 55. This high gain + 18 dB gain of FA Pro Stick will saturate the dongle IF at your location there are strong TV and Mobile/Cell signals.

                  As Nooelec dongle does not have an amplifier it does not face the problem of saturation/overload and drop in performance even with gain setting -10 (=55). Most likely adding a Filter will considerably reduce the strength of interfering TV and Cell/Mobile signal, resulting in dongle performing ok even at -10 gain setting.

                  You can determine the presence and intensity of interfering signals by method described here:

                  Do I need a Filter? - Find RF Signals In Area



                  Originally posted by brez09 View Post
                  One new problem is that my tracked aircrafts drops every few hours from 200-300 to 20-30. After half an hour it becomes normal. I'm still trying to solve the issue.
                  Reduce gain setting to say between 25 and 35. Most likely this problem will disappear.
                  Last edited by abcd567; 2018-09-10, 03:11.

                  Comment


                  • #10
                    Hi abcd567. I appreciate your help! Thank you for your explanation! I'm still trying to solve the MLAT Problem. It isn't a Problem anymore, but i want it to know why ;-) The Setup ist working finde with 49.6 gain now. I got with it the most messages/sec.

                    I was successful solving my newest Problem and want you People outside to know. Maybe there are few who have a simalar spooky problem. As i mentioned my tracked aircrafts drops randomly from 200-300 to 20-30. The reason for was that someone in the house was using the TV. The cable of the ADSB antenna runs togehter with other cabels of the satellite antenna. There have to be strong interferences between the cables so the signal becomes too week. I don't know how to counteract. Maybe a 24 hour TV prohibition. ;-)

                    Comment


                    • #11
                      That's an interesting one.
                      Assuming you can't slightly increase the separation between the cables or re-route one of them the only thing I can suggest is, after checking what cable types are in use, try to find some better quality low loss cable with improved screening.

                      Comment


                      • #12
                        The moment i was realizing was crazy. Turning on the TV reduces the messages/sec within seconds.
                        I will try to seperate them but the tube is already filled with five cables now.
                        I don't know if ist allowed, but i use this antenna + cable: https://shop.jetvision.de/epages/648...oducts%2F67121
                        A new cable would be the best solution. Thank's for your idea!

                        Comment


                        • #13
                          Originally posted by brez09 View Post
                          I was successful solving my newest Problem and want you People outside to know. Maybe there are few who have a simalar spooky problem. As i mentioned my tracked aircrafts drops randomly from 200-300 to 20-30. The reason for was that someone in the house was using the TV. The cable of the ADSB antenna runs togehter with other cabels of the satellite antenna. There have to be strong interferences between the cables so the signal becomes too week. I don't know how to counteract. Maybe a 24 hour TV prohibition. ;-)

                          (1) Determine the frequency and intensity of interfering TV signal by method described here:

                          Do I need a Filter? - Find RF Signals In Area



                          (2) Add a Filter DIRECTLY to the FA Pro Stick to reduce interfering TV Signal.

                          Antenna >> Cable >> FILTER >> FA Pro Stick.

                          This image shows how I have done it.

                          Filter + Pro Stick.jpg
                          Last edited by abcd567; 2018-09-10, 15:08.

                          Comment


                          • #14
                            The cable supplied with the Jetvision antenna appears to be of reasonable quality so I'm not sure changing it would help.
                            http://www.bieffecavi.com/pdf/CO100AFeng

                            The dish LNB will be supplying a wide band of frequencies back to the satellite receiver and there may be a transponder producing high signal levels right across the 1090MHz band.
                            I suppose it's also possible the satellite cable is a bit leaky.

                            Is the Jetvision aerial mounted close to the dish or to the LNB cable?
                            Last edited by jackthom; 2018-09-10, 15:37.

                            Comment


                            • #15
                              The Jetvision Aerial is mounted behind the satellite dish. All cables then go through a tube. Maybe changing the other cabels is easier because they are older. I never thought there could be such dependencies.
                              I will try the method of analysing interfering tv signals on the Weekend.
                              Thanks for you helpful tips! :-)

                              Comment

                              Working...
                              X