Announcement

Collapse
No announcement yet.

RTL-SDR

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PiRad108
    replied
    Well that was a couple of infuriating days I have the second dongle RTL-SDR R820T2 TCX up and feeding. There were two problems, the first lsmod was not showing the dongle, it should it has the same chip as the cheaper version I bought from jetvision. When I first had problems I had gone to the manual and it had advised a blacklist in modprobe.d which I did this did not fix the problem and I was still finding the dongle, but it still was not working. After some long hours wrestling with the problem, I decided to comment out the line in my created in blacllist-rtl.conf now I could see the 820 with lsmod but still not working now the feed was suggesting a connectivity problem but every connectivity test worked. Finally out of sheer frustration I removed the dongle from the Rpi and the feeder cable from the antenna and had a rechecked them both still fine. Then I had this aha moment and decided to put a fresh sma plug on the feeder, well it worked still cannot see what was wrong with the other one but it must have been a connection in the sma plug that shorted or failed when it was screwed up guess I will never know as it is crimped. The new dongle connected to the maligned by some 8 array coco is smashing all previous records. Today I am going to get it up a few meters higher.

    Leave a comment:


  • PiRad108
    replied
    Well the dongle most definitely works a quick check with

    $ rtl_adsb
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    Found Rafael Micro R820T tuner
    Tuner gain set to automatic.
    Tuned to 1090000000 Hz.
    Exact sample rate is: 2000000.052982 Hz
    Sampling at 2000000 S/s.
    *be8a7b1a609a99898ae260b7bcdc;
    *acf294b6cc646eef4cbbae22c233;
    *d1ab47bb8a25ca5c53b6d27d68f9;
    *adfd560ec1f4d4412da919cae9b0;
    *e6ca11cc9aa57b124b5f041e3fff;
    *8ea7ca4bfe9ad18a6486798d0c00;
    *b6090bf4c59027a051a562b6484e;
    *cdf12d9528a43addd469d33d3cf6;
    *9df128abe7a2f12ab269911d5054;
    *83d318e7f6aacc8aeb06dab710e0;
    *b11a3dccaf381121af17b7a391d9;
    *9271b7a4d20d85f2fcb8fab5534f;
    *d43a68e62d50759f305f9c8afe6b;
    *821d83e978e8c19310ab67d5fe6f;
    *b487f48ad7d77baaf9fb49c9bf29;
    *db3a183d625309057f7944041e8b;
    *cb65c8647a91860458c0097b22cd;
    *a7f1ea915f42125ae91905112cd3;
    *a99b69d354581bbc1fa16ea10f4c;
    *bab3738e241830f240cdba47bb05;
    *b935eebc98e9719cf94b775a3d51;
    *d5d577f996fed6957a493c5f3513;
    *c6ae216e75aff5b1411855b82498;
    *f6229ced423e24c8e9b9ee20b868;
    *a29f7cac2387164e43776f4dd1db;
    *83085f67129aebf44a45931150f9;
    *a22de32b25d4ee1ccbeeebf2c8be;
    ^CSignal caught, exiting!

    User cancel, exiting...
    shows lots of activity, In settings the best results I have had with receivers has been DVBT stick it is the next line that has got me, I have tried everything around avr_tcp with no luck. Any ideas

    Leave a comment:


  • PiRad108
    replied
    Okay after some research it seems power supply and current is critical and this sucker is hungry, the difference between 2 power supplies is here

    original power supply

    pi@raspberrypi:~ $ sudo rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    usb_claim_interface error -6
    Failed to open rtlsdr device #0.

    and a better power supply capable of delivering 3.5 amps

    sudo rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001

    Using device 0: Generic RTL2832U OEM
    Found Rafael Micro R820T tuner
    Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
    [R82XX] PLL not locked!
    Sampling at 2048000 S/s.
    No E4000 tuner found, aborting.

    so now it is a matter of getting fr24feed and RTL-SDR v3 to talk to each other

    Leave a comment:


  • PiRad108
    started a topic RTL-SDR

    RTL-SDR

    I have just received an RTL-SDR dongle from jetvision, having started with the jetvision DVB-T dongle. When I swap the dongles in my Rpi it the feed progresively stops until everything is in red and not receiving. I am wondering if I need to do a fresh install or if swapping dongles is an option
Working...
X