Announcement

Collapse
No announcement yet.

RASPBERRY PI DEBIAN Buster will not connect to planeplotter

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RASPBERRY PI DEBIAN Buster will not connect to planeplotter

    I can dump1090m on other computers on my home network also feeding piaware,radarbox24and fr24 , adbs exch no problems feeding but can not connect planeplotter to receive data. Anyone else having a problem?

  • #2
    dump1090 doesn't work properly on the RPi4 yet.

    Seems the RPi4 developers still need to figure out some USB problems.

    Also it seems dump1090-mutability does not compile on buster.

    Comment


    • #3
      it does compile running dup1090/gmap.html fine and loaded feeders to fr24,radarbox 24 adbs exchange and piaware all transmitting data...but can not couple to feed planeplotter.
      Running on a rasp pi 3 not a 4

      Comment


      • #4
        If that's the case I'm assuming your settings in plane plotter is for beast receiver over TCP. With the address the pis new IP:30005.?

        because if not, it's not going to work. The dump1090 options in plane plotter is for direct control

        Sent from my EML-L09 using Tapatalk
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          using rpi dump set to ipadd:30005 will not connect

          Comment


          • #6
            Originally posted by airmale View Post
            using rpi dump set to ipadd:30005 will not connect
            Please use more words. Don't understand

            You have multiple feeders?. They will be set to use beast localhost:30005?

            That data comes from dump1090


            Plane plotter on windows needs to be the same. You can't tell it to use dump1090 also.

            Sent from my EML-L09 using Tapatalk
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              (1) Carry-out steps 1 to 6 in screenshots 1 & 2.
              In screenshot 2, IP address is shown as 192.168.0.21, which is my Pi's IP address. Use your Pi's IP address instead.

              (2) Carry-out steps 1 to 5 in screenshots 3.

              (3) Press Start button to start display as shown in screenshot 4

              Screenshot -1
              planeplotter-input-setting-1.png


              Screenshot -2
              planeplotter-input-setting-2.png


              Screenshot -3
              planeplotter-input-setting-3.png


              Screenshot -4
              planeplotter-input-setting-4.png
              Last edited by abcd567; 2019-07-07, 18:37.

              Comment


              • #8
                i took a raspi 3b loaded dump1090 mutability (script load from abcd567)on a fresh image of BUSTER (rasbians newest )planeplotter will not connect. gmap.html works but i get fail to connect in planeplotter. ( setup planeplotter as per abcd567)..has anyone successfully set up dump1090 and planeplotter on BUSTER with ras pi 3b?

                Comment


                • #9
                  I just don't get it.

                  The webpage is active from PC - says the pi is not blocked from other computers.

                  It's feeding. So the feeders are connecting to dump1090 output just fine. And it is accepting

                  The OS should not make a difference as nothing else has changed.

                  So either you have too many connections and plane plotter is being blocked. Or you need to try change the data source to beast-tcp:30005 Like I do.

                  If there was a real problem the plane plotter help forum would likely be full of posts. And it is not currently

                  https://groups.io/g/planeplotter

                  Sent from my EML-L09 using Tapatalk
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    I believe planeplotter needs to be compiled from dump1090-mutability.
                    This compilation no longer works for Buster.

                    airmale: Showing actual error messages would be very helpful.
                    Also error messages along the install of planeplotter.

                    Comment


                    • #11
                      airmail:

                      Have you installed the planeplotter on Windows Computer, or on Raspberry Pi?

                      The method I have given in my post above is for planeplotter installed on Windows Computer.

                      Comment


                      • #12
                        Originally posted by wiedehopf View Post
                        I believe planeplotter needs to be compiled from dump1090-mutability.
                        This compilation no longer works for Buster.

                        airmale: Showing actual error messages would be very helpful.
                        Also error messages along the install of planeplotter.
                        I'll laugh if this ends up on wine like abcd has just asked.

                        Plane plotter is 'doze and non reliant on any particular build or compile. It has about 13 different feed types it can connect to (still sbs even.. unlike something nearby..) including Avr/beast outputs. Need to check my copy if it actually has bundled 1090 (windows again)

                        But sure has standard dump1090 tcp/network option too.

                        The main guides show building an old Mr version, but I should still work with remote beast format fine. Is how I've had mine going for 6yrs or so after I took it away from direct USB.

                        Sent from my EML-L09 using Tapatalk
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • #13
                          Ah then he probably just didn't add the --net option to the fr24feed settings.

                          Oh well in that case i'll just recommend this:
                          https://github.com/wiedehopf/adsb-wi...for-dump1090fa

                          No --net option you can fail to configure for that ...

                          Comment


                          • #14
                            OK So the planeplotter RTL/Dump1090 Options, attempts to connect to 31001 by default.

                            So unless whatever version is running on Pi opens that port or --net-ro-port 31001 is specified, it won't like it. But 30005/beast will be cause all the other feeds use that.


                            So my suggestion still stands. Tell it its beast TCP, get it from 30005 just like everything else is.
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment

                            Working...
                            X