Announcement

Collapse
No announcement yet.

MLAT does not work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MLAT does not work

    Hello,

    I am new to flightradar24 and wanted to use my flight aware equipment to send data to flightradar.
    I am using the raspberry 3 + Mode-S Beast board and I can not connect the MLAT.

    Am I doing something wrong or is the Mode-S Beast not compatible with the flight radar 24?

    Can anyone help me solve this?

    Thank you

  • #2
    I am having what I think is a similar problem. I am trying to feed with a Raspberry Pi and DVT stick, which has been working for about the last two years.

    It stopped feeding about a month ago and I came to the conclusion that the memory card had failed so I fitted a new sd card and re-installed everything. Now the system appears to be running, but it is not feeding FR24.

    I should point out that I don't fully understand what I am doing with a Pi, but having read and followed some of the posts on this forum I managed to get it running. It is running, but according to FR24, I am not online. I ran the fr24feed-status command and the following messages came up:
    OK. FR24 Feeder/decoder process running
    OK. FR24 Stats timestamp: time and date
    OK. FR24 Link: connected (TCP).
    OK. FR24 Radar: T-xxxxxx (my radar ID)
    OK. FR24 tracked AC.
    FAIL Receiver: down...failed!
    FAIL FR24 MLAT: not running ... failed!

    Can anybody tell me what I need to do to breath life back into my feed please?

    Comment


    • #3
      Originally posted by ptevos View Post
      Hello,

      I am new to flightradar24 and wanted to use my flight aware equipment to send data to flightradar.
      I am using the raspberry 3 + Mode-S Beast board and I can not connect the MLAT.

      Am I doing something wrong or is the Mode-S Beast not compatible with the flight radar 24?

      Can anyone help me solve this?

      Thank you
      Beast can do mlat, but it seems only not in USB mode. When I connect to the raw out of my PC doing the actual usb feeding from the pi via TCP it does..

      Sent from my XT1092 using Tapatalk
      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

      Comment


      • #4
        Help-me....

        Comment


        • #5
          Help you?

          Short answer. Beast = no MLAT on usb.

          So no. Not compatible

          Only time it is. Is using the method I described which requires more hardware and is a waste for just providing MLAT data when you cannot view it locally
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            There is nothing called "MLAT on USB". Please use correct terminology.

            The Beast is probably in AVR mode without timestamp. This is set by SW-commands or DIP-switches. Since the FR24 feeder does not set anything by software, the Beast needs to be correctly "dipped" to RAW (or timestamped AVR) to provide useful data for an mlat client.

            So, check your DIP switches.

            /M
            F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
            P-ESGR, P-ESIA, P-ESIB, P-ESGF
            mrmac (a) fastest.cc

            Comment


            • #7
              Terminology?

              On. Via. Connected to. When connection is USB. Little cable from beast to computer of USB type. Black USB a to b V1 connection.

              He asked a short question. He got short answer

              Sent from my XT1092 using Tapatalk
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

              Comment


              • #8
                ...Or rather, open ended without substance to know the right answer.

                'banana' or 'call police' may have also been a valid responce to 'help-me' if I really wanted to be a jackass

                Sent from my XT1092 using Tapatalk
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  But to follow up, a Reconfigure/check of Dip switches to ensure those related to Binary/Mlat tagging were all but correct for my original Planeplotter hosting options.. and still no change when windows feed configured to use Beast VIA USB connection

                  Infact it's back to listing it as an 'unknown' receiver when using the native client on the non-crashing 18-9 and new kill-client-connections-at-0700 19-15

                  [main][i]FR24 Feeder/Decoder
                  [main][i]Version: 1.0.19-15/generic
                  [main][i]Built on Feb 6 2018 10:20:41 (???/Windows/i386)
                  [main][i]Running on: Windows6.1
                  [main][i]Local IP(s):
                  [main][i]Copyright 2012-2018 Flightradar24 AB
                  [main][i]https://www.flightradar24.com
                  [main][i]Reader thread started
                  [main][i]Socket server started
                  [time][i]Synchronizing time via NTP
                  [master][i]Starting processing thread
                  [reader][i]Initializing reader
                  [httpd][i]Server started, listening on 0.0.0.0:8754
                  [bs][i]Initializing server
                  [reader][i]Connecting to unknown receiver via (COM4@3000000)
                  [bs][i]Starting server on 0.0.0.0:30003

                  MLAT running: N/A
                  The only conclusion I can come up with, is Dump1090 handles the AVR tagging when called for other receivers (like my test case with raw avr data connection from 2nd device ala Pi starting MLAT upload fine) and the uploader likes it, whereas the native reader they've coded in still does not over USB
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    Windows software has been discontinued.

                    Comment

                    Working...
                    X